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Brief Description
The Amadine app is designed for creating and editing vector graphics. Various raster effects
can be used in your designs as well.

You can save your work in either SVG, PDF or EPS formats that support vector graphics. You
can also export to raster formats such as TIFF, PNG and JPEG. Note that EPS is not supported
on macOS 14 Sonoma and later.

System Requirements

macOS 10.14 or later
150 MB of available disk space, or more, depending on your project complexity
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Licensing

Licensing Options

Different types of licenses can be purchased on different stores depending on your budget and
how long you plan to use the app. You can choose either a lifetime license or subscription plan.

For most of users, these stores are available:

The developer's online store (https://amadine.com/store/)
Mac App Store (macappstore://apps.apple.com/app/id1339198386?ls=1&mt=12)

The in-app store lets you purchase from one of those stores depending on from where you
downloaded the app.

The unlicensed copy of Amadine is fully operational. The only limitation is that some exporting
and printing options are not available. To eliminate this limitation, buy a lifetime license or start
a subscription.

Lifetime License

The app becomes licensed automatically if you purchase a Lifetime license. If the app has been
purchased from the developer or their affiliates, a license code will be sent to you in the
purchase confirmation email. You should enter the code in the app.

To enter the license code:

1. Open the application.
2. Bring up the License dialog by choosing Amadine > License… in the menu.
3. Enter your name and license code.

It is recommended that you keep the email containing your license code in a safe place in case
you reinstall or update the application.

If you need to redownload the app purchased on the Mac App Store, use the same user
account on the store. In the case the app doesn't show up as purchased, please follow the
Restore Purchases procedure provided by the Mac App Store.

Subscription

The subscription is available on the Mac App Store. You can subscribe on the Mac App Store
directly or via in-app purchase. To choose a subscription plan in the app, select Amadine >
Buy Amadine… in the main menu. The subscription can renew monthly or yearly depending on
your choice.

If you have an active subscription but the app indicates that it is not licensed, use the Restore
Purchases option in the store to unlock the app.

https://amadine.com/store/
macappstore://apps.apple.com/app/id1339198386?ls=1&mt=12


8

Cancel or Change a Subscription

1. Open the App Store app on your Mac.
2. Click on your name in the bottom-left corner (you must be signed in to continue).
3. Click Account Settings at the top.
4. In the Manage section, click Manage next to Subscriptions.
5. Click Edit and then:

Cancel a subscription: Click Cancel Subscription, confirm, then click Done.
Change a subscription: In the Options list, select a setting, then click Done.
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Updating the Program
To check for updates manually, choose Amadine > Check for Updates… in the menu.

To check for updates automatically, select the corresponding check box in the program
Preferences (Cmd-,).

To update the application downloaded from the Mac App Store, use the App Store application.
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Removing the Program
To completely remove the program and all of its components, delete the following files and
folders.

Program downloaded from the developer's site:
/Applications/Amadine.app

Program preferences:
~/Library/Preferences/com.belightsoft.Amadine.plist

Supporting files:
~/Library/Application Support/Amadine

Program downloaded from Mac App Store:
/Applications/Amadine.app
~/Library/Containers/com.belightsoft.Amadine

"~" means the user's Home folder.

Note that folders marked with a bold font can store user settings and other content. Don't
remove these folders if you are going to use customized materials in the future.

To access any path listed above, copy it. In Finder, choose Go > Go to Folder (Cmd-Shift-G).
Then paste the path into the edit box and press the Enter key.
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Technical Support
The developer of Amadine offers free technical support.

By email: 
support@belightsoft.com

Technical support form on the developer's website: 
https://amadine.com/support/

When reporting a problem, please make sure to specify:

The version of Amadine you are using.
The version of macOS on your computer.
Your actions that could have led to the problem.
If the problem persists, describe how to reproduce it.
When necessary, illustrate your report with screenshots (press Cmd-Shift-3 to save a
screenshot on your Desktop).

mailto:support@belightsoft.com
https://amadine.com/support/
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Useful Web Resources
Amadine Home - Information about Amadine, links to download, update, or buy the program.

Tutorials - Online video tutorials

Amadine on Facebook

Amadine on Instagram

Amadine on Pinterest

Amadine on X

Amadine on Reddit

Amadine on TikTok

BeLight Software - Learn about other BeLight Software products.

https://amadine.com/
https://amadine.com/tutorials/
https://www.facebook.com/amadineapp
https://www.instagram.com/amadine.app/
https://www.pinterest.com/belightsoftware/amadine/
https://x.com/AmadineApp
https://www.reddit.com/r/Amadine/
https://www.tiktok.com/@amadineapp
https://www.belightsoft.com/
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End User License Agreement
PLEASE READ THIS SOFTWARE LICENSE AGREEMENT ("LICENSE") CAREFULLY BEFORE
USING Amadine. BY USING Amadine, YOU ARE AGREEING TO BE BOUND BY THE TERMS
OF THIS LICENSE. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DO NOT
INSTALL AND/OR USE THE SOFTWARE.

Amadine made available through the Internet download or the Mac App Store Service and App
Store Service (collectively, "App Store Service(s)") are licensed, not sold, to you. Your license to
the Amadine product that you obtain through the Internet download or the App Store Service is
subject to your prior acceptance of this Amadine End User License Agreement. Your license to
Amadine under this End User License Agreement is granted by BeLight Software, Ltd
("Licensor"), not Apple. Licensor reserves all rights in and to Amadine not expressly granted to
you under this End User License Agreement.

BeLight Software, Ltd principal place of business is at:
Melnitskaya str. 26/2, office 305
Odesa 65005
Ukraine
info@belightsoft.com

1. Scope of License.

This license granted to you for Amadine by Licensor is limited to a non-transferable license to
use the Licensed Application on any Apple-branded products running iOS (including but not
limited to iPad, iPhone, and iPod touch) or macOS X, as applicable (collectively, "Apple
Device(s)") that you own or control and as permitted by the usage rules set forth in the Mac
App Store, App Store and iBookstore Terms and Conditions (the "Usage Rules"). This license
does not allow you to use Amadine on any Apple device that you do not own or control, and
you may not distribute or make Amadine available over a network in violation of the Usage
Rules. You may not rent, lease, lend, sell, redistribute or sublicense Amadine. You may not copy
(except as expressly permitted by this license and the Usage Rules), decompile, reverse-
engineer, disassemble, attempt to derive the source code of, modify or create derivative works
of Amadine, any updates, or any part thereof (except as and only to the extent that any
foregoing restriction is prohibited by applicable law or to the extent as may be permitted by the
licensing terms governing use of any open-sourced components included with Amadine). Any
attempt to do so is a violation of the rights of the Licensor and its licensors. If you breach this
restriction, you may be subject to prosecution and damages.

Amadine may provide for certain additional content and features available through in-app
purchase(s) ("Purchased Content"). The terms of this License shall govern all such Purchased
Content.

If you licensed Amadine on a subscription basis, Licensor grants to you a non-exclusive,
personal, limited right to use and access Amadine features for the subscription period for which

mailto:info@belightsoft.com
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you have paid the applicable subscription fees, subject to the terms of this License Agreement
and any other terms and conditions accompanying Amadine. You may have the option to
extend your subscription or convert to a perpetual license. If you extend your subscription, you
may continue using Amadine until the end of your extended subscription period. After the
expiration of your subscription, paid features of Amadine will become unavailable.

The terms of this license will govern any upgrades provided by Licensor that replace and/or
supplement the original Amadine, unless such upgrade is accompanied by a separate license in
which case the terms of that license will govern.

2. Licensor’s Rights.

You acknowledge and agree that the Software and Documentation is the proprietary, published
and unpublished property of Licensor. You further acknowledge and agree that all rights, title
and interest in and to the Software and Documentation are and shall remain with Licensor. This
license conveys to You the right to install and use the Software and Documentation in
accordance with the terms of this license. All rights not expressly granted here are reserved by
BeLight Software. The Licensor will not transmit your personal information to any third party
without your express consent.

3. Termination.

This license is effective upon installing the software on any machine, and shall continue until
terminated by you or Licensor. Your rights under this license will terminate automatically without
notice from the Licensor if you fail to comply with any term(s) of this license. Upon termination
of the license, you shall cease all use of Amadine and destroy all copies, full or partial, of
Amadine.

If available and you licensed additional features for Amadine on a subscription basis, Amadine
subscription will be automatically renewed upon the expiration of the then current term, unless
you log into your account and cancel your subscription prior to the expiration date. Fees at the
time of automatic renewals will be at the then-current rates for such Amadine features.

4. Maintenance and Support.

Licensor is solely responsible for providing any maintenance and support services with respect
to Amadine. You acknowledge that Apple has no obligation whatsoever to furnish any
maintenance and support services with respect to Amadine.

5. Third Party Beneficiary.

You agree that Licensor's official resellers, Apple, and Apple''s subsidiaries, are third-party
beneficiaries of Amadine and that, upon the end-user's acceptance of the terms and conditions
of the END USER LICENSE AGREEMENT, Licensor resellers and Apple will have the right (and
will be deemed to have accepted the right) to enforce the END USER LICENSE AGREEMENT
against the end user as a third party beneficiary thereof.

6. Third-Party Materials.
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The Licensed Application may enable access to Apple, Licensor and/or third-party services and
websites (collectively and individually, "Services"). Use of the Services requires Internet access
and use of certain Services requires you to accept additional terms.

By using this software in connection with an iTunes Store account, you agree to the latest
iTunes Store Terms and Conditions and Usage Rules, which you may access and review at:
https://www.apple.com/legal/internet-services/itunes/

You may NOT resell, sublicense or otherwise make available the Software Content for use or
distribution separately or detached from a product or Web page. You may NOT a) create
scandalous, obscene, defamatory or immoral works using the Software Content nor use the
Software Content for any other purpose prohibited by law; b) use or permit the use of the
Software Content or any part thereof as a trademark or service mark, or claim any proprietary
rights of any sort in the Software Content or any part thereof; c) use the Software Content in
electronic format, online or in multimedia applications unless the Software Content is
incorporated for viewing purposes only, and no permission is given to download and/or save
the Software Content for any reason; d) use any Software Content except as expressly
permitted by this License; and e) use the Software Content related to identifiable individuals,
products or entities for any commercial purpose or in a manner that suggests their association
with or endorsement of any product or service.

Certain Services may display, include or make available content, data, information, applications
or materials from third parties ("Third-Party Materials") or provide links to certain third-party
web sites. By using the Services, you acknowledge and agree that Apple and Licensor are not
responsible for examining or evaluating the content, accuracy, completeness, timeliness,
validity, copyright compliance, legality, decency, quality or any other aspect of such Third-Party
Materials or websites. Apple and Licensor, their officers, affiliates and subsidiaries do not
warrant, endorse or assume and will not have any liability or responsibility to you or any other
person for any Third-Party Services, Third-Party Materials or web sites or any other materials,
products, or services of third parties. Third-Party Materials and links to other websites are
provided solely as a convenience to you.

7. Intellectual Property Rights.

Licensor, not Apple, shall indemnify, hold harmless and, at user request, defend user from and
against any and all claims, damages, losses and liabilities that are attributable to such claim, of
which Amadine infringes any third-party intellectual property right; provided that: (a) user gives
Licensor prompt notice in writing of any such suit and permits Licensor, through counsel of its
choice, to answer the charge of infringement and defend such claim or suit; (b) user provides
Licensor information, assistance and authority to enable Licensor to defend such suit; and (c)
Licensor shall not be responsible for any settlement made by user without Licensor's prior
written permission.

8. NO WARRANTY: YOU EXPRESSLY ACKNOWLEDGE AND AGREE THAT USE OF Amadine IS
AT YOUR SOLE RISK AND THAT THE ENTIRE RISK AS TO SATISFACTORY QUALITY,
PERFORMANCE, ACCURACY AND EFFORT IS WITH YOU. TO THE MAXIMUM EXTENT

https://www.apple.com/legal/internet-services/itunes/
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PERMITTED BY APPLICABLE LAW, Amadine AND ANY SERVICES PERFORMED OR
PROVIDED BY Amadine ("SERVICES") ARE PROVIDED "AS IS" AND "AS AVAILABLE," WITH
ALL FAULTS AND WITHOUT WARRANTY OF ANY KIND, AND LICENSOR HEREBY
DISCLAIMS ALL WARRANTIES AND CONDITIONS WITH RESPECT TO Amadine AND ANY
SERVICES, EITHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES AND/OR CONDITIONS OF MERCHANTABILITY, OF
SATISFACTORY QUALITY, OF FITNESS FOR A PARTICULAR PURPOSE, OF ACCURACY, OF
QUIET ENJOYMENT AND OF NON-INFRINGEMENT OF THIRD-PARTY RIGHTS. LICENSOR
DOES NOT WARRANT AGAINST INTERFERENCE WITH YOUR ENJOYMENT OF Amadine,
THAT THE FUNCTIONS CONTAINED IN OR SERVICES PERFORMED OR PROVIDED BY
Amadine WILL MEET YOUR REQUIREMENTS, THAT THE OPERATION OF Amadine OR
SERVICES WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN Amadine OR
SERVICES WILL BE CORRECTED. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN
BY LICENSOR OR ITS AUTHORIZED REPRESENTATIVE SHALL CREATE A WARRANTY.
SHOULD Amadine OR SERVICES PROVE DEFECTIVE, YOU ASSUME THE ENTIRE COST OF
ALL NECESSARY SERVICING, REPAIR OR CORRECTION. SOME JURISDICTIONS DO NOT
ALLOW THE EXCLUSION OF IMPLIED WARRANTIES OR LIMITATIONS ON APPLICABLE
STATUTORY RIGHTS OF A CONSUMER, SO THE ABOVE EXCLUSION AND LIMITATIONS MAY
NOT APPLY TO YOU.

9. Product Claims.

You acknowledge that Licensor, not Apple, is responsible for addressing any claims of the end
user or any third party relating to the Licensed Application or the end-user's possession and/or
use of that Licensed Application, including, but not limited to: (i) product liability claims; (ii) any
claim that the Licensed Application fails to conform to any applicable legal or regulatory
requirement; and (iii) claims arising under consumer protection or similar legislation.

10. Limitation of Liability.

TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT SHALL LICENSOR BE LIABLE
FOR PERSONAL INJURY OR ANY INCIDENTAL, SPECIAL, INDIRECT OR CONSEQUENTIAL
DAMAGES WHATSOEVER, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF
PROFITS, LOSS OF DATA, BUSINESS INTERRUPTION, OR ANY OTHER COMMERCIAL
DAMAGES OR LOSSES ARISING OUT OF OR RELATED TO YOUR USE OR INABILITY TO USE
Amadine, HOWEVER CAUSED, REGARDLESS OF THE THEORY OF LIABILITY (CONTRACT,
TORT OR OTHERWISE) AND EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES. SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OF LIABILITY
FOR PERSONAL INJURY, OR OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS
LIMITATION MAY NOT APPLY TO YOU. In no event shall Licensor's total liability to you for all
damages (other than as may be required by applicable law in cases involving personal injury)
exceed the amount of fifty dollars ($50.00). The foregoing limitations will apply even if the above
stated remedy fails in its essential purpose.

Licensor provides a thirty (30) day money-back guarantee on Amadine that was purchased
directly from Licensor. If, during this period, you are dissatisfied with the Software for any
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reason, Licensor will refund your money if you stop using and destroy all copies of the Software
within thirty (30) days of the date of the original purchase.

If Amadine was purchased from App Store Service(s), you may notify Apple of any failure to
conform to any applicable warranty, and Apple will refund the purchase price for Amadine;
Apple will have no other warranty obligation whatsoever with respect to Amadine.

11. You may not use or otherwise export or re-export Amadine except as authorized by United
States law and the laws of the jurisdiction in which Amadine was obtained. In particular, but
without limitation, Amadine may not be exported or re-exported (a) into any U.S.-embargoed
countries or (b) to anyone on the U.S. Treasury Department's Specially Designated Nationals
List or the U.S. Department of Commerce Denied Persons List or Entity List. By using Amadine,
you represent and warrant that you are not located in any such country or on any such list. You
also agree that you will not use these products for any purpose prohibited by United States law,
including, without limitation, the development, design, manufacture or production of nuclear,
missile or chemical or biological weapons.

12. Amadine and related documentation are "Commercial Items", as that term is defined at 48
C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer
Software Documentation", as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202,
as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §227.7202-1 through 227.7202-4,
as applicable, the Commercial Computer Software and Commercial Computer Software
Documentation are being licensed to U.S. Government end users (a) only as Commercial Items
and (b) with only those rights as are granted to all other end users pursuant to the terms and
conditions herein. Unpublished rights are reserved under the copyright laws of the United
States.

13. Complete Agreement; Governing Language. This License constitutes the entire agreement
between you and Licensor relating to the use of Amadine and supersedes all prior or
contemporaneous understandings regarding such subject matter. No amendment to or
modification of this License will be binding unless in writing and signed by Licensor. Any
translation of this License is done for local requirements, and, in the event of a dispute between
the English and any non-English versions, the English version of this License shall govern, to
the extent not prohibited by local law in your jurisdiction.

14. The laws of the State of California, excluding its conflicts of law rules, govern this license
and your use of Amadine. Your use of Amadine may also be subject to other local, state,
national, or international laws.

15. Severability.

Should any term of this license be declared void or unenforceable by any court of competent
jurisdiction, such declaration shall have no effect on the remaining terms hereof.

If you have any questions regarding this Agreement or if you wish to request any information
from the Licensor, please use the address and contact information included with this product to
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contact the Licensor, or by email:
info@belightsoft.com

© 2003-2025 BeLight Software, Ltd. All Rights Reserved. BeLight Software and Amadine are
trademarks of BeLight Software, Ltd.

mailto:info@belightsoft.com
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BeLight Software Privacy Statement
Your privacy is important to us. This Privacy Statement covers how we collect, use, disclose,
transfer and store your information.

Collection and Use of Personal Information

Personal information is data that can be used to identify or contact a single person.

You may be asked to provide your personal information any time you are in contact with
BeLight Software. We may share and use this information consistent with this Privacy
Statement. We may also combine it with other information to provide and improve our
products, services, content and advertising. You are not required to provide the personal
information that we have requested, but, if you choose not to do so, in many cases, we will not
be able to provide you with our products or services or respond to any queries you may have.

What personal information we collect:

When you purchase a product, download software or an update, register for company or
product newsletters, contact us or participate in an online survey, we may collect a variety of
information, including your name, mailing address, phone number and email address.

How we use your personal information:

The personal information we collect allows us to keep you posted on BeLight Software's
latest product announcements, software updates and upcoming events. If you don't want
to be on our mailing list, you can opt out any time by emailing us at:
news@belightsoft.com
We also use personal information to help us create, develop, operate, deliver and improve
upon our products, services, content and advertising, as well as for loss prevention
purposes.
We may use your personal information to verify identity, assist with identification of users
and determine appropriate services.
From time to time, we may use your personal information to send important notices, such
as communications about purchases and changes to our terms, conditions and policies.
Because this information is important to your interaction with BeLight Software, you may
not opt out of receiving these communications.
We may also use personal information for internal purposes, such as auditing, data
analysis and research to improve BeLight Software products, services and customer
communications.
If you enter into a sweepstakes, contest or similar promotion, we may use the information
you provide to administer those programs.

mailto:news@belightsoft.com
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Collection and Use of Non-personal Information

We also collect data in a form that does not, on its own, permit direct association with any
specific individual. We may collect, use, transfer and disclose non-personal information for any
purpose. The following are some examples of non-personal information that we collect and
how we may use it:

We may collect information such as occupation, language, zip code, area code, unique
device identifier, referrer URL, location and the time zone where a BeLight Software
product is used so that we can better understand customer behavior and improve our
products, services and advertising.
We may collect information regarding customer activities on our websites and from our
other products and services. This information is aggregated and used to help us provide
more useful information to our customers and to understand which parts of our website,
products and services are of most interest. Aggregated data is considered non-personal
information for the purposes of this Privacy Statement.

If we do combine non-personal information with personal information, the combined
information will be treated as personal information for as long as it remains combined.

Cookies and Other Technologies

BeLight Software websites, online services, interactive applications, email messages and
advertisements may use "cookies" and other technologies, such as pixel tags and web
beacons. These technologies help us better understand user behavior, tell us which parts of our
websites people have visited and facilitate and measure the effectiveness of advertisements
and web searches. We treat information collected by cookies and other technologies as non-
personal information. However, to the extent that Internet Protocol (IP) addresses or similar
identifiers are considered personal information by local law, we also treat these identifiers as
personal information. Similarly, to the extent that non-personal information is combined with
personal information, we treat the combined information as personal information for the
purposes of this Privacy Statement.

If you want to disable cookies, and you're using the Safari web browser, go to Safari
Preferences and then to the Privacy pane to manage your preferences. For other browsers,
check with your provider to find out how to disable cookies. Please note that certain features of
the BeLight Software website will not be available once cookies are disabled.

We use this information to understand and analyze trends, to administer the site, to learn about
user behavior on the site, to improve our product and services and to gather demographic
information about our user base as a whole. BeLight Software may use this information in our
marketing and advertising services.

In some of our email messages, we use a "click-through URL" linked to content on the BeLight
Software website. When customers click one of these URLs, they pass through a separate web
server before arriving at the destination page on our website. We track this click-through data
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to help us determine interest in particular topics and measure the effectiveness of our customer
communications. If you prefer not to be tracked in this way, you should not click text or graphic
links in the email messages. Pixel tags enable us to send email messages in a format
customers can read, and they tell us whether mail has been opened. We may use this
information to reduce or eliminate messages sent to customers.

Disclosure to Third Parties

At times, BeLight Software may make certain personal information available to strategic
partners that work with BeLight Software to provide products and services or that help BeLight
Software market to customers. Personal information will only be shared by BeLight Software to
provide or improve our products, services and advertising; it will not be shared with third parties
for their marketing purposes.

Service Providers

BeLight Software shares personal information with companies that provide services such as
information processing, fulfilling customer orders, delivering products to you, managing and
enhancing customer data, providing customer service, assessing your interest in our products
and services and conducting customer research or satisfaction surveys. These companies are
obligated to protect your information.

Services we use and their respective privacy policies:

Google Analytics is used to analyze website visitors' behavior and activity:
https://policies.google.com/privacy

Vimeo is used for video content playback:
https://vimeo.com/privacy

FastSpring is used for online order processing:
https://fastspring.com/privacy/

Paddle is used for online order processing:
https://paddle.com/privacy/

Others

It may be necessary - by law, legal process, litigation and/or requests from public and
governmental authorities within or outside your country of residence - for BeLight Software to
disclose your personal information. We may also disclose information about you if we
determine that disclosure is reasonably necessary to enforce our terms and conditions or
protect our operations or users. Additionally, in the event of a reorganization, merger or sale, we
may transfer any and all personal information we collect to the relevant third party.

https://policies.google.com/privacy
https://vimeo.com/privacy
https://fastspring.com/privacy/
https://paddle.com/privacy/
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Protection of Personal Information

BeLight Software takes the security of your personal information very seriously. BeLight
Software online services, such as the BeLight Software website store and embedded into
software store, protect your personal information during transit using encryption such as
Transport Layer Security (TLS). When your personal data is stored by BeLight Software, we use
computer systems with limited access and encrypted storage.

When you use some BeLight Software products, services or applications, or post on a BeLight
Software forum, chat room or social networking service, the personal information and content
you share is visible to other users and can be read, collected or used by them. In these
instances, you are responsible for the personal information you choose to share or submit.

Integrity and Retention of Personal Information

BeLight Software will retain your personal information for the period necessary to fulfill the
purposes outlined in this Privacy Statement unless a longer retention period is required or
permitted by law.

Access to Personal Information

Access, correction or deletion requests can be made via email at:
sales@belightsoft.com

Children

If we learn that we have collected the personal information of a child under 13, or equivalent
minimum age depending on jurisdiction, we will take steps to delete the information as soon as
possible.

Parents can contact us via email at:
sales@belightsoft.com

Third-party Sites and Services

BeLight Software websites, products, applications and services may contain links to third-party
websites, products and services. Our products and services may also use or offer products or
services from third parties. Information collected by third parties, which may include such
things as location data or contact details, is governed by their privacy practices. We encourage
you to learn about the privacy practices of those third parties.

Commitment to Your Privacy

To ensure that your personal information is secure, we communicate our privacy and security
guidelines to BeLight Software employees and strictly enforce privacy safeguards within the
company.

mailto:sales@belightsoft.com
mailto:sales@belightsoft.com
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Questions

If you have any questions or concerns about the BeLight Software Privacy Statement or data
processing, or if you would like to make a complaint about a possible breach of local privacy
laws, please contact us at:
sales@belightsoft.com

BeLight Software may update its Privacy Statement from time to time. When we change the
policy in a material way, a notice will be posted on our website along with the updated Privacy
Statement.

mailto:sales@belightsoft.com
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Workspace
Once you create or open a document, the program displays it in a working environment, which
is called the "workspace". By default, the workspace consists of the main window with your
document and several panels. You can customize the interface as you like.

The main elements of the workspace are the document window, Tools panel and Control panel.

1 - Tabs of open documents in the main window.

2 - Control panel. Some tools and selected objects show additional options in this panel. For
example, the Text tool shows here the font, size and other settings. If you select a rounded
rectangle, the panel will display its corner radius.

3 - Tools panel.

4 - The canvas in the main window. This is the area in which you edit your document.

5 - A Sheet is a part of the canvas. If you are not familiar with graphic editors, you can treat a
sheet as a page or printable area.

6 - Panels let you adjust the properties of different objects or an open document. There are four
panels in the program: Appearance, Geometry, Layers and Sheets. The Managing Windows
and Panels section explains how to customize the panels.

Windows and panels of your workspace use the same measurement unit that was selected
when you created a new document. Several documents that are open at the same time can
have different measurement units. You can change the measurement unit in the main window.
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Minimalistic Interface

In order to preview your design with minimum distraction, hide most of the interface elements
using the Window > Hide UI in the main menu, or press the Tab key. Note that this shortcut
wouldn't work while you are editing text or changing the property value in a text field.
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The Main Window
The main window is where you preview and edit documents. We can also call it "document
window" in this documentation.

1 - Measurement units. To change the measurement unit, click on the current one and choose a
new option from the list. The rulers should be displayed to have this button on the screen.
The last item in the drop-down list lets you choose between Global Rulers and Active Sheet
Rulers. The Active Sheet Rulers option sets the zero point of the rulers to the top left corner of
the active sheet. As soon as you activate another sheet, the corner of this sheet will define the
new location of the zero. If you select Global Rulers, the zero point of the rulers will be static.

2 - Grid. To show or hide the grid, use the View > Grid menu command. For more details, read
the Grid and Guide Lines sections.

3 and 4 - Vertical and horizontal rulers.

5 - Canvas

6 and 7 - Sheets

Rulers

The vertical and horizontal rulers are displayed by default when you create a new document. To
hide or show the rulers, use the View > Rulers menu command.

The measurement units button at the top left corner of the main window appears and
disappears together with the rulers. To select a measurement unit, click on the button and
choose a new measurement unit.
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Canvas and Sheets

The canvas is the space where you can place and edit elements of your design.

Although objects can be placed anywhere on the canvas, your design should fit a sheet. You
can think about sheets as an equivalent to pages in a text editor. A sheet represents a printable
area. Objects placed outside any sheet will not be printed or exported. If a part of an object is
located on a sheet, and the rest is on the canvas, the boundary of the sheet will work as the
crop area.

There can be one or multiple sheets on the canvas and, consequently, in your project. This lets
you save several related or completely separate designs as a single document.

How to manage sheets and arrange them over the canvas is described in the Sheets section.

Zooming In and Out

There are several ways to change the scale of the open document:

Commands at the top of the View menu let you zoom in or out through the predefined
steps or fit the current sheet or all of them to the main window.
The Zoom tool in the Tools panel lets you fit a portion of your design to the main window.
Activate the tool. Then click and drag the mouse cursor to indicate the area you want to
enlarge. In order to zoom out, click on the canvas with the Zoom tool holding down the
Option key. The point at which you click will be centered in the main window.
Zoom controls in the Control panel let you zoom in or out in steps, select one of
predefined options in the drop-down list, or type in a value you want into the edit box.

Use the mouse scroll wheel together with the Option key.

Position the Artwork within the View Area

At high levels of zoom, your design may not fit the view area completely. In such cases, you can
use the horizontal and vertical scroll bars to access any part of the artwork.

Another way to do that is to use the Hand tool. It is more precise than the scroll bars. It also
lets you move the artwork vertically and horizontally at the same time. Before using this tool,
make sure that you are not in the text editing mode or changing the value of any edit box.
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To move the artwork with the Hand tool, press and hold the Space key. The mouse pointer will
turn into a hand icon. Drag the artwork. To deactivate the tool, release the Space key. The
Hand tool can also be activated using the middle key of the mouse.

Preview Modes

The canvas can display your document in one of the following preview modes: normal, Outline,
Pixel Preview or Retina Pixel Preview.

To switch between the modes, use the View menu. In fact, there are three options in the menu.
When all of them are off, the program works in the normal mode, which is the default.

Normal Mode

The normal mode is supposed to be used as the main mode for editing vector paths, arranging
objects, etc. In this mode, the program displays all object features such as the stroke, fill and
effects.

Outline Mode

The Outline mode displays object outlines as paths. No Stroke, Brush, Fill or other features are
visible. This mode might be useful when you need to edit paths. Since graphics are displayed in
a very simplified way in the Outline mode, the program should redraw your design faster than in
the normal mode.
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Pixel Preview Mode

The Pixel Preview mode lets you see how your artwork may look after being rasterized (e.g., if
you export it to a JPEG file). In this mode, the program simulates rasterization. All vector-based
graphic elements in your document remain editable.

The program generates the pixel grid based on the size of the current sheet. For example, if the
sheet is 100x100px, your artwork will be presented by 100 pixels horizontally and 100 pixels
vertically.

To hide or show the pixel grid, use the Guides and Grid section of the Preferences dialog.

Retina Pixel Preview Mode

The Retina Pixel Preview mode is identical to the Pixel Preview mode, but it will display the
artwork with doubled resolution. In other words, if the sheet is 100x100px, your artwork will be
presented by 200 pixels horizontally and 200 pixels vertically.



30

The Tools Panel
Tools in the Tools panel are used to select, create and manipulate objects. Some tools have
additional options that can be displayed in the Control panel.

Tools in the panel can be arranged in one or two columns. Clicking on a small triangle in the top
left corner of the panel switches from one mode to another. You can customize the workspace
so that all panels, including the Tools panel, are attached to the main window. In this mode, the
panel can arrange tools in one or two columns automatically depending on the main window
size.

To activate a tool, click on its icon in the panel.

 - Move Tool: selects, moves and resizes objects

 - Selection Tool: selects and manipulates path elements

 - Lasso Tool: selects entire objects, anchor points or path segments by outlining them

 - Pen Tool: creates paths with curves or straight lines

 - Draw Tool: draws freehand lines

 - Path Width Tool: creates strokes with variable widths

 - Gradient Tool: adds and adjusts gradients

 - Text Tool: adds text boxes and activates the text editing mode

 - Knife Tool: cuts paths or objects
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 - Scissors Tool: cuts paths at any point you click with the tool

 - Eraser Tool: erases a portion of an object

 - Fusion Tool: removes segments and merges shapes

 - Eyedropper Tool: copies appearance attributes from one object to another

 - Zoom Tool: zooms in or out of the canvas

 - Free Transform Tool: moves, rotates, scales or skews objects

 - Rectangle Tool: creates rectangles

 - Rounded Rectangle Tool: creates rectangles with rounded corners

 - Ellipse Tool: creates ellipses and circles

 - Polygon Tool: creates polygons with a customizable number of sides

 - Star Tool: creates stars with a customizable number of points

 - Line Tool: draws straight lines

 - Arc Tool: creates arcs and sectors

 - Sheets Tool: adds or deletes sheets and adjusts their size and position
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The Control Panel
The Control panel, located right below the main menu, displays the settings of the currently
activated tool (if it has those). The settings are described together with tools in the dedicated
sections.

The middle of the panel lets you manipulate selected objects (e.g., align or adjust spaces). The
right side of the panel is occupied by controls that set up the current document and bring up
the libraries.

The rightmost group of controls lets you zoom in or out. You can type in the required scale,
select it from a drop-down menu or simply click the minus or plus buttons.

The button with an eye icon opens the drop-down menu, which helps you set up the work area
and current document.

Outline Preview: Toggles the way objects are displayed on the canvas. You can either show
objects normally or as a wireframe (with no stroke, fill, etc.). For more details, read the Preview
Modes section.

Pixel Preview: Displays the artwork as raster graphics.

Retina Preview: Displays the artwork as raster graphics simulating Retina screen resolution.

Smart Guides: Shows smart guides when you move or resize objects.

Grid: Turns the grid on and off.

Snap to Grid: Allows the program to snap objects to the grid when you move them.
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Snap to Pixel: Snap objects to the pixel grid. This makes sense when you need to save your
vector graphics in a raster file format. For more details, read Align Objects to the Pixel Grid.

Rulers: Shows or hides the rulers.

Document Setup: Opens the Document Setup dialog.
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Managing Windows and Panels
By default, the program interface consists of a single main window that includes everything.
Alternatively, you can switch to the mode with floating panels and windows. This allows you to
customize the workspace. You can rearrange most of its elements and also show or hide
certain panels.

The Main Window

The main window (we also call it "document window" in this documentation) has the title bar
that displays the current document name. In order to move the window around, drag the title
bar with the mouse.

You can resize the main window by dragging any of the window sides. To do this, move the
mouse cursor across the window edge. When the cursor turns into a double-sided arrow, click
and drag.

By default, all panels, toolbar and open documents reside inside the main window. You can
move and resize them together. Each open document is represented as a tab below the Control
bar. Document windows and panels can also be separated from each other by using the
Window > Detach Panels menu command.

Panels

There are four panels in the program: Appearance, Geometry, Layers and Sheets. You can
manipulate them individually.

In order to open or close a panel, click on its name in the Window menu.

When the panels are in the floating mode, you can attach one panel to the bottom of another.
Then these panels can be moved together. To detach a panel, just move it aside.

If panels are attached to the main window, you can rearrange them. To do this, move a panel up
or down to place it above or below another panel.

All panels have common controls.
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1 - Close the panel.

2 - The name of the panel.

3 - Collapse or expand the panel. When it is collapsed, only the panel's title bar is visible.

4 - The title bar. To move the panel, drag the title bar using the mouse.

5 - Drag the bottom edge of the panel in order to make it taller or shorter. You can resize panels
that display lists of objects or properties to see more or fewer items at a time. Items that are not
visible can be accessed using the scroll bar.

Tools Panel

The Tools panel can display tools in one or two columns. You can click on a triangle in the top
left corner to switch between these two modes. When the panel is attached to the main
window, it can select the one- or two-column mode automatically depending on how much
vertical space is available.
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Program Settings
To open program settings, use the Amadine > Preferences… menu command.

General

UI Theme: Allows you to select either Light or Dark UI theme manually. If you choose the
System option, the theme will be set up automatically.

Tolerance: Sets the tolerance for selection and drawing tools. Greater values make it easier to
click on a path or anchor point in order to select or grab it.

Draw/insert above the selection: Places an object right above the currently selected one in
the stack of objects (see the Layers panel). When the option is deactivated, an object is placed
atop of all of the objects within the current layer.

Skip image fill on creation: Turns off the image fill when a new object is created. Otherwise
the image used to fill one object will be used by default to fill following new objects until you
choose a different fill type.

Layers panel focus on selection: Scrolls the Layers panel up or down to make the name of an
object visible once it is selected on the canvas.

Allow filling: Allows the Draw tool to apply the Fill property to the path while you are drawing
it. This requires that you enable a Fill property in the Appearance panel.

Allow to continue the Path: Enables the possibility to continue drawing a selected path with
the Draw tool.
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Check for updates daily: Allows the program to check for software updates automatically. To
check for updates manually, choose Amadine > Check for Updates… This option is not
available in the application purchased on the Mac App Store.

Guides and Grid

Settings in this section define the colors of guide lines, smart guides and grid. There is also an
option to show or hide the pixel grid when the program is working in the Pixel Preview mode.

To set a new color, choose a predefined one from the drop-down menu, or click on a color
circle and use the Color pane.
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Menus
Amadine
File
Edit
Modify
Layer
Text
Select
View
Window
Help

The "Amadine" Menu

About Amadine Display the dialog with information about the program.

Check for Updates… Check for the latest update on the Internet. (Not available in the
application purchased on the Mac App Store.)

Preferences… (Cmd-
",") Bring up the program preferences dialog.

License… Open the registration dialog box. (Not available in the application
purchased on the Mac App Store.)

Buy Amadine… Open the store where you can buy the app or restore your earlier
purchase.

Quit Amadine (Cmd-
Q) Quit the application.

The "File" Menu

New (Cmd-N) Create a new document.

Open… (Cmd-O) Open a document.

Open Recent > Open one of the recently edited documents.

Close (Cmd-W) Close the open document.

Close Window (Cmd-
Shift-W) Close the open window.

Close All (Cmd-Opt-
W) Close all open windows.

Save… (Cmd-S) Save the current document.
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Duplicate (Cmd-Shift-
S) Create a copy of the current document.

Save As… (Cmd-
Shift-Opt-S) Save the current document to a new file.

Rename… Rename the current document.

Move To… Move the current document to another location.

Revert To > Cancel all of the changes in the current document and restore an
earlier version of the document.

Import… Import a graphic file to the current document.

Export… (Cmd-Opt-
E) Export the current document to a graphic file.

Document Setup…
(Cmd-Shift-P)

Open the Document Setup dialog to verify or set up measurement
units, grid and other properties.

Print… (Cmd-P) Bring up the standard Print dialog.

The "Edit" Menu

Undo (Cmd-Z) Reverse the last operation that you performed.

Redo (Cmd-Shift-Z) Reverse the last Undo operation.

Cut (Cmd-X) Cut selected object(s) to the Clipboard.

Copy (Cmd-C) Copy selected object(s) to the Clipboard.

Paste (Cmd-V)
Paste the contents of the Clipboard into the document. A pasted
object can appear either above all of the objects in the active layer or
above a currently selected object depending on the Draw/insert
above the selection option.

Paste in Place (Cmd-
Shift-V)

Paste the contents of the Clipboard into the document at the same
location as the original object. A pasted object can appear either
above all of the objects in the active layer or above a currently
selected object depending on the Draw/insert above the selection
option.

Duplicate (Cmd-D) Duplicate selected object(s).

Delete (Delete) Delete selected object(s).

Copy Style (Cmd-
Opt-C) Copy the style of a selected object.

Paste Style (Cmd-
Opt-V) Apply the style, copied to the Clipboard, to a selected object.
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Spelling and
Grammar > Check spelling and grammar.

Transformations > Turn a selected piece of text to all capitals, all lower case, or
capitalize it.

Speech > The app can read text in the text editor aloud. Commands in this
menu start and stop reading.

Start Dictation… (fn
fn) Dictate your text.

Emoji & Symbols
(Cmd-Ctrl-Space) Open the Emoji & Symbols panel.

The "Modify" Menu

Group (Cmd-G) Group selected objects.

Ungroup (Cmd-Shift-
G) Ungroup a selected group.

Ungroup All Ungroup a selected group. All nested groups to the full extent will be
ungrouped.

Recolor… Bring up the Recolor dialog.

Transform… Bring up the Transform dialog.

Transform Again
(Cmd-J)

Apply the same transformation that was set up and applied using the
Transform dialog the last time.

Reset Bounding Box
Reset the boundary of a selected object. For example, once you
rotate an object, its boundary turns accordingly. The command
creates a new boundary whose top and bottom are horizontal.

Arrange > Bring to
Front (Cmd-Shift-]) Place a selected object in front of other objects.

Arrange > Bring
Forward (Cmd-])

Move a selected object by one object forward within the object
stacking order.

Arrange > Send to
Back (Cmd-Shift-[) Place a selected object behind other objects.

Arrange > Send
Backward (Cmd-[)

Move a selected object by one object backward within the object
stacking order.

Align > Align edges or centers of selected objects.

Distribute > Create equal distance between edges or centers of selected objects.
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Path > Explode Split a selected path into separate segments keeping the result
looking as the original path.

Path > Join Join two selected paths to create a single path. A new segment can
be added to fill the gap between the original paths.

Path > Open Open a closed path. This command disconnects the two ends of the
path. No path segments will be removed.

Path > Close Connect the ends of a selected path. A new segment can be added
to fill the gap between the ends of the original path.

Path > Reverse Reverse the direction of the path. This command can move an
arrowhead from one end of the path to another.

Path > Simplify… Simplify a path by reducing the number of points it consists of.

Fill Mode > Use Non-
Zero Winding Fill Rule Fill a path that crosses itself so that no holes are created.

Fill Mode > Use
Even-Odd Fill Rule

Fill a path that crosses itself so that holes are created according to
the even-odd rule.

Combine > Union
(Cmd-Ctrl-U) Combine selected objects using the Union operation.

Combine > Intersect
(Cmd-Ctrl-T) Combine selected objects using the Intersect operation.

Combine > Subtract
(Cmd-Ctrl-S) Combine selected objects using the Subtract operation.

Combine > Exclude
(Cmd-Ctrl-X) Combine selected objects using the Exclude operation.

Combine > Divide
(Cmd-Ctrl-V) Divide selected objects into parts.

Combine > Release Reverse a combine operation in order to turn a combined object into
the original ones.

Expand Split an object into several parts that look together as the original.

Expand Selected
Corners

Permanently apply the result of the corner rounding tool. The
adjustable rounded corner will be replaced with a path segment.

Make Compound
Path Turn selected paths into a compound path.

Release Compound
Path

Reverse the creation of a compound path. Paths that were parts of
the compound path will be separate again.

Make Clipping Mask Create a clipping group from selected objects.

Release Clipping
Mask Turn a clipping group into a set of individual objects.
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The "Layer" Menu

Lock (Cmd-L) Lock a selected object.

Unlock All (Cmd-Opt-
L) Unlock all objects in the document.

Make Non-Printable Excludes the contents of a selected layer from being exported or
printed. Once applied, the command changes to Make Printable.

New Layer (Cmd-
Shift-N) Create a new layer.

New Sublayer Create a new sublayer as an item of the current layer.

Duplicate Active
Layer (Cmd-Shift-D) Create a copy of the active layer.

Isolate Active Layer Isolate the active layer. This command prevents objects on other
layers from being selected or manipulated.

The "Text" Menu

Font > Show or Hide
Fonts (Cmd-T) Open or close the Fonts panel.

Font > Bold (Cmd-B) Make selected text bold.

Font > Italic (Cmd-I) Turn selected text into italic.

Font > Underline
(Cmd-U) Underline selected text.

Font > Bigger (Cmd-
Ctrl-=)
Font > Smaller (Cmd-
Ctrl-minus)

Increase or decrease the size of the selected text.

Font > Kern Adjust spacing between characters.

Font > Ligatures Set up ligatures.

Font > Baseline Adjust the baseline of selected text.

Font > Show Colors Show or hide the Colors pane.

Alignment > Align
Left
Alignment > Center
Alignment > Justify
Alignment > Align
Right

Align text to the left, right, center or justify it.
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The "Select" Menu

Select All (Cmd-A)
Select all objects on all sheets except for locked objects.
Select the entire text in the text editor when text editing mode is
activated.

Select All on Active
Sheet (Cmd-Opt-A)

Select all objects on the active sheet except for locked objects.
Locked objects will not be selected.

Select All on Layer Select all objects on the active layer. Locked objects will not be
selected.

Deselect All (Cmd-
Shift-A) Deselect all objects.

Invert Selection
(Cmd-Opt-Shift-A)

Select objects that are currently not selected, and deselect those that
are selected.

Select Same >
Appearance

Select objects with exactly the same properties in the Appearance
panel. The order of the Fill, Stroke and other properties is important.

Select Same > Fill &
Stroke

Select objects with all the same Fill and Stroke properties. The order
of the Fill, Stroke and other properties is important.

Select Same > Fill
Color Select objects whose upper Fill properties have the same color.

Select Same > Stroke
Color

Select objects whose upper Stroke or Brush properties have the
same color.

Select Same > Stroke
Width

Select objects whose upper Stroke or Brush properties have the
same width.

The "View" Menu

Zoom In (Cmd-+) Zoom in the current view.

Zoom Out (Cmd-"-") Zoom out the current view.

Fit Sheet in Window
(Cmd-0) Zoom the current sheet to fit the window.

Fit All in Window
(Cmd-Opt-0) Fit the whole document into the window.

Zoom to Actual Size
(Cmd-1) Display the document at 100% scale.

Outline Preview
(Cmd-Y) Activate the Outline Preview mode.

Pixel Preview (Cmd-
Opt-Y) Activate the Pixel Preview mode at 72 dpi.

Pixel Preview Retina
(Cmd-Opt-Shift-Y) Activate the Pixel Preview mode at 144 dpi.
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Guides > Add
Horizontal Guide Add a horizontal guide.

Guides > Add Vertical
Guide Add a vertical guide.

Guides > Make
Guides Create a guide out of a selected path.

Guides > Release
Guides Reverse the Make Guides command making a path out of a guide.

Guides > Remove
Guides Remove all guides.

Guides > Hide
Guides (Cmd-;) Hide or show guides.

Guides > Lock
Guides Lock or unlock all guides.

Rulers (Cmd-R) Show the rulers.

Grid (Cmd-') Show the grid.

Snap to Grid (Cmd-
Shift-') Snap to the grid when you are moving or resizing an object.

Snap to Pixel Snap to the pixel grid when you are moving or resizing an object.

Smart Guides
(Cmd-/) Show smart guides when you are moving or resizing an object.

Show / Hide Corner
Handles Show or hide handles that are used for rounding corners of shapes.

Enter Full Screen /
Exit Full Screen Activate or deactivate the full screen mode.

The "Window" Menu

Minimize (Cmd-M) Minimize the currently active window.

Zoom Fit the program window to the screen size.

Show Next Tab Show a document in the next tab. This command is available when all
documents and panels are displayed in a single main window.

Show Previous Tab
Show a document in the previous tab. This command is available
when all documents and panels are displayed in a single main
window.

Attach or Detach
Panels

Put all of the document windows and panels into a single window.
Or, show documents and panels as independent windows or floating
panels.
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Hide UI (Tab) Hide or show the toolbar and most of the panels.

Appearance Show or hide the Appearance panel.

Geometry Show or hide the Geometry panel.

Layers Show or hide the Layers panel.

Sheets Show or hide the Sheets panel.

Libraries & Stock
Images Show the internal image library or one of online image collections.

Bring All to Front Show windows of Amadine in front of others.

The "Help" Menu

Amadine Help Open Help documentation delivered with the application.

Amadine Website Open the Amadine website.

Social Networks Access app's pages on social media.

What's New Open release notes on the Amadine website.

Online Registration… Open the online registration form.

Send Feedback… Send your feedback to the developer by email.

Video Tutorials Open the online video tutorials.

Keyboard Shortcuts Open the online list of keyboard shortcuts.
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Keyboard Shortcuts
Documents
Windows and Panels
Document View and Canvas
Layers and Objects
Text Editing and Formatting
Tools

Documents

Cmd-S Save the current document.

Cmd-Shift-Opt-S Save the current document to a new file.

Cmd-Shift-S Create a copy of the current document.

Cmd-O Open a document.

Cmd-N Create a new document.

Cmd-Shift-P Open the Document Setup dialog to verify or set up measurement
units, grid and other properties.

Cmd-W Close the active document.

Cmd-Opt-W Close all open windows.

Cmd-Opt-E Export the current document to a graphic file.

Cmd-Q Exit the application.

Cmd-Z Reverse the last operation you performed.

Cmd-Shift-Z Reverse the last Undo operation.

Windows and Panels

Cmd-Shift-W Close the open window.

Cmd-"," Bring up the Preferences dialog.

Cmd-M Minimize the currently active window.

Cmd-P Bring up the standard Print dialog.

Tab Hide or show the toolbar and most of the panels.
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Document View and Canvas

Cmd-+ Zoom in the current view.

Cmd-"-" Zoom out the current view.

Cmd-0 Zoom the current sheet to fit the window.

Cmd-Opt-0 Fit the whole document into the window.

Cmd-1 Display the document at 100% scale.

Cmd-Y Activate the Outline Preview mode.

Cmd-Opt-Y Activate the Pixel Preview mode.

Cmd-Opt-Shift-Y Activate the Retina Pixel Preview mode.

Cmd-; Hide or show guides.

Cmd-R Show the rulers.

Cmd-' Show the grid.

Cmd-Shift-' Snap to the grid when you are moving or resizing an object, or when
you are moving individual anchor points.

Cmd-/ Show smart guides when you are moving or resizing an object.

Space Activate the Hand tool which lets you scroll the canvas by dragging it.

Layers and Objects

Cmd-C Copy a selected object to the Clipboard.

Cmd-V Paste the contents of the Clipboard into the document.

Cmd-Shift-V Paste the contents of the Clipboard into the document at the same
location as the original object.

Cmd-X Cut a selected object to the Clipboard.

Cmd-A Select all objects on all sheets except for locked objects.

Cmd-Opt-A Select all objects on the active sheet except for locked objects.

Cmd-Shift-A Deselect all objects.

Cmd-Opt-Shift-A Select objects that are currently not selected, and deselect those that
are selected.

Cmd-D Duplicate a selected object.

Delete Delete a selected object.

Cmd-Opt-C Copy the style of a selected object.

Cmd-Opt-V Apply the style, copied to the Clipboard, to a selected object.
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Cmd-G Group selected objects.

Cmd-Shift-G Ungroup a selected group.

Cmd-J Apply the same transformation that was set up and applied using the
Transform dialog the last time.

Cmd-L Lock a selected object.

Cmd-Opt-L Unlock all objects in the document.

Cmd-Shift-N Create a new layer.

Cmd-Shift-D Create a copy of the current layer.

Cmd-] Move a selected object by one object forward within the object
stacking order.

Cmd-Shift-] Place a selected object in front of other objects.

Cmd-[ Move a selected object by one object backward within the object
stacking order.

Cmd-Shift-[ Place a selected object behind other objects.

Shift-D Apply the default style to the selected object.

Cmd-Ctrl-U Combine selected objects using the Union operation.

Cmd-Ctrl-T Combine selected objects using the Intersect operation.

Cmd-Ctrl-S Combine selected objects using the Subtract operation.

Cmd-Ctrl-X Combine selected objects using the Exclude operation.

Cmd-Ctrl-V Divide selected objects into parts.

Shift-X Swap the colors of the object's stroke and fill.

Text Editing and Formatting

Cmd-V Paste text from the Clipboard into the edit box.

Cmd-A Select all text in the text editor.

Cmd-T Open or close the Fonts panel.

Cmd-B Make selected text bold.

Cmd-I Turn selected text into italics.

Cmd-U Underline selected text.

fn fn Dictate your text.

Cmd-Ctrl-Space Open the Emoji & Symbols panel.
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Tools

V Activate the Move tool.

A Activate the Selection tool.

L Activate the Lasso tool.

P Activate the Pen tool.

D Activate the Draw tool.

W Activate the Path Width tool.

G Activate the Gradient tool.

T Activate the Text tool.

K Activate the Knife tool.

C Activate the Scissors tool.

E Activate the Eraser tool.

F Activate the Fusion tool.

I Activate the Eyedropper tool.

Z Activate the Zoom tool.

Q Activate the Free Transform tool.

R Activate the Rectangle tool.

Shift-R Activate the Rounded Rectangle tool.

O Activate the Ellipse tool.

Shift-O Activate the Polygon tool.

Shift-S Activate the Star tool.

/ Activate the Line tool.

S Activate the Sheets tool.

[ Decrease the diameter of the Pen, Draw and Erase tools.

] Increase the diameter of the Pen, Draw and Erase tools.

Cmd

Temporarily activate a different tool. This key switches the Selection
tool to the Move tool and vice versa. The Draw or Pen tool will be
switched to the Selection tool. Other tools will be switched to either
Selection or Move tool depending on which of them was activated
most recently.
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Creating Documents
To create a new document, select the File > New command in the main menu. The New
Document dialog will open. You should set up document properties and click the Create button
to have the document created.

When you start the program, the New Document dialog opens up automatically.

New Document Dialog

The combination of the Type and Preset options lets you select one of the predefined
templates. The Type lets you choose a set of presets by usage (e.g., Web). Then you can select
a particular sheet size from the Preset drop-down list.

The Width and Height give you an alternative way to set up the sheet size. Instead of choosing
a template, you can set any size you want directly.

The Measurement Units drop-down menu lets you select units to show the Width and Height.
The same measurement units will be used for sizes and distances on the canvas. You can
change units any time later.

The Orientation buttons let you choose either horizontal or vertical orientation of a sheet by
swapping the Width and Height values.

The Color Mode popup menu lets you choose between the RGB and CMYK color models.

The Color Profile popup menu defines the color profile for the document.

Notice that the dialog helps you create the first sheet. Your document can consist of multiple
sheets of different sizes. Once a new document is created, you will be able to add more sheets.



51

Creating a New Document by Importing an Image

If you drag-and-drop an image onto the icon of the program, the latter will create a default
document with your image added.
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Opening Documents
To open an existing document, choose one of the following methods:

Choose File > Open… in the menu (Cmd-O).
Select your document name in the File > Open Recent menu.
Lastly, you can double-click on the document icon in Finder.

Documents created on macOS, iOS or iPadOS are compatible on all other platforms. In other
words, a design created on Mac can be opened on iPad, and vice versa.

If you have forgotten the name of your document and it is not listed in the File > Open Recent
menu, try to find the file in Spotlight by searching the "amdn" or "amdc" file name extension.

Using iCloud

If you have an account at iCloud, you can open your documents from your iCloud storage. The
iCloud option is located in the Open File dialog.
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Saving Documents
The program saves documents in its own format. Document files have either "amdc" or "amdn"
file name extension. Both formats are used on all platforms that are supported by the app. To
search for your documents, type "amdc" or "amdn" in the search box of Spotlight.

To save the current document, select File > Save… or File > Save As… menu command. The
latter appears in the menu when you hold down the Option key. By default, the app saves
documents in the "amdc" format. It better suits for storing files on third party cloud storages.
Documents in this format are compressed to decrease the file size. If your document was saved
in one format but you need a different one, use the File > Save As… menu command and
choose a new format.

To find out the location of the current document on disk, click on the document's name in the
title bar of the main window.

The operating system automatically saves versions of modified documents. Due to this feature,
you don't need to save documents frequently during your work. Since the auto save feature has
limitations, it is recommended that you periodically save your document manually. To find and
restore any of the saved versions, select File > Revert To > Browse All Versions…
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Document Settings
The Document Setup dialog lets you change most of the settings that were available when you
created a document.

To open the dialog, choose File > Document Setup… from the main menu.

Dimension and Color Settings

Document Units: Defines the global measurement units. A quick way to change the units in the
course of your work is to click a measurement units button at the top left corner of the canvas
where the vertical and horizontal rulers touch each other.

Color Mode: Lets you choose between the RGB and CMYK color models.

Color Profile: Defines the color profile for the document.

Edit Size: This button gives you access to the tools that help you add and delete sheets and
also change their dimensions. This button closes the Document Setup dialog and activates the
Sheets tool.

Raster Effects

Effects Quality: Defines how accurately effects such as shadow or glow should be displayed
on the canvas. With higher values, effects will be rendered more smoothly. Smaller values make
the program interface more responsive when you are editing a complex document. Note that
this option does not affect the quality of exported graphics.
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Grid Options

Grid Type: Defines the type of the grid (e.g., standard or isometric). Note that changing the grid
type shows the grid if it was invisible. To control the visibility of the grid, use the View > Grid
command in the main menu or the drop-down menu in the Control panel.

Spacing: Sets the distance between the grid lines.

Subdivision: Divides each grid cell into several parts. For example, type "3" in the edit box to
split cells into three parts.

Show on Background: Defines whether the grid should be displayed in front or behind
everything else on the canvas.
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Layout Basics
Your documents can consist of one or multiple sheets and layers. There must be at least one
sheet and one layer at any time, and you can add or delete them as your work progresses.

Layers and sheets help you keep your document structure manageable even with a complex
design by putting together elements that are related to one other.

Sheets

A sheet is an area on the canvas where you create your design. You can think of a sheet as a
page in a text editor, or printable area. The boundary of a sheet defines a crop area. Objects
placed outside the sheet partially or completely will be trimmed.

Sheets are located on the canvas side by side. Frequently, each sheet holds a separate design,
but all of the sheets in a document are linked together as parts of a particular project (e.g.,
pages of a brochure, or different versions of the same design).

It is possible to change the size and position of sheets individually. You can learn about this in
the Sheets section.

An example of how sheets can be used is a design of two states of a button: normal and
pressed. It is useful to store all artwork in the same document. In this case, each button takes a
separate sheet.

If you already used other graphics software, you could use the artboard term for what we call a
sheet.

Layers

Layers can help you arrange objects within a sheet. A layer serves you like a folder, inside of
which you can place objects. Properties, that you apply to a layer (e.g., visibility or opacity), will
also affect the objects of this layer.

Objects added to a document are arranged as a layered structure. It becomes clear that, when
you place objects one over another, they overlap. Objects are stacked even if they don't
overlap. The program lets you put the objects in different layers (inside those virtual folders)
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without breaking the global stacking order. We can say that layers define the vertical structure
of the document.

Let's have a look at a small example—a button. The artwork consists of three parts organized
as three individual layers: Background, Button and Text. This structure lets us separate the
design of the button from the background and text. The background was added only to preview
the artwork with certain color around. The background won't be exported because the button
will be used in the interface, which already has the background.

Taking text aside from other objects makes sense if it is a variable part of the design. We may
need to create multiple buttons with different texts (e.g., "Cancel", "OK", etc.). In this case, you
can place all of the text in a separate layer. By hiding all of the text but one, you can get one of
the buttons. To edit the button itself, you hide the whole layer containing the text.

You can manage layers using the Layers panel.
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Sheets
Documents can have one or multiple sheets. You can specify the initial size of sheets when you
are creating a new document.

Activate a Sheet

To activate (or select) a sheet, click on its name in the Sheets panel. If you are going to work
with multiple sheets, it makes sense to name sheets appropriately in order to distinguish them
in the list.

Another way to activate a sheet is to click on it with the Sheets tool .

Objects and Sheets

The location of an object can be calculated in either a local or global system of coordinates.
When the coordinate system is local, each sheet has the zero point at the top left corner.
Consequently, the object coordinates are calculated in relation to the zero point of the active
sheet.

Each object is associated with some sheet. There is no strong linking between sheets and
objects. Once an object is added on top of a sheet, the object becomes associated with this
sheet. Then, any time you select that object, the respective sheet becomes activated.

Later, it will be explained how to rearrange sheets on the canvas. When you change the location
of a sheet, objects can either move along with it or remain at the same position. In the former
case, all objects that are placed over the sheet completely or partially will move no matter
which sheet they belong to. After that, all objects that were relocated together with the sheet
will belong to this sheet.

If you choose to move objects together with a sheet, make sure that all of your artwork either
moves or stays. Otherwise, you can break the design apart.

The Move artwork with the sheet button  controls the ability to move objects when you
relocate a sheet. It is available in the Control panel when the Sheets tool is activated. The same
button is present in the Sheets panel.

Manage Sheets using the Sheets Panel

To open the Sheets panel, choose Window > Sheets command from the main menu.
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The Sheets panel lists sheets present in the current document. If there are multiple sheets in the
document, give them meaningful names to easily differentiate one sheet from another. In order
to rename a sheet, double-click on its name in the list. Notice that each sheet has two
identifiers. In the image above, "Sheet 1" is the name that you can edit. To the left from the
name, there is the sheet number which is "1" in our case. The sheet number cannot be
changed.

The panel lets you add and delete sheets using  and  buttons correspondingly. See the
Add and Delete Sheets subsection for more details.

A sheet can be made invisible by clicking on a check box near the sheet's name.

To define how sheets should be arranged on the canvas, click on the  button. The Move and
Arrange Sheets section has more details on this topic.

You can move a sheet on the canvas together with the objects on it. Click the Move artwork
with the sheet button  to switch this behavior on or off.

Sheet Properties

Properties of each sheet can be accessed by clicking on the corresponding  icon. The
Properties pop-up lets you set up the size, orientation, and position of the sheet.

You can choose a pre-defined sheet size by selecting a combination of Type and Preset. You
can also input the width and height directly into the W and H fields.

The Orientation buttons simply swap the current width and height.

Each sheet can be positioned on the canvas by inputting the X and Y coordinates. Notice that
these fields always operate with the global coordinates.

You can also change the origin point using the 9-point Anchor control. It defines which of the
nine points should appear at the coordinate set by X and Y. For example, if you want to place
the center of the sheet at the zero coordinate, click on the point in the center of the Anchor
control.

Add and Delete Sheets

In order to add a new sheet, click the plus button at the bottom of the Sheets panel.
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By default, a new sheet has the same size as one that was previously selected in the list. That
is, if your document already has big and small sheets, and you want to have one more small
sheet, select the small one before clicking on the plus.

To delete a sheet, select it in the list and click on the trash icon. You cannot delete the last
sheet.

Right-clicking on the list of sheets in the Sheets panel brings up a contextual menu. It contains
the New, Duplicate and Delete commands.

If you duplicate a sheet while the Move artwork with the sheet option  is activated, the
objects on this sheet will be duplicated as well.

There is an alternative way to add and delete sheets. This can be done using the Sheets tool
that is described below.

Move and Arrange Sheets

You can select how sheets should be arranged on the canvas by clicking on  in the Sheets
panel. This button opens a pop-up panel.

The Layout options define how sheets should be arranged on the canvas.

The Reverse check box inverses the order of sheets when you add them.

The leftmost button in the Layout settings places sheets in a fixed number of columns and
variable number or rows. The Columns parameter defines how many columns there should be.
Identically, you can set up the number of rows when the second Layout button is selected.

The Spacing field defines the distance between sheets vertically and horizontally.

To apply a new setting, you simply click the Rearrange button.

Jump to a Sheet

In a document with multiple sheets, one or several of them may appear beyond the visible area.
You can use scrolling in order to access such a sheet. The Sheets panel lets you jump to a
sheet by double-clicking on the sheet's number. This function scrolls to the sheet and fits it into
the editing area.
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Sheets Tool

The Sheets tool lets you add, delete and relocate sheets. To activate this tool, click on its icon
in the Tools Panel.

Once the tool is activated, the Control panel displays the related controls. Later, we'll discuss
the purpose of each of them.

Select a Sheet

In order to delete, move or resize a sheet, you should select it.

To select a sheet, click on it with the Sheets tool or choose it in the Sheets panel. A selected
sheet displays a frame with handles.

Resize a Sheet

To resize a sheet, click on it with the Sheets tool. Then drag a side or corner handle.

To input the exact width and height in pixels or other units, use the Properties pop-up in the
Sheets panel.

Add a Sheet

There are two ways of adding new sheets using the tool in addition to the method given in the
Add and Delete Sheets section.

To add a new sheet with predefined dimensions, click on the plus icon and then choose one of
the options from the Preset drop-down menu.

You can apply a Preset and change the Orientation of a sheet any time later.

Another way to add a new sheet is to draw it. Activate the Sheets tool. Place the cursor over
the free space on the canvas. Press and hold the left mouse button to define the position of the
first corner. Move the cursor to another point where the opposite corner should appear. Release
the button.

In order to create a new sheet, you can also duplicate one of the sheets in your document. To
duplicate a sheet, Option-drag it on the canvas with the Sheets tool. If you activate the Move
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artwork with the sheet option in the Control panel, the program will duplicate all objects on
the sheet as well. Otherwise, an empty sheet will be created.

Delete a Sheet

To delete a sheet, click on it with the Sheets tool. Then click on the trash icon.

Relocate a Sheet

To relocate a sheet, drag it with the mouse.

A more accurate way is to input new coordinates into the X and Y fields in the Control panel.

The Move artwork with the sheet option lets you move objects located on the sheet together
with the sheet. Normally, this option should be activated.

The Coordinate System

The rulers can show the coordinates of a sheet and objects on it in one of two modes: Global
Rulers and Active Sheet Rulers. To select one of them, click on the measurement units button
on the rulers in order to open the drop-down menu.

Global Rulers: The coordinate system and, consequently, the rulers' zero are used for the whole
document.

Active Sheet Rulers: The coordinate system and the rulers' zero are local for each sheet. As
soon as you activate a new sheet in this mode, the rulers will align the zero coordinate with the
sheet. By default, whichever sheet you activate, its upper left corner appears at zero.

When the Sheets tool is activated, the rulers display only the global coordinates.
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Modifier Keys and Shortcut Summary

Shortcut:

S activates the Sheets tool.

Sheets tool modifier keys:

Space switches to the Pan mode.
Command switches to either Move or Selection tool depending on which of them was
active most recently.
Option lets you duplicate a sheet. Drag a sheet to create its duplicate.
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The Grid
The grid can help you place objects on a sheet. It can also be useful when you resize an object
or sheet with the mouse.

To show or hide the grid, use the View > Grid (Cmd-') command in the main menu. It is
possible to show or hide the grid using the drop-down menu in the Control panel.

To make an object or its part snap to the grid, activate the Snap to Grid feature using the drop-
down menu shown above, or use View > Snap to Grid (Cmd-Shift-').

The program Preferences has an option to change the color of the grid.

Grid Types

The app lets you choose different grid types in the Document Settings. Each of the types has
different angles of the grid lines.

Standard grid with lines at 0 and 90 degrees

Isometric grid with lines at -30 and +30 degrees
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The purpose of the Standard grid is to arrange objects in your design. Other types include
isometric and axonometric grids. They can help you create designs that use parallel projection
to make objects look three-dimensional.
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Layout Guides

Guide Lines

Guide lines (or guides) are used to align objects on the canvas. They can also be used to
visually split a sheet into several parts.

To add a guide:

Double-click on a ruler at the coordinate where a guide should appear. Use the horizontal
ruler to add a vertical guide and vice versa.
Place the cursor over the vertical or horizontal ruler. Press and hold the left mouse button.
Move the cursor towards the canvas. Release the button where you want to place the
guide.
Use either View > Guides > Add Horizontal Guide or View > Guides > Add Vertical
Guide menu command.

To move a guide, drag it with the mouse. It is possible to select a guide by clicking on it. Then
you can move it using the arrow keys.

To input an exact coordinate, select a guide and then type the coordinate into the X or Y field in
the Geometry panel.

To lock a guide, click on its lock icon in the Layers panel. To lock all guides, select View >
Guides > Lock Guides in the menu. Locking guides prevents them from being accidentally
moved. To unlock guides, use the View > Guides > Unlock Guides menu.

In order to hide or show all guides, use either View > Guides > Hide Guides or View > Guides
> Show Guides menu. The Layers panel lets you make individual guides invisible and visible.

To delete a guide:

Select it and hit the Delete key.
Use the Layers panel.

In the Guides and Grid tab of the Preferences, you can change the color of guides.
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Smart Guides

When you move or resize an object, the program helps you align it with others using smart
guides.

A smart guide is a line that looks like a regular guide, but shorter. It appears in your document
automatically when an object you manipulate becomes aligned with something in the design.
The smart guide that is displayed at that moment visually links the object with the point it is
aligned to. If you move the object farther, the alignment will be broken, and the smart guide will
disappear.

When you are moving one of the ends of a line, a smart guide can display the extension of the
line helping you snap to the same angle. A small cross indicates the original location of line's
end.

Create a Guide from a Path

You can create a guide from a path. This may be helpful if you need a guide with unique
properties. For example, a customized guide can have an angle other than 0 or 90 degrees.
Customized guides can be much shorter than the standard ones. This enables you to have a
guide only in the area where it is needed. A new guide can be created from a non-straight path
as well.

To turn a path into a guide, use the View > Guides > Make Guides menu command.
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You can also convert a guide into a path by using View > Guides > Release Guides.
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Select Objects
In order to edit an object or its part, you should select it. Then you can use tools or panels to
modify the object's properties, such as the shape, color, size and others. The program lets you
select an object, an object's part or multiple objects using different methods.

If an object is locked, it cannot be selected directly on the canvas.

Select a Single Object

To select an object, activate the Move tool , and then click on the object.

As a rule, you should click on a visible part of an object to select it. For example, when a
rectangle has a stroke but there is no fill, you should click on the stroke. Clicking inside the
rectangle won't select it. On the other hand, if the Fill option is on, you can click anywhere on
the rectangle.

Select Multiple Objects

To select several objects, activate the Move tool , and then click on each of the objects
holding down the Shift key.

Another way to select multiple objects is to outline those objects with the selection frame. Click
with the Move tool at an empty point and drag the tool. The selection frame will appear
between the starting point and the current position of the tool. Make the selection frame big
enough to completely or partially outline the objects you want to select.

To deselect one of several selected objects keeping the rest of them selected, Shift-click on
that object.

To deselect all selected objects, and select all unselected objects, choose Select > Invert
Selection (Cmd-Opt-Shift-A).

Select All Objects

To select all objects that are not locked, use either Select > Select All (Cmd-A) or Select >
Select All on Active Sheet (Cmd-Opt-A) command from the main menu.

Select an Object in the Layers Panel

You can select an object by clicking on its name in the Layers panel.
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To select multiple objects, click on their names in the Layers panel holding down the Cmd key.

To select multiple objects, the names of which follow one after another, click on the first name,
then press and hold the Shift key and click on the last name.

Select Objects with Identical Properties

You can select objects that have the same property or a set of properties in the Appearance
panel. This may be useful when a design contains many similar objects (e.g., snowflakes or
flowers on a postcard). You could create one, make it look as you wish and then make its
copies. Once you decide to change their color, you have to select all of them. In such cases,
the Select > Select Same menu comes in handy.

To select all objects with identical properties:

1. Select one object that will be used as a model to search for others.
2. Open the Select > Select Same menu and choose one of the options.

The following selection commands are supported:

Select > Select Same > Appearance selects objects with exactly the same properties in
the same order in the Appearance panel.
Select > Select Same > Fill & Stroke selects objects with all the same Fill and Stroke
properties placed in the same order. Effects such as shadow are ignored.
Select > Select Same > Fill Color selects objects whose upper Fill properties have the
same color. Stroke properties (including their location in the list in relation to Fill) as well as
effects are ignored. The transparency of the color is also taken into account.
Select > Select Same > Stroke Color selects objects whose upper Stroke properties
have the same color. Fill properties (including their location in the list in relation to Stroke)
as well as effects are ignored. Notice that stroke width (whether it is constant or variable)
doesn't matter. So, both objects will be selected if one has a black Stroke and the other
has a black Brush property. The transparency of the color is also taken into account.
Select > Select Same > Stroke Width selects objects whose upper Stroke properties
have the same width. Fill properties (including their location in the list in relation to Stroke)
as well as effects are ignored. Notice that Stroke and Brush with the same width are
treated as identical. Strokes with variable width (e.g, created with the Path Width tool) are
ignored.
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Be cautious with this selection tool. It might select more objects than you expect. Try to make
sure visually that there are no objects that you didn't want to select.

Deselect an Object

To deselect one or multiple objects, click with the Move tool  at any empty space on a
sheet or on the canvas.

An alternative way is to choose Select > Deselect All (Cmd-Shift-A) from the main menu.

Isolation Mode

The Isolation mode is used to work with a particular object or its part. In this mode, only the
isolated object can be edited. The rest of the objects are locked and displayed in dimmed
colors. As soon as you deactivate the Isolation mode, those objects will become unlocked.

You can isolate a standalone object, an object that is a part of a compound object or group.

To isolate an object, double-click on it with the Move or Selection tool. If an object is in a
group that itself is a part of another group, click on the object several times until you reach it.

An alternative way to enter the Isolation mode is to select the layer that you want to edit in the
Layers panel. Then bring up the context menu and choose Isolate Active Layer.

To exit the Isolation mode, hit the Esc key, or click the "X" button in a bar below the horizontal
ruler, or double-click outside the isolated object. This bar displays the name of the isolated
object. If the isolated object is inside a group, the name of the group will be indicated there.

In the Isolation mode, the Layers panel hides the list of layers and objects and shows the
"Isolation Mode" item as the top level object. The isolated object will be one of its subitems
directly, or it can be inside of one of nested subitems.
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Select Objects Inside a Group

It is possible to access an object inside a group without ungrouping it. There are several ways
to do this. One of them is to use the Isolation Mode discussed earlier.

Another way is to make use of the Layers panel. You should click on a triangle near the name of
the group to expand it and show the grouped objects. Then click on the name of the object you
want to select.

Finally, it is possible to select an object in a group by clicking on it with the Selection tool.
Neither the entire group nor other objects in it won't become selected.

Locking and Unlocking Objects

Locking an object helps you prevent it from being moved or edited accidentally.

To lock an object, use one of these methods:

Select the object and choose the Layer > Lock (Cmd-L) command from the main menu.
Click on the object's Lock icon in the Layers panel.

To unlock an object, click on its Lock icon in the Layers panel.

To unlock all objects, select Layer > Unlock All (Cmd-Opt-L).

Defining the Order of Objects

A currently selected object can define where an object that you add to the design should
appear in the stack of objects. This concerns different types of objects that you can add: paths,
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texts, graphics from the built-in libraries, pasted and imported objects. When the Draw/insert
above the selection option in the Preferences is activated, a new object will be placed right
above the selected object. When the option is deactivated or none of the objects is selected, a
new object will appear at the upper position in the active layer. The overall order of layers and
objects can be changed using the Layers panel.
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Delete or Hide an Object
To delete an object, select it and then use any of these methods:

Press the Delete or Backspace key.
Choose Edit > Delete command from the main menu.
Click the Delete button in the Layers panel.

If an object is locked, you should unlock it before removing.

You can delete an object from a group without ungrouping it. To do this, select an object in the
Layers panel, and click the Delete button.

Hide an Object

If you need an object to disappear without deleting it from the document, you can hide it. If you
hide an object that interacts with other objects after applying a blend mode, Boolean operation
(e.g., Subtract) or something else, that interaction will also disappear as if the object doesn't
exist. If you show the object again, effects related to this object will be restored.

To hide an object, clear a check box to the left from its name in the Layers panel.

To show an object, set the check box in the Layers panel.

You can hide an individual object, group or layer.
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Move, Resize and Rotate Objects
The geometric properties of an object can be modified directly on the canvas or using the
Geometry panel. The latter has more options, and also lets you input numerical values, which
provides better accuracy. Editing objects right on the canvas is usually faster and more
convenient.

You should select an object before modifying its properties. A selected object displays its
boundary box with handles in the corners at the middle of each side. We will use these handles
later.

Most of the properties discussed below can be adjusted with an individual object, several
objects or groups selected. Multiple selected objects, even not grouped, will respond to
adjusting parameters in the same way as a group. For example, if you select two squares and
change the width in the Geometry panel, the new value will be applied not to each of the
squares but to the selection boundary. In order to apply the same value to all selected objects,
use the Transform command from the context menu.

Manipulating an Object on the Canvas

Move an Object

To move an object, activate the Move tool . Then click on the object and drag it.

As a rule, you should grab a visible part of an object. For example, when a rectangle has a
stroke but there is no fill, you should drag the outline of the object.

You can also move a selected object using the arrow keys. In order to move the object faster,
hold down the Shift key while pressing on an arrow.

The commands from the Modify > Align menu let you move an object to the center or edges of
the current sheet. Normally, these commands require that you select several objects that
should be aligned. If you select one object, it will align to the sheet.

Resize an Object

To resize an object, drag a corner or side handle on the object's boundary box using the Move
tool . To preserve the aspect ratio, do that by holding down the Shift key.

When you drag a corner or side handle the opposite corner or side of the object's boundary
retains its position by default. To resize an object symmetrically, hold down the Option key. In
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this case, the center of the boundary will preserve its location.

Rotate an Object

To rotate an object, activate the Move tool . Place the mouse pointer outside the bounding
box near a corner handle. The cursor should turn into a bent double-sided arrow. Click and
move the cursor to specify a new angle.

Hold down Shift to rotate with 15 degree steps.

The default center of rotation coincides with the center of the object's boundary. To set any
other point as the center of rotation, click on  in the Control panel. Then drag a circular
handle, that indicates the rotation center, to a new place.

Using the Geometry Panel

The Geometry panel helps you manipulate objects by setting up exact values for the object's
location, size or rotation angle. To open the panel, choose Window > Geometry from the main
menu.

Modifier Keys and Shortcut Summary

Shortcut:

V activates the Move tool.

Move tool modifier keys:

Space switches to the Pan mode.
Command switches to the Selection tool.
Shift allows you to select multiple objects.
Shift allows resizing an object preserving its aspect ratio.
Shift lets you rotate an object in 15 degree steps.
Option lets you duplicate an object. Option-drag an object to create its duplicate.
Option lets you resize an object preserving the location of its center.
Option-Shift resizes an object preserving its aspect ratio and location of the center.
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The Geometry Panel
The Geometry panel lets you adjust an object's size and coordinates, and change its other
properties. To open the panel, choose Window > Geometry from the main menu.

1 - The object's width and height. The Maintain Aspect Ratio option can prevent an object's
deformation when you change one of its dimensions. The Maintain Aspect Ratio icon is
located to the right of the text fields.

2 - Reference point selector. The coordinate defined by X and Y is the location of the reference
point. The 9-point selector lets you choose a corner, the middle of any side or the center.

With the same coordinates but different reference points, an object will have different locations.
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3 - The object's coordinates.

4 - The rotation tool. You can either input the angle into the text field or rotate the circular
control.

5 - The vertical Shear tool.

6 - The horizontal Shear tool.
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7 - Flip horizontally or vertically.

8 - Rotate an object 90 degrees left or right.

9 - Scale stroke and other effects when the object is resized. For example, making an object
twice as big, you can expect that its stroke and shadow will be two times wider.

Move and Rotate an Object with the Geometry Panel

To move an object to a new location, change its X, Y or both coordinates. Notice that, by
default, X and Y coordinates define the location of the top left corner of the object's boundary.
You can choose one of nine points using the Reference point selector.

In order to resize an object, change the W and H properties. Use the Maintain Aspect Ratio
button to preserve the object's aspect ratio while you are modifying either the width or height.

To rotate an object, input a new value into the angle field, or drag the handle on the circular
rotation tool.

In order to rotate an object with 90 degree steps to the left or right, click the corresponding
bent arrow icon.

Apart from rotation, you can also mirror objects using the vertical and horizontal flip buttons.
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Align and Distribute Objects
In order to access the Align, Distribute or Spacing tools, select objects. Each of the three
buttons that will appear in the Control panel opens the corresponding set of tools.

1 - Align tools.

2 - Distribute tools.

3 - Spacing tools.

Align Objects

This section explains how to align objects to one other. If you want to align an object to the grid
or guide line, go to the corresponding page.

To align objects, select two or more of them. If only one object is selected, it will be aligned to
one of the edges or center of the active sheet.

1 - Align to the leftmost object.

2 - Align objects' centers horizontally.

3 - Align to the rightmost object.

4 - Align to the upper object.

5 - Align objects' centers vertically.

6 - Align to the lower object.

Let's take the first tool to explain the alignment principle. The program finds an object whose
left side or a single point is the most far to the left compared to other objects. We can call this
object a key object. Then the rest of the objects are moved to the left until they reach the
leftmost point of the key object. The key object always retains its position. Notice that the
program considers only the path. Strokes, shadows or other properties that may visually affect
the objects' dimensions are not taken into account.
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When you choose to align objects' centers, the centers take the same horizontal or vertical
coordinate. This coordinate is calculated as the center of the boundary of all currently selected
objects.

 

Distribute Objects

The Distribute tools equalize the distance between sides or centers of selected objects. You
should select three or more objects in order to distribute them.

To distribute objects, the program finds two key objects. These are the rightmost and leftmost
objects to distribute horizontally, or the upper and lower objects to distribute vertically. The key
objects retain their positions. All the remaining objects will be relocated in order to comply with
the selected Distribute command.

Make equal distances between:

1 - Left sides of objects.

2 - Centers of objects horizontally.

3 - Right sides of objects.
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4 - Tops of objects.

5 - Centers of objects vertically.

6 - Bottoms of objects.

The image below demonstrates the original location of the objects at the top, and the result of
the Distribute centers of objects horizontally tool.

Set Up Spacing

The Spacing tools are used to set up an exact distance between objects. You should select two
or more objects in order to set up spacing between them.

In order to set new spacing, the program defines a key object (e.g., the leftmost for horizontal
spacing). The position of this object will be fixed. All the remaining objects can be moved in
order to make spaces between them equal to the value you set.

The image below shows what happens with the objects' locations when you set the horizontal
spaces between them to a particular value.
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Align and Distribute Anchor Points

The Align, Distribute and Spacing tools can also work with individual anchor points including
those that belong to different paths. The Select Anchor Points subsection describes how you
can select anchor points.
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Lock an Object
You can lock an object to prevent it from moving or being edited. In fact, locking prevents the
object from being selected. As a consequence, you won't be able to modify it by mistake.

To lock an object, select it and click on the Lock icon in the Layers panel.

It is possible to lock not only an individual object but a group or layer.

To unlock an object, click on its Lock icon in the Layers panel.

The Lock icon is located to the right from the object's name in the Layers panel.

It is also possible to lock and unlock objects using the Layer > Lock and Layer > Unlock All
commands from the main menu.
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Group and Expand Objects

Group or Ungroup Objects

Grouping objects lets you combine them into a single piece of design. The created group can
be moved, rotated and resized as you could do with a single object. Some other manipulations
like adding Fill and Stroke or applying distortion are also possible. This may be useful if your
whole design or its part is created out of several primitive objects, and you don't want it to fall
apart when you move or rotate it. For example, you can create a keyboard as a number of keys
and the body. Then you group them together to have the keyboard as a single unit.

The item in the Layers panel that represents a group is named Group by default. You can click
on the triangle near the group name to access the grouped objects.

A group can include another group and so on. In this case, we say that groups are nested.

To group objects, select them. Then right-click on any of the selected objects and choose
Group.

To ungroup, select the group, bring up its context menu, and choose Ungroup.

It is possible to select an individual object in a group on the canvas without ungrouping it. To do
that, click on the object with the Selection tool.

There are two other types of groups. Compound groups are explained in one of the following
sections. Clipping groups are related to the clipping masks which are described in the Using a
Clipping Mask section.

Using the Layers Panel for Grouping and Ungrouping

In order to ungroup objects, select one or several of them in the Layers panel. Then drag the
selected objects outside the group. Objects moved in this way outside the group will become
ungrouped. Once a group is empty it disappears. This method also works with compound and
clipping groups. The latter though have a small difference. If you move all but one object
outside a clipping group, the last object will be moved outside automatically and the clipping
group will disappear.
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To create a clipping group, drag the name of one object in the Layers panel and drop it onto a
second one. The second object will become a clipping mask for the object that you have
dropped.

In order to add a new object to an existing group of any type, drag the object into the group in
the Layers panel.

Using the Isolation Mode to Edit a Group

You can edit a group in the Isolation Mode without ungrouping it. That includes moving and
rotating an object in the group in relation to others, editing text and more. To activate the
Isolation Mode, select the group. Then double-click on it with the Move tool.

Compound Group

By applying one of the Combine commands (e.g., Union) to multiple objects, you can create a
compound group. Like groups discussed earlier, a compound group serves as a container that
includes the original paths. This means that you are still capable of modifying these paths and
therefore updating the result. For example, we can create a hole in a shape using the Subtract
operation. Then the original objects will appear inside a compound group, which can be
operated mostly like a regular object. But, at the same time, you can reach the original objects
using the Isolation mode or the Layers panel, and change their location or shape.

Original Shapes

Compound Group
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Expand Objects

The Expand button in the Control panel (also Modify > Expand in the main menu) turns an
object into a number of typically more primitive objects. Those objects together look exactly
like the original one. Objects are often expanded in order to edit their parts.

The following image shows an arrow with a stroke and gradient fill expanded into two objects:
an arrow with gradient and the arrow outline. All created objects were manually moved apart for
the illustration.

The result of expanding is a group of objects. After expanding in the example above, the outline
and gradient are grouped. This is the most common case.

The Expand feature has many different use cases. They often rely on the fact that vector
objects are expanded into paths that you could access independently. This enables object
editing that is not possible in other ways. For example, the Rounded Rectangle tool creates a
parametric object. The shapes of its corners are defined by respective settings. But these
settings limit your capabilities to adjust the object's shape. Once you have reached that limit,
you can expand a rounded rectangle and edit it as a path using the Selection or other tools.

Another case is text. Once it is expanded, you can make letters look differently from the original
font. For instance, rotate individual letters, turn the "O" letters into smiley faces and so on.

There is no way to switch back and forth between the expanded object's state and the original
one. That can be done using the Undo command by canceling all the editing you did after
expanding. Before expanding, it is useful to create a duplicate of your original object or text just
in case you need it later.

In certain cases, you have to apply Expand more than once to actually expand an object. For
example, let's take a shape with rounded corners. When you expand it for the first time, the
app converts parametric corners into a rounded path. At the second time, the object's fill and
stroke will be expanded.
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Align Objects to the Pixel Grid

Create a Pixel-Aligned Object

To create a pixel-aligned object, activate the View > Snap to Pixel option in the main menu.

As you draw a standard shape or create a path using the Pen tool, the cursor will snap to
pixels. As a result, all anchor points of the created path will be aligned to the pixel grid.

Align an Object to the Pixel Grid

To have a rasterized line look sharp, its width should be a whole number in pixels (no fractions).
Also, this line should be aligned to the pixel grid.

In many cases, when you align an object to the pixel grid, you want to align vertical and
horizontal lines to the pixel grid. This can be done by aligning anchor points to the grid. To do
this, activate the View > Snap to Pixel option in the main menu. It can also be useful to display
the pixel grid using the View > Pixel Preview command. Then slightly move anchor points near
their locations with the Selection tool to snap them to the grid.

The pixel grid becomes visible at a zoom of 500% or higher.

The Pixel Preview mode is also discussed in The Main Window section.

Why should you Align Objects to the Pixel Grid?

The alignment of objects to the pixel grid may make a big difference if your graphics are going
to be exported in a raster format.

In the following example, we have two identical vector rectangles. The one on the right is
aligned to the pixel grid. The left one is not aligned to the pixel grid horizontally. Its offset is 1/2
pixel. Both rectangles have 1 pixel wide black stroke.

In the normal preview mode, both rectangles have a perfect look as it is expected from vector
graphics.

Two identical rectangles in the normal mode
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The Pixel Preview mode reveals the appearance of the rectangles once they have been
rasterized. Vertical lines of a misaligned left rectangle become blurred. This happened because
a 1 pixel vector line was mapped not on one but on two columns of pixels.

The same rectangles in the Pixel Preview mode

To activate the Pixel Preview mode, select View > Pixel Preview in the main menu.
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Introduction to Layers and Objects

Using Layers to Organize Objects

Complex designs can consist of hundreds or thousands of elements. Even if you name all of
them appropriately in the list of objects, it would still be difficult to manage them. Layers
provide a way to organize objects into sets. A layer serves as a folder on your disk that contains
some number of items in isolation from others.

A new document has only one layer. All objects appear in this layer by default. You can add
more layers with meaningful names, and organize elements of your design into groups by type,
color or other principle. You can also add sublayers inside a layer. This can be used to keep
together identical items.

A layer lets you manipulate objects that are inside as a whole by switching the visibility on or
off, locking them or adjusting their transparency.

Let's see how we can use layers for a flower design. We can place all parts of the flower into a
single layer. Also, we can add two sublayers for leaves and petals.

Any layer can include one or multiple objects or sublayers.

Objects are not bound to layers. You can relocate an object to another layer by a simple drag-
and-drop in the Layers panel.

About the Layers Panel

The Layers panel is a complete list of layers and objects that you have in the document. This
list is presented as a structure where layers appear as top level items. You can look inside of a
layer and see objects and sublayers in it. The whole list from top to bottom represents exactly
the same order in which objects appear in the document. If some object is behind others on the
canvas, this object will be lower than others in the Layers panel.
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In order to visually link objects on the canvas with layers, the object's boundary, when it is
selected, has the same color as the color that marks the corresponding layer in the Layers
panel. This works only if a single item is selected.

More details about the panel can be found in The Layers Panel section.
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The Layers Panel
The Layers panel helps you organize objects in your document. It displays objects as a list. The
top-level items in this list can only be layers. Each layer serves as a folder that can store
objects and sublayers. In complex designs, you can place related objects into the same layer to
keep them together. A simple design can have a single layer.

To open the Layers panel, choose Window > Layers from the main menu.

1 - Opacity of a layer or object.

2 - The active layer is marked by a line near the panel's left side.

3 - Visibility option.

4 - Layer's color.

5 - Add a new layer.

6 - Reveal a selected object in the list. This button tries to make a selected object visible in the
Layers panel and on the canvas. If necessary, it can scroll the object list in the panel and it can
zoom and scroll the canvas.

7 - Blend mode of a layer or object.

8 - Lock option. You can lock an individual object, or a layer with everything inside it.

9 - Delete the active layer or selected object.

Each line in the list relates to one layer or one object (or compound object or group).

Items in the list have default names. To edit a name, double-click on it. Then press the Enter
key to apply a new name.

Layers and objects in the list have the context menu with these commands:

New Layer creates a new layer above the current one.
New Sublayer creates a new sublayer.
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Duplicate creates a copy of a layer or object.
Delete deletes a layer or object.
Select All Layers selects all layers including hidden and locked ones.
Select All on Layer selects the contents of the active layer including paths, groups and
sublayers. If you select one object and then run the command, all the rest objects on the
same layer will become selected. You can also select a layer directly. If several layers are
selected, the command will select the contents of these layers.
Hide hides a layer or object.
Lock locks a layer or object.
Unlock All unlocks all layers and objects.
Make Non-Printable marks a layer as non-printable. All the contents of a non-printable
layer will not be exported or printed. The Make Printable command makes the layer
contents printable again.
Merge Selected merges selected layers. The result is a single layer that contains objects
of the original layers.
Collapse All shows only the top layers' names in the list. The content of layers, including
sublayers, will not be displayed. To show it again, click on the v-shaped icon of the
corresponding layer.
Isolate Active Layer activates the Isolation mode for the active layer.

Autoscroll to the Selected Object

The Layers panel focus on selection checkbox in the Preferences defines two modes in
which the panel can operate. If you select an object on the canvas when the checkbox is on,
the panel will scroll the list of objects to make the selected object visible. If other layers are
present in the panel, their contents will collapse. If you deselect the selected object, all of the
layers become collapsed. When the checkbox is switched off, the Layers panel doesn't change
its state when you select or deselect objects.

Active Layer

At any given time, one layer is active. If you add an object, the latter will be placed into the
active layer. The currently active layer is indicated by a line on the left side of the Layers panel.
Only one layer can be active.

Do not confuse the active and selected layer terms. You can select multiple layers, but only one
of them will be active.

To activate a layer, click on its name or icon in the Layers panel. A layer also becomes active
when you select any object in it.

Visibility of Layers and Objects

Objects that you add to the design are visible by default. To hide an object or layer, deselect a
checkbox near its name.



94

Hiding a layer is equivalent to hiding all objects in this layer.

Hidden objects do not appear on the canvas and are not visible in the exported or printed
graphics. Invisible objects do not interact with other objects. For example, there will be no
effect from an applied blend mode or a combine option.

Opacity of Layers and Objects

You can make an object or layer transparent or semi-transparent by changing the value in the
top left corner of the panel.

Setting a certain level of opacity for a layer gives a result similar to setting the same level of
opacity for all objects in this layer.

Locking Layers and Objects

You can lock an object or layer by clicking on its lock icon. A locked item cannot be selected on
the canvas and therefore it is protected from editing by mistake.

By locking a layer you lock everything in it.

Notice that guide lines have another way to be locked or unlocked using the View > Guides
menu.

Layer's Color

Each layer has a color associated with it. It is used to establish the relationship between a layer
and items in this layer. Once you select an object on the canvas, its boundary or path has the
same color as the layer it belongs to. This color doesn't affect your design.

In the Layers panel, the color of each layer is shown as a vertical color bar to the right from the
checkbox.

To change the color, click on the bar and choose a new color from the pop-up menu.

Find an Object on the Canvas

As soon as you zoom in to work with one object, the others may appear outside the editing
area. So to get to another object, you may need to zoom out and then scroll. You can also jump
to a particular object by double-clicking on its icon in the Layers panel. This function fits the
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object into the editing area and selects it. In a design with many elements, this way may be
faster than scrolling and zooming.

Double-clicking on the layer's icon in the panel fits all objects of the layer into the editing area.
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Creating and Deleting Layers
You can use the Layers panel to add and delete layers.

Create a Layer

To add a new layer, click on the plus button at the bottom of the Layers panel.

You can create a sublayer inside some other layer. Open the context menu of a layer inside of
which you want to add a sublayer. Then select the New Sublayer command from the menu.

You can also create a copy of an existing layer. To do this, select the Duplicate command in the
context menu of that layer.

The Layer item in the main menu provides commands to create and duplicate layers.

Delete a Layer

To delete a layer, click on it in the Layers panel to select. Then click on the trash bin icon.

Attention! When you delete a layer, all objects in it will be deleted as well.
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Arranging Layers and Objects
Layers and objects stack one over another while you are adding them to the document. The
stacking order of objects on the canvas is identical to the order in the Layers panel. If two
objects overlap on the canvas, then the same object would be the upper on the canvas and in
the list. This was discussed in the Layout Basics section.

The order of items in the Layers panel is important because it defines whether each individual
object or layer should be behind or in front of another one. The Layers panel helps you reorder
layers and objects.

The Initial Order of Objects

When you add (e.g., draw, paste or import) an object to the design it appears in the stack
together with other objects. The order of objects in the stack is defined by one of two possible
methods:

A new object appears right above a currently selected object. To make this happen, there
must be a selected object in your document, and the Draw/insert above the selection
option should be activated.
A new object becomes the upper object in the active layer. The app works in this way
when nothing is selected. To have this behaviour all the time, deactivate the Draw/insert
above the selection option in the Preferences.

Change the Order of Layers

To reorder layers, drag a layer to a new position in the list.

You can also use drag and dropping to place a layer inside another layer or to move a sublayer
outside its parent layer.

Change the Order of Objects

To reorder objects, drag an object to a new position in the list.

An alternative way to change the order of objects is to use commands from the Modify >
Arrange menu. The same set of commands is available in the context menu of the object on
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the canvas.

Move an Object to Another Layer

You can move objects between layers. To do this, drag and drop an object from one layer to
another. The Layers panel lets you select several objects and move them together.

Another way is to cut an object. Activate a destination layer and then paste the copied object.
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Blending Layers
A blend mode determines how pixels of the upper layer interact (or blend) with pixels of a lower
layer. Blending applies to objects in the same way as to layers. So, to make the page easier to
read, we'll only talk about layers.

To select a blend mode, use a drop-down menu at the top of the Layers panel.

To see any visual effect from applying a blend mode or transparency, the upper layer should
overlap the lower layer(s).

Transparency

Making a layer transparent is one of the ways to mix the color of its pixels with the pixels of the
layer beneath.

When you decrease the Opacity parameter in the Layers panel, you make the contents of the
layer more transparent. This increases the impact of the lower layer pixels on the result.

Opacity 100%

 

Opacity 70%

 

Opacity 20%

Layer Blending

The default blend mode is Normal. If the top layer is opaque, then only that layer determines
the color. Otherwise, the result depends on the color of the top layer pixel, on the level of its
transparency, and on the color of the underlying layer pixel.

The rest of the blend modes calculate color in a more complicated way, but they always take
the transparency into account.
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Let's consider a few examples.

Normal blend mode

In the earlier subsection, we can see the Normal blend mode with different levels of opacity
applied to the upper layer.

Multiply blend mode

The Multiply blend mode makes the overlap area darker. Within grayscale, if we use 0 for black
and 1 for white, then two gray colors with level 0.5 will blend into a dark gray at 0.25.

Screen blend mode

The Screen blend mode produces brighter colors. In the same example as we used for Multiply,
two gray colors at 0.5 each will create light gray with level 0.75.

Difference blend mode

The Difference blend mode creates lighter colors when the colors you blend are different.
Blending similar colors makes the overlap area dark. Blending identical colors creates black.
Blending with black produces no change.

It is recommended that you use the blend modes with RGB colors applied to the objects and
the document. With the CMYK color model, you may have less predictable results.

If you wish to read about other blend modes, please read the Blend modes article on Wikipedia.

https://en.wikipedia.org/wiki/Blend_modes
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Vector Graphics
Graphics in your designs are primarily based on vector objects (paths and shapes). These
objects appear on the canvas as anchor points and curves. Internally, they are mathematically
defined via coordinates of anchor points and curvature of lines that pass through those points.
Due to this, vector graphics can be scaled with no quality loss.

Original image

Zoomed in vector image

Zoomed in raster image

All drawing tools in the program create objects that are based on paths. A path is a thin vector
line that enables you to edit it. Paths are explained in detail in the Path and its Features section.

You can apply a number of properties such as stroke or fill to a path to make the object look as
you need. Although the path itself is vector, some effects that you can apply to it can be raster-
based (e.g., gradient fill or shadow). In the case of such a combination of vector and raster
graphics, you should take into account the resolution of the raster parts.

Text is also vector. It is based on glyphs provided by a selected font. You can convert text to
paths in order to edit the shape of individual characters.
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Path and its Features
Drawing tools create objects that are based on paths. Although a line, brush stroke or
geometrical figure may look very different, their shape is defined by a thin line called the path.
The path itself is invisible on the canvas unless you select it. The object becomes visible thanks
to an applied stroke, brush, fill or other properties.

Path with all properties turned off
You can see it only because it is selected

Path with Stroke

Path with Brush

All paths are made up of anchor points and segments (lines that link points). So, the simplest
path consists of one segment and two anchor points at its ends. A path is closed if its start and
end points are the same point.

Paths are listed in the Layers panel as items named Path.

The color of a selected path on the canvas (don't confuse it with a stroke) coincides with the
color of the layer the path belongs to. This color is indicated in the Layers panel as a vertical
line to the right from the check boxes. The same color is used to display the selection frame.
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Features of a Path

1 - Straight segment.

2 - Corner rounding handle.

3 - Direction point. A direction point works as a handle to manipulate the respective direction
line.

4 - Direction line.

5 - Anchor point.

6 - Curved segment.

Segments

Depending on the way you draw a segment, it can be straight or curved. You can change the
shape of segments by editing the path.

Anchor Points

Anchor points define the shape of a path in two ways. Primarily, they are intermediate points for
the path. So, by changing the location or amount of the intermediate points, you can
significantly change the shape of the path.

The location of an anchor point defines the shape of the path

Also, anchor points can have direction lines that let you adjust the curvature of the
corresponding segments. In this case, anchor points in the middle of the path have two
direction lines because two segments are attached to this point. An end point has only one
direction line.
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Corner Points and Smooth Points

Any anchor point is either smooth or corner point. The Edit a Path section explains how to turn
an anchor point from one type to another.

Corner point

Smooth point

At a corner point, a path breaks, creating a corner. Corner points often have no direction lines.
At a smooth point, the path creates no corner. This happens because the angle between the
direction lines is 180 degrees. With any other angle, the segments will create a corner. The
segments that are attached to the same corner point can be straight or curved in any
combination.

A corner anchor point will not show direction lines by default even if you select it. The direction
points of a corner point and the corner point itself have exactly the same location. Because of
this, the direction lines have zero length and, consequently, are not visible.

The Change the Type of an Anchor Point subsection explains how to convert a smooth point to
a corner point and vice versa.

Rounding Corners

The app can display a handle near a corner point when the Selection tool is activated. This
handle lets you change the radius of the rounded corner. Read the Rounding Corners section
for more details.
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Direction Lines and Direction Points

Direction lines let you change the direction and curvature of a segment. To operate a direction
line, you should drag its direction point. You can adjust the angle and length of direction lines.

Changing the direction line angle

Changing the direction line length

The Manipulate Direction Lines subsection explains how to work with direction lines.
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Draw a Path with the Pen Tool
The Pen tool  lets you draw both straight and curved lines. To draw a path, you should add
one segment after another. If any of the added anchor points or segments require adjustments,
you can edit the path after it is created.

Controls of the Pen Tool

The Pen tool displays several options in the Control panel. They let you choose different modes
of the tool. The use of those modes is discussed further in this section and also in Edit a Path.

1 - Pen tool to draw a path. In this mode, you add anchor points to create a new path.

2 - Add an anchor point to an existing path. Click on the path with this tool.

3 - Delete an anchor point. Click on the anchor point with the tool.

4 - Convert anchor point mode. This mode can be temporarily activated by pressing the Option
key. In this mode, you can:

Click on an anchor point to select it.
Click on an anchor point and drag to convert a corner point into a smooth point.
Click on a smooth point to convert it into a corner point.
Drag a direction point to adjust the curvature of one segment keeping another segment
unchanged.
Option-drag a direction point to adjust the curvature of both segments that are connected
to the anchor point.

5 - Convert a selected anchor point to the corner point type.

6 - Convert a selected anchor point to the smooth point type.

7 - Remove selected anchor points.

You can change the anchor point type from smooth to corner or vice versa by double-clicking
on that point with the Pen tool. To remove a direction line (actually make its length equal to
zero), click on its direction point with Pen holding down the Option or Shift key. This also turns
a smooth point into a corner.

Draw a Straight Line

1. Activate the Pen tool.
2. Click at the point where the line should start.
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3. Click at the point where the line should end.
4. Hit the Escape key to finish drawing.

Draw a Polygon

1. Activate the Pen tool.
2. Click at the point where one of the polygon's corners should be located.
3. Click several times at points where other corners should appear.
4. Click on the first point to close the outline of the polygon. A circle near the cursor

indicates that the program will close the shape if you click.
5. Hit the Escape key to finish drawing.

Draw Curved Path

1. Activate the Pen tool.
2. Place the cursor at the point where the path should start.
3. Press and hold the left mouse button.
4. Move the cursor aside to see the direction lines. Both the length and angle of the direction

lines will affect the curvature of the path you draw. Release the button.

Another way to adjust the direction lines is to press and hold the Option key. Then drag
the corresponding direction points. When done, release Option and continue drawing.

5. Move the cursor to the next point.

6. Repeat the three preceding steps.
7. Click on the first point if you want to close the shape.
8. Hit the Escape key to finish drawing.

Notice that you can combine curved and straight segments.

As an alternative technique of drawing a curved path, you can create it out of straight
segments. Then make them curved as explained on the Edit a Path section.

While you are drawing a path, you can switch the type of a segment that you are about to add,
from curved to straight. To do this, click on the point that is currently the last point of the path.
If a future segment, the one between the last point and the cursor, is already straight, a single
click on the last point won't change anything.

In the middle of the path drawing process, you can add and remove anchor points. To do that,
switch the Pen tool to the appropriate mode. Then you can continue drawing in the main mode.
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Continue Drawing an Existing Path

After you have finished drawing a path, it is possible to add more segments at one of its ends.
To do this, select the path and then activate the Pen tool. The anchor point that was added the
last may have an additional circle around indicating that a new segment will begin at this point.

If no point was selected by default, or you want to choose the opposite end of the path, select
the respective point with the Selection tool. Then activate the Pen tool to draw a segment. To
stop drawing, press the Escape key.

Stroke Width and Color

To change the stroke width and color, use the Appearance panel. To change the stroke width,
you can also use these keys: [ to decrease, and ] to increase.

Modifier Keys and Shortcut Summary

Shortcut:

P activates the Pen tool.

Pen tool modifier keys:

Space switches to the Pan mode.
Command switches to the Selection tool.
Option activates the Convert Anchor Point tool.
Shift-clicking lets you select multiple anchor points.
Drag a direction point with Option in the Convert Anchor Point mode to adjust the path
curvature in both directions.
To remove a direction line (make a corner), click on the respective direction point holding
down the Option or Shift key.
[ decrements the stroke width.
] increments the stroke width.



109

Create a Path with the Draw Tool
The Draw tool  is a freehand tool. It creates a curved path that follows the cursor as you
draw. You can use it to create graphics that resemble a hand-drawn image. It is possible to edit
the created path.

Unlike the Pen tool, with which you place anchor points directly, the Draw tool adds anchor
points automatically depending on the curvature of the path. An almost straight path may
require only two anchor points on its ends, while a zigzag requires an anchor point every time it
changes its direction. Another factor that determines the amount and location of anchor points
is the Smoothing parameter. We will discuss it later.

The Draw tool operates in two modes. Any time you draw, you are actually using either the
Pencil or Brush tool. The Draw tool creates a path. How this path looks depends on whether
the Stroke or Brush property is applied to the path. You can switch between Stroke and Brush
using the Appearance panel.

When you are using the Draw tool, the app hides the Fill property of the object that you draw.
This helps you see the object and surrounding design more clearly. As soon as you finish
drawing, the Fill can appear on the object. This happens, if the Allow filling option is activated
in the Preferences dialog, and if the current style includes the Fill property.

To continue drawing a path that you created earlier, select this path using the Move or
Selection tool. Then activate the Draw tool and draw beginning from one or another path end.
Such use of the tool requires that the path is open and the Allow to continue the Path option
is enabled in the Preferences dialog.

In order to temporarily switch to the Selection tool, press and hold the Cmd key.

Settings of the Draw Tool

Settings of the Draw tool are located in the Control panel.

The Smoothing parameter defines the amount of smoothing applied to the path. Higher values
make the curve more smooth. If you want to create a path that follows the cursor as accurately
as possible, set the parameter to "0".

The Close Radius option enables the automatic closing of the path that you draw. When the
distance between the end and start points is smaller than the specified value, the app closes
the path. The distance is measured in the "screen pixels" and, consequently, doesn't depend
on the canvas zoom level.

To quickly change the stroke width before or after drawing it, use these keys: [ to decrease, and
] to increase.
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Stroke Profile

The Profile pop-up menu lets you choose one of three modes of the tool: Uniform, Pressure
and Custom.

The Uniform profile lets you create a Stroke with constant width. It is used for the Pencil tool.

The Custom profile allows variable width strokes. It can be used with both Pencil and Brush
tools. The Brush tool changes the stroke width depending on the direction of the path. The
Pencil tool can produce lines with variable width if you select a non-uniform profile in the
Stroke settings.

The Pressure profile lets you control the Stroke width of the Pencil tool while you are using a
stylus with a pressure sensor. The more pressure you apply, the thicker the stroke becomes.
Click on the gear icon to access settings of this profile.

The Width parameter defines the maximum stroke width. It mirrors the Width parameter for a
stroke in the Appearance panel.

The Variation parameter defines how much the stroke width changes depending on the
pressure.

With lower values of Accuracy, the program normalizes the stroke width depending on the
length of the path. So, while you are drawing, the already drawn part of the path can re-adjust
its stroke width automatically. To make the stroke width remain exactly as you have drawn it,
set the Accuracy to 100%.

Modifier Keys and Shortcut Summary

Shortcut:

D activates the Draw tool.

Draw tool modifier keys:

Command switches to the Selection tool.
[ decrements the stroke width.
] increments the stroke width.
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Draw a Path with the Pencil Tool
Pencil is a freehand drawing tool. It creates a path that follows the cursor as you draw. The
Pencil tool is, in fact, the Draw tool that draws with a stroke.

To activate the Pencil tool, click on the Draw icon  in the Tools panel. Before using it, make
sure that a stroke is selected in the Appearance panel.

Settings of the Pencil tool are located in the Control panel. They are described in the Create a
Path with the Draw Tool section.

The Pencil tool supports all of the profiles that you can select in the Profile pop-up menu.

The Pencil tool can work with a stylus that has a pressure sensor. By applying different
pressure, you can change the thickness of the stroke while you are drawing. To enable the
pressure sensitivity, activate the Pressure option in the Control panel. There are several
parameters that control drawing with variable pressure. You just click on the gear icon in the
Control panel to access them.

Once you finish drawing, you can modify the created graphic. To edit the path, use tools and
methods described in the Edit a Path section. To change how your graphic element looks, use
the Appearance panel.
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Draw a Path with the Brush Tool
Brush is a freehand drawing tool. It creates a path that follows the cursor as you draw. The
Brush tool is, in fact, the Draw tool that draws with a Brush stroke.

To activate the Brush tool, click on the Draw icon  in the Tools panel. Before using it, make
sure that a Brush is selected in the Appearance panel.

Settings of the Brush tool are located in the Control panel. They are described in the Create a
Path with the Draw Tool section.

Brush requires that you select the Custom profile in the Control panel. Brush does not use the
pressure information when you draw with a stylus. For that reason, the Pressure profile cannot
be used with the Brush tool. If you select an incompatible profile, the active tool will switch
from Brush to Pencil.

Once you finish drawing, you can modify the created graphic. To edit the path, use tools and
methods described in the Edit a Path section. To change how your graphic element looks, use
the Appearance panel.
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Edit a Path

Choose the View Mode

Objects in your document can be displayed with all their features or as wireframes.

In many cases, the regular view mode is convenient for editing a path. If you prefer a clear view
when no strokes, fills or other effects are visible, you can activate the Outline Preview mode by
selecting View > Outline Mode in the main menu.

Object is not selected

 

Path is selected in Normal mode

 
Path is selected in Outline Preview mode

Select a Path

To work with a path or anchor point, you should select it. You can select either the entire path,
individual anchor points or all anchor points.

To select the entire path, click on it with the Selection tool . You can also click on the
object's stroke, or even filled area, depending on what is visible and easier to reach.

The Selection tool lets you select a path by drawing a selection frame around it. To do this,
place the mouse pointer over an empty space. Press the left button and move the mouse
toward the object. Once the selection frame touches the path, the latter becomes selected.
Notice that you can select several paths in this way. Also notice that this method selects all
anchor points that you outline.

Select Anchor Points

In order to select an anchor point, select the path first. Then click on the anchor point with the
Selection tool. To select several anchor points Shift-click on each of them.
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You can select multiple anchor points using the selection frame as explained above.

Sometimes it may be difficult to select certain anchor points using the selection frame because
anchor points that shouldn't be selected also appear inside the frame. If there are only a few of
those that were selected unintentionally, you can deselect those anchor points by Shift-clicking
on them.

Selecting Points Using the Lasso Tool

The Lasso tool  can help you select anchor points when the selection frame is not
effective. Outline one or more anchor points that you want to select with Lasso. This tool lets
you select extra points in addition to those that are already selected. To do this, press and hold
the Shift key before using the Lasso tool. An opposite technique is also supported. You can
select all of the object's anchor points and then deselect those that you don't need. This can
be done by selecting a range of anchor points with any suitable tool. After that, holding down
the Option key, outline points that you want to deselect with the Lasso tool.

With the Lasso tool, you can also select handles that are used for rounding corners.

Controls of the Selection Tool

The Control panel displays the following options when the Selection tool is activated.

1 - Edit a segment by dragging. You can grab and bend the segment at any point. The ends of
the segment will preserve their locations.

2 - Convert a selected anchor point to the corner point type.
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3 - Convert a selected anchor point to the smooth point type.

4 - Delete a selected anchor point.

5 - Link two ends of a path with a straight segment. If you select an open path, the command
will close this path. The command can also join two open paths if you select one end point of a
first path and another end point of a second path.

6 - Cut the path at a selected anchor point(s). The tool does not create any visible gap because
the ends of the created paths will coincide at the cut points.

Add an Anchor Point

1. Activate the Pen tool .
2. Click on a path where you want to add a new anchor point. Adding an anchor point will

not change the shape of the path.

The same can be done in the Add Point mode  selected in the Control panel.

Delete an Anchor Point

You can use either the Pen or Selection tool to delete anchor points.

Delete an Anchor Point Using the Selection Tool

1. Activate the Selection tool .
2. Select an anchor point.
3. Click on the Remove Point button  in the Control panel in order to delete the selected

anchor point.

You can select multiple anchor points using the Selection or Lasso tool in order to delete them
together.

Delete an Anchor Point Using the Pen Tool

1. Activate the Pen tool .
2. Click on the Remove Point button  in the Control panel.
3. Click on an anchor point that should be deleted.

Link Anchor Points

You can link end points of the same path or end points of two independent paths. In both
cases, the points will be connected with a straight segment.

To close a path, select it with the Selection tool . Then click on the Join button .
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To link two independent paths, make sure that none of them is closed. Using the Selection tool
, select one end point of each path that should be linked. Then click on the Join button 

.

Set the Type of an Anchor Point

Anchor points can be of smooth or corner type.

To set the type of an anchor point:

1. Activate the Selection tool .
2. Select an anchor point.
3. Choose one of the Convert options in the Control panel.

You can also convert an anchor point to another type while the Pen is activated. It has the
Convert buttons as well.

Another way to change the anchor point type is to double-click on it with the Selection or Pen
tool.

Finally, you can turn a smooth point into a corner point by changing the angle between the
direction lines from 180 degrees to any other angle. To do this, use the method described in the
Adjust Direction Lines of a Corner Point subsection.

Change the Shape of a Corner

One more way to reshape a path is to change the shape of the corner created by this path. For
example, you can turn a sharp corner into a rounded one.

Sharp corner  Rounded corner

How to do this is explained in the Rounding Corners section.

Manipulate Direction Lines

You can change the length and angle of direction lines using the Pen and Selection tools. To
do this, drag the respective direction point to a new position. The difference between the two
tools will be explained further.

You should select an anchor point in order to access its direction points. If a selected anchor
point displays neither direction lines nor direction points, read the Show Direction Lines of a
Corner Point subsection.

It is possible to move one or two direction points at the same time. By manipulating only one
direction point, you can change the angle between direction lines attached to the same anchor
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point. In this way, you will convert the latter to a corner anchor point. By moving both direction
points synchronously, you can keep the angle between the direction lines equal to 180 degrees.
As a result, the anchor point will remain smooth. Note that the second case is possible only if
the original anchor point is smooth.

Adjust Direction Lines of a Smooth Point

Activate the Selection tool . Select an anchor point. Place the cursor over one of the
direction points, press the left mouse button and drag aside. In this way, you can adjust the
length of the direction line whose point you are moving, and you can also change the angle of
both direction lines. The anchor point will remain smooth.

Adjust Direction Lines of a Corner Point

Activate the Selection tool . Select an anchor point. Place the cursor over one of the
direction points. Holding down the Option key, drag the point aside. In this way, you can adjust
the length and angle of the direction line whose direction point you are moving. The other
direction line will not be affected.

If you use this technique against a smooth anchor point, you will convert it into a corner point.

The same result can be achieved using the Pen tool . Just activate the tool and select the 
 option. Drag a direction point in order to adjust the angle and length of its direction line.

Show Direction Lines of a Corner Point

Direction lines become visible when you select an anchor point. However, direction lines may
not be visible when the direction points are located exactly over the respective anchor point.
This makes the length of the direction lines equal to zero. This is true for corners of a polygon.
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Direction lines are not visible

Smooth point displays its direction lines

You can drag a direction point off its anchor point in order to work with direction lines. By doing
this, you will set the length and angle of the direction lines.

Modifier Keys and Shortcut Summary

Shortcuts:

A activates the Selection tool.
L activates the Lasso tool.

Selection tool modifier keys:

Space switches to the Pan mode.
Command switches to the Move tool.
Shift-clicking lets you select multiple anchor points.

Lasso tool modifier key:

Space switches to the Pan mode.
Shift lets you select more anchor points in addition to already selected ones.
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Simplify a Path
You can create several paths that have the same shape using different numbers of points. This
is possible because points may make different impacts on the shape depending on their
location and also on properties of their direction lines.

When we talk about simplifying a path, we mean removing unnecessary anchor points trying to
preserve the original path shape.

You may want to simplify paths because it is easier to edit a path which has less points. Also,
reducing the number of points might increase the performance of the app with complex
designs.

Some paths cannot be simplified because most or all of the points are important for the path
shape. For example, a rectangle has four points. Removing any of them would affect the shape
significantly.

To simplify a path select it. If you wish to see points of the path, select it with the Selection tool
. Then choose Modify > Path > Simplify… from the main menu to open the Simplify

dialog.

Use the Curve Precision slider or edit box to adjust the number of points. Check how much
the path shape changed in your design. It is useful to compare the shapes of the original and
current paths making sure that the difference between them is acceptable. To display the
original path, activate the Show Original Path check box. Your goal is to make the Result
number of points less than the Original.
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Here is an example of a simplified path.

Original path
36 points

 

Simplified path (blue)
12 points
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Draw Lines and Shapes
There is a set of tools in the Tools panel that lets you draw lines and primitive shapes.

1 - Rectangle Tool: creates rectangles

2 - Rounded Rectangle Tool: creates rectangles with rounded corners

3 - Ellipse Tool: creates ellipses and circles

4 - Polygon Tool: creates polygons with a customizable number of sides

5 - Star Tool: creates stars with a customizable number of points

6 - Line Tool: draws straight lines

7 - Arc Tool: creates arcs and sectors

Smart Shapes

The tools create objects of different types. The Line, Rectangle, Ellipse and Arc tools create
regular objects (paths) as those you can draw using the Pen tool. The other objects are smart
shapes: Star, Polygon and Rounded Rectangle. These are parametric objects that let you vary
their shape after an object has been drawn.

If you click on a smart shape with the Selection tool, you won't see anchor points. Instead,
smart shapes have round handles. The handles are pre-programmed to change the object's
shape in a particular way such as adjusting rounded corners. If you drag a handle of a rounded
rectangle, you will edit all of its corners because all of the handles are selected by default. In
order to manipulate only one handle, you should click on it, and then all the rest will become
deselected. You can select several handles by Shift-clicking on them.
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In addition to that, smart shapes display their properties in the Control panel.

More information about editing corners can be found in the Rounding Corners section.

You can turn a smart shape into a regular object by calling the Expand command from the
context menu or Control panel. Then you will be able to edit the object by working with anchor
points. Notice that it is not possible to convert a path into a smart shape.

Line

Draw a Line

1. Activate the Line tool.
2. Place the cursor on the canvas where a new line should start.
3. Press and hold the left mouse button.
4. Move the cursor to the point where the line should end.
5. Release the mouse button.

Basically, a line created with the Line tool is no different from a single straight segment of a
path drawn using the Pen tool.

Star

Draw a Star

1. Activate the Star tool.
2. Place the cursor on the canvas where the center of a new star should appear.
3. Press and hold the left mouse button.
4. Move the cursor aside in order to define the size and orientation of the object.
5. Release the mouse button.

Properties of the Star Object

The Control panel lets you change the number of points, the Inner Radius and Corner
parameters.
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You can adjust the size of the space taken by the body of a star using the Inner Radius
parameter.

By making the Corner greater than zero, you can make the points of the star rounded or to
have other predefined shape. You can choose the shape after clicking on the gear icon in the
Control panel.

Polygon

Draw a Polygon

1. Activate the Polygon tool.
2. Place the cursor on the canvas where the center of a new polygon should appear.
3. Press and hold the left mouse button.
4. Move the cursor aside in order to define the size and orientation of the object.
5. Release the mouse button.

Properties of the Polygon Object

The Control panel lets you change the number of sides of a polygon.

By making the Corner greater than zero, you can make the corners of the polygon rounded.
The corners can be not only rounded, but they can have other shapes as well. You can choose
the shape after clicking on the gear icon in the Control panel.

Rectangle

Draw a Rectangle

1. Activate the Rectangle tool.
2. Place the cursor on the canvas where a corner of a new rectangle should appear.
3. Press and hold the left mouse button.
4. Move the cursor to the point where the opposite corner should be located.
5. Release the mouse button.
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Rounded Rectangle

Draw a Rounded Rectangle

1. Activate the Rounded Rectangle tool.
2. Place the cursor on the canvas where a "corner" of a new rectangle should appear

meaning an imaginary corner if it wasn't rounded.
3. Press and hold the left mouse button.
4. Move the cursor to the point where the opposite corner should be located.
5. Release the mouse button.

Properties of the Rounded Rectangle Object

You can choose the shape of the corners after clicking on the gear icon in the Control panel.

You can also choose different shapes for the corners.

Ellipse

Draw an Ellipse

1. Activate the Ellipse tool.
2. Place the cursor on the canvas where a corner of the bounding box of a new ellipse

should appear.
3. Press and hold the left mouse button.
4. Move the cursor to the point where the opposite corner should be located.
5. Release the mouse button.

Arc and Sector

Draw an Elliptical Arc

1. Activate the Arc tool.
2. Select the Elliptical Arc mode in the Control panel.
3. Place the cursor on the canvas at the starting point.
4. Press and hold the left mouse button.
5. Move the cursor to the point where the end point should be located.
6. Release the mouse button.
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Draw a Circular Arc or Sector

1. Activate the Arc tool.
2. Select either Circular Arc or Circular Sector mode in the Control panel.
3. Place the cursor on the canvas at the center or the future object.
4. Press and hold the left mouse button.
5. Drag the cursor until you have a circle with the proper diameter.
6. Place the cursor at the point where the arc or sector should start and release the mouse

button.
7. Move the cursor to the point where the arc or sector should end and click.

Modes of the Arc Tool

The Control panel lets you choose the type of object you want to create. Notice that you must
select the type before drawing. There is no possibility of switching the type of already created
objects.

 - Elliptical Arc

 - Circular Arc

 - Circular Sector

In the Elliptical Arc mode, you can change the direction in which the arc bends using the
Direction button . The same can be done by pressing the X key.

Draw Shapes with Fixed Center

When you draw a line in the default mode, you define the location of each line's end. Similarly,
when you draw a shape, you define the locations of opposite corners of the object's boundary.

Sometimes, the center of a new line or shape should be located at a particular point. In this
case, you can indicate the position of the object's center using the Option key.

Before you start drawing, press and hold the Option key. Place the cursor where the center of a
future object should be. While you are drawing a new object, its center will stay fixed. The
position of the cursor will change only the size of the object.

Further Editing

Primitive shapes might be the basis for creation of more complex graphics.

You can combine shapes using Boolean operations.

To edit the path of a shape, use tools and methods described in the Edit a Path section. To
change how your graphic element looks, use the Appearance panel.
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To quickly change the stroke width before or after drawing it, use these keys: [ to decrease, and
] to increase.

Modifier Keys and Shortcut Summary

Shortcuts:

R activates the Rectangle tool.
Shift-R activates the Rounded Rectangle tool.
O activates the Ellipse tool.
Shift-O activates the Polygon tool.
Shift-S activates the Star tool.
/ activates the Line tool.

Shape tools' modifier keys:

Space switches to the Pan mode.
Option lets you draw a shape around the specified center.
[ decrements the stroke width.
] increments the stroke width.

Elliptical Arc modifier key:

X inverses the direction of the arc.
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Stroke
You can apply one or multiple strokes to a path using the Appearance panel. For a complete
description of the panel's interface, refer to the Appearance Panel section.

To open or hide the Appearance panel, use the Window > Appearance command from the
main menu.

1 - Strokes are listed in the Appearance panel among other properties.

2 - Add stroke.

3 - Delete stroke.

4 - Stroke width.

5 - Open stroke properties.

6 - Stroke color. Clicking this button opens the Color panel.

Add and Delete a Stroke

Before adding or deleting a stroke, you should select a path in your design.

To add a stroke, click on the ring icon in the bottom bar of the Appearance panel.

To delete a stroke, select it in the Appearance panel. Then click on the trash bin icon.

It is possible to hide a stroke without actually removing it. To do this, use the respective check
box in the Appearance panel.

Edit Stroke Width

The Path Width tool  lets you customize the variable width of the Stroke. If the object has
several Strokes, the tool will modify the upper Stroke. In order to edit a lower Stroke, drag it to
the upper position in the Appearance panel. When the editing is finished, move the Stroke to
the original position.
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The path that you are going to edit must have a Stroke applied. If the most part of the stroke
should have a certain width, then you can set that width in the Appearance panel.

To modify the width, select a path, and then activate the Path Width tool. Place the cursor at a
point where the width should be changed. A handle will appear on the path near the cursor.

Drag the handle off the path to set a new width at the selected point. This point will have three
handles. If you drag the handle in the middle, the point that defines the width will move along
the path. If you drag any of the handles on the sides, you will adjust the stroke width.

While holding down the Option key, you can move a handle on only one side. This lets you
create non-symmetrical strokes.

If you deactivate the tool, the handles will disappear until you activate the tool again.

The Path Width tool lets you manipulate only the stroke width handles. For other operations
like selecting, moving or resizing objects, you should activate an appropriate tool.

Modifier Keys and Shortcut Summary

Shortcut:

W activates the Path Width tool.

Path Width tool modifier keys:

Space switches to the Pan mode.
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Command switches to either Move or Selection tool depending on which of them was
active most recently.
Option lets you move a handle on one side keeping the position of the opposite handle
unchanged. This makes the stroke asymmetrical in relation to the path.

Properties of a Stroke

The Appearance panel gives you direct access to the width and color of strokes. The Color
panel is described in the Color Panel section. To access all available properties, click on the
gear icon.

The Width parameter is the same as the width you can set in the Appearance panel.

The Cap options define whether the stroke should end where the path ends, or it should go a
half-width farther. In the second case, you can choose if the stroke should be rounded. The
option applies to a solid line as well as to individual elements of dashed or dotted lines.

The Corner options let you select how the stroke looks at corners. You can make it sharp,
rounded or clipped.
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The Limit parameter lets you set up the miter limit. It defines how far a stroke can stretch out in
sharp corners. The spike gets cut off depending on the angle and miter limit. This parameter
has no effect with rounded or clipped corners, as well as when Align is set to the right option.

Let's compare corners with different angles and stroke widths at tree miter limit values.

Miter limit 21

Miter limit 20

Miter limit 8

We can see that the corner with smaller angle gets clipped at higher value of miter limit. The
clipping does not depend on the stroke width.

The Align options let you align a stroke to the center of the path, or outside or inside of the
shape. Notice that the alignment options can work only with closed paths.

The following set of controls lets you create dashed and dotted lines.

In the middle, there is a drop-down menu with patterns that have different combinations of dots
and dashes.

Any dashed line can be described as a sequence of dashes and gaps of a particular length. So,
in order to create your own pattern, you can fill in the dash and gap fields at the top. For
example, to create a pattern like "long dash - gap - dot - gap", you can type in 10 - 5 - 1 - 5
starting from the leftmost dash field.
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These settings

create this pattern (shown with the ruler)

The slider below the menu with patterns moves the pattern along the path. With this slider, you
can place dashes at corners of your shape or align the pattern to other features of the path.

The two pairs of identical controls let you add arrowheads or other elements to a Stroke at the
path ends.

To add an arrowhead to a Stroke, choose a pattern from the drop-down menu. In order to
adjust the arrowhead's size, change the numeric value below the drop-down menu.
Arrowheads and dashed patterns are supported only with the Uniform profile. They will not be
applied to the Stroke if you choose a variable-width profile.

You can change the profile of a Stroke.

By default, strokes have the Uniform profile that creates lines with constant width. However,
there are other options as well. For example, the stroke width can gradually change from max
to min value along the path.
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You can add your own profile to the list if you wish to reuse it. To do this, you create a new
profile using the Path Width tool. Bring up the list of profiles and click the plus button. To delete
a custom profile from the list, select this profile and click on the trash bin icon.
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Brush
You can apply one or multiple brush strokes to a path using the Appearance panel. For a
complete description of the panel's interface, refer to The Appearance Panel section.

To open or hide the Appearance panel, use the Window > Appearance command from the
main menu.

1 - Brush strokes are listed in the Appearance panel among other properties.

2 - Add a brush stroke by clicking the plus button.

3 - Delete a brush stroke.

4 - Brush stroke width.

5 - Open brush stroke properties.

6 - Brush stroke color. Clicking this button opens the Color panel.

Add and Delete a Brush Stroke

Before adding or deleting a brush stroke, you should select a path in your design.

To add a brush stroke, click on the plus icon in the bottom bar of the Appearance panel and
choose Brush from the drop-down menu.

To delete a brush stroke, select it in the Appearance panel. Then click on the trash bin icon.

It is possible to hide a brush stroke without actually removing it. To do this, use the respective
check box in the Appearance panel.

Properties of a Brush Stroke

The Appearance panel gives you direct access to the width and color of brush strokes. The
Color panel is described in the Color Panel section. To access all available properties, click on
the gear icon.



134

The top of the panel displays an oval on the left (we'll discuss later), and a sample line on the
right that displays how your stroke would look in the design.

The Width parameter is the same as the width you set in the Appearance panel. Since a brush
stroke may have variable width, the value you set is the maximum width.

Note that to see features of a brush stroke, its width should be set to several pixels or more.
Otherwise, it will look like a regular stroke.

The Angle parameter lets you rotate the brush.

Roundness can make the brush either round or oval.

The oval at the top of the panel is actually a tool that can change the Angle and Roundness at
the same time. In order to change the values, drag the blue handle around the center.

Using Presets

At the bottom of the panel, you can see the library of presets.

To apply a preset, click on its icon.

To save the current brush parameters as a preset, click the plus button.

To delete a preset, right-click on its icon and choose the Remove command.
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The Appearance Panel
The Appearance panel lets you manage the object's Fill, Stroke and other effects. To open the
panel, choose Window > Appearance from the main menu.

1 - Each line contains one effect, such as Stroke or Shadow.

2 - Hide or show an effect. Uncheck an effect to remove it from the design but still have the
ability to easily re-apply it again.

3 - Add an effect. You can choose from a list of all supported effects: Fill, Stroke, Gradient,
Brush, Inner Glow, Outer Glow, Inner Shadow, Shadow and Blur.

4 - Add a stroke.

5 - Add a fill.

6 - Swap the colors of a stroke and fill. If an object has multiple strokes or fills, only the upper
stroke and upper fill exchange their colors. The rest remain unchanged.

7 - Change the color.

8 - Show a panel with the effect's settings. Some of the settings, such as the color or stroke
width, can be accessed from the Appearance panel directly.

9 - Restore the default object's Fill and Stroke and also remove all of the customized
properties.

10 - Delete the selected item.

The panel has the context menu. You can open it by right-clicking on an item in the list like
Stroke or on empty space. The menu has these commands:

Add adds a Stroke, Fill or an effect. This command does the same as the plus button at
the bottom of the panel.
Duplicate creates a copy of the selected item in the list.
Delete removes the selected item from the list.
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Copy Style copies the style of a selected object. This includes all of the strokes, fills and
effects present.
Paste Style applies the copied style to a selected object.
Reset Style applies the default Fill and Stroke and also removes all of the customized
properties.
Swap Stroke/Fill (Shift+X) swaps the colors of the object's stroke and fill.

Changing the Order of Effects

Effects in the Appearance panel are ordered in the same way as they were applied to an object.

The arrangement of effects atop one other defines how the object looks on the canvas. Two
rectangles below have identical paths, stroke and color fill. The only difference is that the left
one has the stroke below the fill. The rectangle on the right has the opposite order of effects. As
you can see, when the stroke is behind the color fill, half of the stroke width is invisible, making
it look two times thinner.

 

To change the order of effects, drag one to a new position.

The ability to place certain properties or effects above or below others in the list depends on
their type. These types are presented in the Appearance panel as sections separated with lines.
Let's take a text object as an example. The panel has separated all properties into three
sections.
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The Text entry always occupies the top of the list. The section in the middle can contain only
Fill, Stroke, Gradient or Brush entries in any order. The lower section is for Inner Glow, Outer
Glow, Inner Shadow, Shadow or Blur. You can rearrange properties within their own section, but
placing them into another section is not possible.

The Style of an Object

Any object in your design has particular effects set up in a certain way. We call such a
combination of effects "style".

In order to apply exactly the same style to a second object, you can copy this style. To do this,
select the first object and choose Edit > Copy Style from the main menu. Then select the
second object and use the Edit > Paste Style command. These commands are also available
in the context menu which can be opened by right-clicking on an object.
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Introduction to Colors
Most objects allow you to choose colors for Stroke, Fill and effects such as drop shadow.

Color Modes

The app supports the RGB and CMYK color modes for storing object colors in the document.
You can choose a color mode in the New Document dialog when you are creating a new
document. To change the color mode later on, use the Document Settings dialog. You should
take into account that the CMYK color space supports less color tones than RGB does. As a
result, switching from RGB to CMYK may make some parts of your design look darker and
more dull. The Usage of the RGB and CMYK Color Modes page will help you decide which of
the color modes to choose.

Color Models

The app lets you choose colors using the RGB, CMYK and HSB color models (color spaces) in
the Color panel. They use different ways to create a color out of components.

If a color model selected in the Color panel differs from the color mode of the document, than
the app will convert the color that you pick to the document's color mode. For example, if the
Document Settings dialog indicates that you have a CMYK document, but you set a color using
the RGB sliders, than those RGB color will be converted to the CMYK color model.

The Color panel allows you to select the CMYK color space for particular object properties
such as Fill or Stroke in an RGB document. Such technique ensures that your document will
look in the same way after printing or converting to CMYK. It is preferable to use the same color
model for all objects in your document to make colors in it more predictable.

RGB

RGB is based on the mixture of the red (R), green (G) and blue (B) colors. The RGB color model
is commonly used to display colored graphics on the screen. Sources of red, blue and green
light optically mix their lights to create a final color. As a consequence, the more that each
component is present, the brighter the result. RGB images are frequently used on the Web.

The amount of each color component is measured as a value between 0 (no color) to 255
(max). Notice that the same composition of RGB colors can be represented in the hexadecimal
format.
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Here are several examples of combinations of primary colors:

Red Green Blue Result

0 0 0

255 0 0

0 255 0

0 0 255

255 255 255

241 255 73

When the red, green and blue have equal values, the result is a tint of gray. All colors set to zero
create black. All colors set to 255 create white.

CMYK

The CMYK color model, most commonly used in publishing, uses the cyan (C), magenta (M),
yellow (Y) and black (K) to create the entire range of colors. The final color is created by mixing
inks or dyes of the primary colors: cyan, magenta and yellow. Consequently, the more ink you
add, the darker color you will have all the way to black. To create pure black, it is preferred to
use only the black ink.

We measure the amount of each component as values from 0 to 100%.

Cyan Magenta Yellow Result

100% 100% 100%

100% 0% 0%

0% 100% 0%

0% 0% 100%

0% 0% 0%

9% 0% 57%

Adding a portion of black to a mix of cyan, magenta and yellow just makes the final color
darker, keeping the basic tint unchanged.

Note that the CMYK color space cannot cover all colors supported by RGB. This mostly affects
bright colors and tints of green. For example, the yellow shown in the RGB table has no
equivalent in the CMYK color space. The CMYK table displays a yellow that is close but not
exactly the same as in the RGB table. If you are going to create graphics for printing, it may be
reasonable to use CMYK colors in your design. In this case, you can ensure that your graphics
will look the same way when you print it.
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HSB

The HSB (hue, saturation, brightness) color model takes into account how the human eye
perceives colors. Unlike the previous models, HSB is a combination of qualities that together
determine a specific color.

Saturation and brightness are measured from 0 to 100%. Hue is measured in degrees.

The brightness might be the easiest one to understand. While you are changing the brightness
from maximum to zero, the color varies from the tint, specified by Hue (H) and Saturation (S), to
black.

Hues can be visually represented as a color wheel.

If we pick the red color as the starting point and move along the edge, we will pass through all
colors of the spectrum. Any color can be defined by an angle from the starting point. Having
red as the zero point, we can say that green takes the sector near 120 degrees.

When you move a point from the center to the circle's edge, you change the Saturation from 0
(pale colors) to 100% (colorful).

Grayscale

Grayscale represents tints of black. Values are measured from 0% (black) to 100% (white).

Grayscale colors can be reproduced using the RGB, CMYK and HSB color models.

Representing Colors in the Hexadecimal Format

Colors can be represented in the hexadecimal format. A hexadecimal number can consist of
numbers 0-9, and letters A, B, C, D and F. In software, hexadecimal values are frequently
preceded by the # sign, or they can be labeled as "Hex" or "Hex color".

The hexadecimal format is mostly used to indicate RGB colors for the Web and some other
applications.

Each primary color (red, green, or blue) is encoded as a two-digit number, so any arbitrary color
is represented as a six-digit number. For example, the yellow color in the RGB table above can
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be represented as F1FF50. Here, the value of red is F1, green is FF and blue is 50.

You don't have to learn how to convert RGB colors to the hexadecimal format because graphic
software usually displays values of colors in both formats.
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The Usage of the RGB and CMYK Color Models

Why do we have RGB and CMYK?

The RGB and CMYK color models have different approaches to create a color because they
were designed for particular purposes.

In most cases, you can see an image on one of two types of surfaces. The first type includes
screens of computers, phones, TV sets and so on. Their common feature is the capability to
emit light. The RGB color model perfectly suits such devices because higher values of red,
green and blue components make brighter colors in the same way as raising the screen
brightness does.

An example of the second type is an image printed on white paper. Such a surface reflects light
but cannot emit it. Areas with no ink remain white (the paper color). This corresponds to zero
quantity of cyan, magenta, yellow and black inks. The more ink droplets cover a particular area,
the darker and more saturated color we get. A mix of all inks, even without black, can
completely screen the paper making a very dark color.

How to Choose a Color Model for a New Document?

Let's begin with more simple cases when the purpose of your design is obvious. Graphics that
are intended to be displayed on the screen should be RGB. That includes digital art, user
interface designs for Web and apps, graphics to be used in video clips, content for social media
and so on.

CMYK is often used for designs that will be printed. However this doesn't apply to all cases.
Print shops may have their own requirements for customer's materials including color space,
file format and others.

If your design is intended for displaying on a screen and for printing at the same time, you
should choose RGB. It supports a wider color range and therefore better suits both use cases.
So why use CMYK at all? This is necessary to be able to verify your design colors before
printing. Once you convert an RGB design to CMYK, certain colors (often greens) can become
dull. You might prefer to discover this sooner in order to make corrections in the design if
necessary. If you send an RGB file to a printer, the printer driver will make the RGB to CMYK
conversion for you. However you won't see the result until it is printed.

Unless you definitely know that you need CMYK, design in the RGB color space. Check how
your design looks in CMYK if you care about how the design will look after being printed.

Switching Between Color Modes

The New Document dialog lets you select a color mode before a new document is created.
Later on, use the Document Settings dialog.
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In order to see how your RGB design looks in the CMYK color space, temporarily select CMYK
in the Document Settings dialog. Then you can switch back to RGB.

Note that each color mode comes together with a list of supported color profiles. If you are not
familiar with profiles, keep the default one.

Which of the File Formats Support CMYK?

Since RGB is supported by most of the graphic file formats, let's pay more attention to CMYK.

PDF is the most popular format for CMYK because it also supports multi-page documents, it is
capable of containing vector elements and text. Among raster formats, TIFF is one that
supports CMYK.

Color Profiles

Different devices (e.g., computer display or phone screen) may reproduce the same color with
slightly different tints. In order that colors look uniformly, manufacturers calibrate their devices
(monitors, printers, scanners) and save that information as a device's profile.

A color profile can be embedded into a graphic file to ensure that the image looks the same on
different devices.

To select a new profile to your document, use the Document Settings dialog.
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Fill an Object with a Color, Gradient or Image
An object can be filled with a plain color, gradient or image. The Appearance panel is used to
choose those options and adjust their properties.

To add a Fill property to an object, click on the plus icon and choose Fill. A quick way is to click
on the circle icon. Clicking on the ring adds a stroke. Don't confuse these two icons.

Fill properties are listed in the Appearance panel. The column of check boxes on the left lets
you hide any Fill or other property. The color icon in the right column opens the Color panel.

In order to choose a color, set up a gradient or select an image, click the color icon. The Color
panel will open up. Click on the Color, Gradient or Image tab.
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These sections explain how to select a color or work with gradients or images:

Selecting Colors
Gradients
Image Fill
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The Color Panel
The Color panel lets you choose plain colors, create gradients or select an image to use as a
texture. To open the panel, click on the appropriate color button. For example, each Stroke item
in the Appearance panel has its own color button.

The Color panel has individual sections for plain color, gradient and image. You can apply only
one of these features at a time. You may need to use more than one feature, for example, an
image and a color that tints that image. In this case, you should add two Fill attributes to the
object: one for the image and another for the tint color.

Color

The Color tab lets you select a plain color.

1 - Opacity. You can set up the opacity of the selected color. Unlike the opacity of an object or
layer, here you can adjust the transparency of an object's part, for example, the object's body,
while the stroke will remain opaque.

2 - Sample of the currently selected color.

3 - Eyedropper tool. It helps you copy colors from other objects. Read Selecting Colors for
more details. Also read The Eyedropper Tool and Privacy Settings about the Screen Recording
permission.

4 - Values of the primary colors that create the final color. The Grayscale color model has only
one parameter here. If you select the HSB color model, the panel will show the Hue, Saturation
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and Brightness parameters.

5 - Opacity of the current color. This opacity will be preserved if you save this color as a
swatch. This opacity is independent from the effect opacity. The app applies both of them at
the same time.

6 - Color field. You can select a color you like by clicking on it.

7 - Library of color swatches. You can save a color to the library in order to use it at a later time.

8 - Save the current color as a swatch.

9 - Blend mode. It defines how the colors of Fill, Stroke and effects interact with colors below
them. If you wish to select a blend mode for the whole object, use the Layers panel.

10 - Color model. You can select RGB, CMYK or HSB. There is also an option to choose
Grayscale.

11 - Hexadecimal representation of the current color.

12 - Delete the selected swatch.

Using Swatches

You can save a color as a swatch in order to use it later. The library of swatches can save you
time when you need to apply the same color many times. The library contains a number of
colors by default.

To save the current color as a swatch, click on the plus button below the library.

To restore a color from a swatch, click on that swatch.

In order to delete a swatch, click on it to select it. Then click on the trash bin icon in the bottom
right corner of the panel.

You can change the order of swatches in the library. To do this, drag and drop a swatch to a
new position.

To move or delete multiple swatches, select them holding down the Shift key.

The library of swatches works with gradients in the same way as described above.

Gradient

You can create either linear or radial gradients. To select one of the types, click the
corresponding button that is located above the gradient preview field. The Gradient Fill section
explains how to create and modify gradients.
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Linear Gradient

1 - Opacity of the whole gradient. You can also adjust the opacity of the colors that create your
gradient. This lets you create a transition from some color to a fully transparent area.

2 - Buttons to select the linear or radial gradient type.

3 - Gradient preview field. This is not only a preview but a tool to adjust your gradients. We will
describe later how to use it.

4 - Scale adjusts the width of the color transition area in relation to the whole size of the
gradient.

Scale: 100%

 

Scale: 20%

With 20% scale, the pure black and red colors took up most of the image space.

Note that the preview doesn't change when you adjust this parameter. Therefore watch how the
object with the gradient updates on the canvas.

5 - Offset of the gradient from the centered position. Drag the round handle and preview the
result on the object to which the gradient was applied. Use the X and Y fields to set up the
offset precisely.
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Centered

 

Off the center

6 - Library of swatches. You can save a gradient to the library in order to use it later.

7 - Save the current gradient as a swatch.

8 - Blend mode. It defines how the colors of Fill, Stroke and effects interact with colors below
them. If you wish to select a blend mode for the whole object, use the Layers panel.

9 - Reverse the direction of the gradient. The result will be similar to rotating the gradient by
180 degrees.

10 - The angle of the gradient. You can rotate a gradient in relation to the object it was applied
to. Changing the angle doesn't affect the gradient preview field.

11 - Delete the selected swatch.

Radial Gradient

Radial gradients share most options with linear gradients. Let's look at those that are specific to
radial gradients.

1 - Scale adjusts the width of the color transition area in relation to the whole size of the
gradient. By adjusting this parameter, you can create objects that look like a sphere under
different lighting conditions.
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Scale: 99%

 

Scale: 46%

Note that the preview doesn't change when you adjust this parameter. Therefore watch how the
object with the gradient updates on the canvas.

2 - Roundness changes the aspect ratio of the gradient. It is circular at 100%. If you decrease
the value to 50%, the gradient will look like an oval with the height two times smaller than the
width.

3 - Offset of the gradient from the centered position. The original transition between colors will
be preserved. Drag the round handle and preview the result on the object to which the gradient
was applied. Use the X and Y fields to set up the offset precisely.

4 - Offset of the middle gradient color from the center. This property extends the gradient in a
particular direction making it non-symmetrical. Drag the round handle and preview the result on
the object to which the gradient was applied.

5 - The direction of a non-symmetrical gradient that has the offset applied.

Image

The Image tab lets you fill an object with an image. There are various options that define the
position and size of the image inside the object boundary.

For more details, read the Image Fill section.

The Eyedropper and Privacy Settings

When you activate the Eyedropper tool for the first time, macOS displays this system
message: "Amadine would like to record this computer's screen". At the same time, Amadine
will get listed in the System Preferences > Security & Privacy > Screen Recording section as an
app that requested access.

By default, the operating system prevents apps from accessing windows of other apps. This
means that the Eyedropper tool is always capable of picking a color within Amadine's
windows. However, to sample a color from another app, you need to grant access in the Screen
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Recording section. In the case of occasional work, you may enable Screen Recording access
just for a short time when you need it.
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Selecting Colors
There are several ways to select a color for Stroke, Fill or some other effect.

Using the Color Panel

Select a Color Directly

In order to select a color directly, select a color model, such as RGB or CMYK. Then enter the
numeric values for color components, for instance, red, green and blue. Use either the sliders
or text fields. Otherwise, click on the palette to select a color you need. Then use the sliders to
adjust the color more precisely. You can also set a color in the hex format.

If necessary, adjust the opacity.

Using Swatches

If a color or gradient that you need is present in the library of swatches, click on the
corresponding swatch.

Using the Eyedropper

You can copy a color from almost any spot visible on the screen. To do this, click on the
eyedropper icon in the Color panel. The cursor will turn into a magnification glass. You should
place its center over the color you want to choose and then click. The operating system may
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block your attempts to pick a color because of the privacy settings. In such a case, refer to the
The Eyedropper and Privacy Settings section.

Copying Object's Style

You can copy the style of another object.

Note that a style is not only a single color. By copying a style, you can copy a combination of
the stroke and fill colors, and also effects like shadow depending on what has been applied to
the source object.

To copy an object's style:

1. Select the source object.
2. Choose Edit > Copy Style from the main menu.

You can do the same by opening the object's context menu and selecting Copy Style.
3. Select the destination object.
4. Choose Edit > Paste Style or open the object's context menu and select Paste Style in

the context menu.

You can also copy a style with the help of the Eyedropper tool:

1. Select the destination object.
2. Activate the Eyedropper tool  located in the Tools panel.
3. Click on the source object.

Modifier Keys and Shortcut Summary

Shortcut:

I activates the Eyedropper tool.

Eyedropper tool modifier keys:

Space switches to the Pan mode.
Command switches to either Move or Selection tool depending on which of them was
active most recently.
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Gradients
There are two ways to fill an object with a gradient:

Use the Gradient tool to add and adjust a gradient directly on the canvas.
Use the Color panel.

Note that any of these methods does not exclude another. You can do part of the work with the
help of one method and then finish using another.

Using the Gradient Tool

Add a Gradient

To fill an object with a linear gradient:

1. Select the object.
2. Activate the Gradient tool  on the Tools panel.
3. Place the cursor over the object, press the left mouse button and drag. You have added

the start point of the gradient.
4. Move the cursor around to adjust the direction of the gradient and control the way it fills

the object.
5. Click to at the end point.

The Color panel is used to choose the linear or radial gradient type.

The Gradient tool can fill several objects with one gradient. To do that, select multiple objects
or grouped objects. Each of the objects will take a part of the gradient.

Adjust Gradient Colors

Let's see how a gradient is created. We'll talk about linear gradients for simplicity. In order to
edit a gradient on the canvas, activate the Gradient tool.

Any gradient has two predefined colors at its ends. Let's call such predefined colors "base
colors". Base colors are shown inside circles. The default gradient has two base colors. We'll
see later how to add more.
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All colors in the middle are generated by the software to create a smooth transition between the
base colors.

The direction along which colors change is shown by a line that links the base colors. There are
white and black handles at the ends of the line.

To add an intermediate base color, click on the line. A plus near the cursor shows that this
operation is possible.

The third base color will be shown in a new circle attached to the line.

You can move base colors using the mouse in order to change the distribution of colors over
the given area.

To delete an intermediate color, drag it off the line until a cross appears near the cursor. Then
release the mouse button.

Only intermediate base colors can be deleted.

In order to change a base color, click on the corresponding circle. Then use a simplified version
of the Color panel to select a new color.
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Adjust the Gradient Position on the Canvas

The black and white handles let you rotate the gradient and also change the distance between
the base colors at the ends.

To move the gradient in relation to the object, drag the line which links the two handles.
Alternatively, drag the white and black handles to new positions.

To rotate the gradient, drag either black or white handle around the opposite one.

To change the width of the color transition area, move one handle to or away from another
handle.

Adjust Radial Gradient

To create a radial gradient, activate the Gradient tool. After that, switch to the radial gradient in
the Color panel. Then draw with the tool over an object to fill it with a gradient.

Once applied to an object, the radial gradient displays several handles. The handles allow you
to set the location of the middle point of the gradient, make it either circular or oval and more.

1 - Adjusts the shape of the gradient. Moving the handle toward the center turns a circular
gradient into an oval gradient. The handle lays on the circle or oval that indicates the shape of
the gradient.

2 - Handle that defines the location of the central color of the gradient.
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3 - Handle that defines the size of the gradient outlined by a circle or oval. Beyond the outlined
area, the color is the same.

4 and 5 - Base colors. Click on a circle to choose a different color.

Radial gradients let you add and delete intermediate colors in the same way as you can do with
linear gradients.

Using the Color Panel

Add a Gradient

When you open the Gradient tab of the Color panel, you automatically apply a default gradient
to the currently selected object.

Adjust Gradient Colors

You can add and delete base colors in the same way as you can do on the canvas. See the
Adjust Gradient Colors subsection for details.

In order to change a base color, click on the corresponding circle.

Drag circles that define the location of base colors to make different color tints take up more or
less space.

You can apply a predefined gradient by choosing one in the swatch library. Gradient swatches
are used in the same way as color swatches.
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Adjust the Gradient Position

The Scale parameter lets you change the distance between the base colors at the ends. The
result is equivalent to moving the black handle on the canvas closer or farther from the white
one.

Use the rotation control to change the direction of the gradient.

To move the whole gradient relative to the object, use the square control or change the X and Y
values. Note that it is more convenient to move and rotate gradients directly on the canvas.
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Image Fill
You can use raster and vector images in your document. They may be used as tiled textures,
backgrounds or for other purposes.

Add an Image

The easiest way to add an image to your document is to drag it from Finder onto the canvas.
The image will be added as a new object with the original aspect ratio. You can also copy an
image from other software.

In order to fill a shape with an image, you should use the Color panel:

1. Select an object.
2. Add a Fill property to the current object in the Appearance panel if the object doesn't

have one.
3. Click on the color icon of the Fill property to open the Color panel. Then select the Image

tab.
4. Click the Choose image… button and select an image.
5. Adjust image properties if necessary.

Whatever way you have added an image, you can come back to the Color panel and re-adjust
the settings there.

The Color Panel
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1 - Opacity. Unlike the opacity of an object or layer, here you can adjust the transparency of the
image itself, keeping the stroke or other effects with their own opacity.

2 - Image thumbnail.

3 - Offset of the image from the centered position in relation to the object. Drag the round
handle and preview the result on the object in your document.

4 and 5 - The horizontal and vertical scales of the image. You can make the image bigger or
smaller without resizing the object which contains the image. At a scale higher than 100%, the
image will get cropped. In order to change the both values simultaneously, lock them using the
icon on the right.

6 - Shear the image. This parameter transforms the image into a parallelogram.

7 - Blend modes. If you wish to select a blend mode for the whole object, use the Layers panel.

8 - Click to load an image from a file.

9 - The Fill Type options define how the image should fit the object. For details, see the Fill
Type section.

10 and 11 - Set the image offset using numeric values. These edit boxes work together with the
square offset control.

12 - Rotate the image inside the object.

13 - Flip the image inside the object.

14 - Maintain the current aspect ratio when either Scale X or Scale Y is changed.

Note that when the Fill Type is set to Stretch, the app sets most of the parameters
automatically. Consequently, most of the controls become disabled.

Fill Type

The Fill Type drop-down menu lets you choose the Fill, Stretch and Tile options.

At 100% scale, and when the boundary has the same aspect ratio as the image, all of the
options can yield the same result. The difference will become visible if you change the aspect
ratio of the boundary or if you scale the image.
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Original image

To see how the Stretch option works, we can decrease the height of the object. With Fill, the
image will keep its aspect ratio, but some image parts that don't fit can be invisible. Stretch will
reshape the image to fit it for the new width and height.

Fill:
image is cropped

 

Stretch:
image is deformed

The Tile option makes a difference when the image is scaled down. Many copies of the image
will take up the whole available space. With Fill, you'll still have a single small copy.

Fill:
single copy

 

Tile:
many copies

Note that to create a texture, you may need to use a specially designed image that can be tiled
seamlessly. Creation of such images is outside the scope of this documentation.
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The Recolor Panel
The Recolor panel is used to adjust object colors. To open the panel, select Modify >
Recolor… in the main menu.

The panel is designed to change many different colors of one or multiple objects at once. This
is useful when you need to try different color schemes. The panel is also capable of decreasing
the variety of colors by using one color tone instead of several similar ones. The key part of the
panel is the list of colors where you map the original colors into new ones.

1 - Changes the Hue of all output colors.

2 - Changes the Saturation of all output colors.

3 - Changes the Brightness of all output colors.

4 - Merge Tolerance defines a threshold for merging close color tones into one color.

5 - Input color which is one of the object's original colors. Several original colors may appear in
the same line if they were set to be replaced with one output color.

6 - The lock icon lets you prevent an original color from being changed by any tool in the panel.

7 - Shows how objects on the canvas would look if you apply new colors.

8 - Restore the original object colors.

9 - Output color that an object's element will receive if you apply changes.
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10 - Changes the order of colors in the list (e.g., by lightness).

Clicking on the original colors in the list lets you select one or multiple lines in order to
manipulate the colors directly. You need to press and hold the Shift key to select a range of
colors. The Cmd key helps you select multiple colors in arbitrary order.

In order to find out the numeric value of an input color in the hexadecimal format, place the
mouse cursor over that color.

The panel lists stroke and fill colors, as well as base colors of raster effects. If an object has a
gradient with several base colors, all of them will appear in the list.

The panel cannot recolor an image used to fill a shape.

The list of colors has a context menu:

Merge merges selected input colors.
Split splits input colors that are displayed in the same line. This command does the
opposite to Merge.
Lock lets you keep the output color unchanged. This command repeats the function of
the lock icon.
Unlock deactivates the lock option.
Restore makes the output color identical to the corresponding input color. This command
also splits input colors if they were merged.

Change the Hue, Saturation and Brightness

The Hue, Saturation and Brightness sliders affect all of the output colors. If you don't want a
certain output color to be modified, lock it using the lock icon.

Set an Output Color Directly

You can set an output color directly. To do this, click on the circle with the output color. This
opens the Color panel.

In order to make the output color the same as the corresponding input color, choose the
Restore command from its context menu.
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Merging Colors

Merging colors lets you represent input colors with a smaller number of output colors. This can
be done by replacing multiple similar input colors with the same output color. This is an
equivalent for the posterize function from raster graphics editors.

You can merge colors automatically or manually. Also you can combine these two methods.

Once two or more colors have been merged, they appear in the same line, and consequently
have the same output color. The new output color is the same as one of the output colors
before merging.

The following image shows two green colors merged. The output color was taken from the
second green color.

Merging Colors Automatically

To merge colors automatically, just move the Merge Tolerance slider to the right. The Merge
Tolerance set to 0% turns the automatic merging off. By increasing the tolerance, you allow
more different color tones to get into the same group.

To prevent a particular color from being merged, lock it.

Merging Colors Manually

In order to merge input colors manually, drag one of them on top of another. The output color
will be taken from the input color onto which you drop other colors. In other words, if you drag
a red color onto a blue one, the output color of this group will be the same as the blue color
before merging.

Another way to merge colors is to select multiple of them in the list. Then choose the Merge
command from the context menu.

In order to separate merged colors, select Split in the context menu. Or just drag one of the
merged colors to a new line.
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Introduction to Text Objects
You can add text to your design. The Text tool  is used to add text. The tool has several
modes that create different types of text. These modes are explained in the following sections.

A new text object contains the default text. You can type in your own text or paste it from the
clipboard.

Types of Text Objects

Rectangular Text Boundary

Text can be placed inside a rectangular text box. This is the most common type. You can use
this type of text object for a few words as well as for several paragraphs.

If you resize a text box, or edit text, the latter automatically wraps to the container boundary.
The size of the text box doesn't depend on the amount of text inside or on the font size. It is
possible to create text inside a non-rectangular boundary.

Distortable Text

You can add distortable text. Text inside this text object fits the width and height of the
bounding box. If you change the text box size, the text will squeeze or stretch in order to fit the
new width and height. On the other hand, if you change the font size, the text box will adapt to
new dimensions of the text.

Such text won't wrap to the next line automatically. If you wish to create another line, you
should place the cursor at a certain position and hit the Return key.

This type of text object is useful for small pieces of text or for headings.
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Text Along a Path

Text can be placed on a path. Text starts at one of the end points. In the case of a closed
shape, one of the anchor points will play the role of the beginning of the path. You can edit the
path using standard path editing tools.

This text object type can be used for small portions of text.

Text Inside a Shape

A path can serve as the boundary for text. Like a regular text box, it outlines the area that can
be taken by text. You can edit the path using standard path editing tools.

Presenting Text as Columns

A single piece of text can be distributed within several text boxes. This kind of layout is
frequently used to create columns of text. The text can flow from one text box to another
because the text boxes are linked. This feature is supported by the rectangular text and text
inside a shape objects.

Converting Text to Paths

You can convert text to path by choosing the Modify > Expand command from the main menu.
This command turns a text object into a group of paths that will look like the original letters. You
will be able to modify those paths using the Selection and other tools. It will not be possible to
use the text editing and formatting tools any more. There is no way to convert paths back to
text, unless you use the Undo command. For that reason, prefer to work with text objects when
you need to display text in your design.
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Text in Rectangular Boundary

Adding Text

To add a text box:

1. Press the T key.
or
Click on the Text tool  in the Tools panel. Make sure that the Text mode  is
activated in the Control panel.

2. Place the cursor on the canvas to define the location of a corner of a new text box.
3. Holding down the left mouse button, move the cursor to start drawing the text box.
4. Release the mouse button when the text box is the proper size. As a result, you will have

a text box containing the default text.
5. Type in or paste new text.

To exit the text editing mode, press the Escape key or activate another tool.

Editing and Formatting Text

To edit text in your document, double-click on it with the Move or Selection tool. Alternatively,
you can start editing text by clicking on it with the Text tool. The built-in text editor provides
basic capabilities for editing and formatting text.

Apart from the text itself, you can change its font, color and other properties as described in the
Properties of Text section. The most important properties can be found in the Control panel
located above the canvas.

Editing Text as Paths

You can convert a text object to paths using the Modify > Expand command from the main
menu. Then you can edit each character as paths and anchor points using the respective tools.
Note that after expanding a text object it will not be possible to edit it as text nor change its
formatting.
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Modifying the Boundary

To resize or rotate the boundary, drag the corresponding corner or side handle as explained in
the Move, Resize and Rotate Objects section.

The boundary of a text box can also be modified as a path with the Selection, Pen and other
tools. So, you can create a "text in a shape" object by customizing a rectangular text box.

Modifier Keys and Shortcut Summary

Shortcuts:

T activates the Text tool.
Shift-T activates the Text on Path tool.
Option-T activates the Text in Shape tool.

Text tool modifier key:

Command switches to either Move or Selection tool depending on which of them was
active most recently.
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Distortable Text

Adding Text

To add a text box:

1. Press the T key.
or
Click on the Text tool  in the Tools panel. Make sure that the Text mode  is
activated in the Control panel.

2. Click on the canvas to define the location of the top left corner of a new text box.
3. Type in or paste new text.

To exit the text editing mode, press the Escape key or activate another tool.

Editing and Formatting Text

To edit text in your document, double-click on it with the Move or Selection tool. Alternatively,
you can start editing text by clicking on it with the Text tool. The built-in text editor provides
basic capabilities for editing and formatting text.

When you add or remove a portion of text, the text box resizes automatically to hold the
present amount of text.

Apart from the text itself, you can change its font, color and other properties as described in the
Properties of Text section. The most important properties can be found in the Control panel
located above the canvas.

Distorting Text

You can squeeze or stretch text by changing the width or height of the text box. To do that,
drag its side or corner handle. Text won't wrap to another line when the amount of space inside
the text box decreases or increases. Instead of that, the size of characters changes to make the
text fit the currently available space.

To resize text preserving the current aspect ratio, hold down the Shift key and drag a corner
handle of the text box.
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In order to restore the original aspect ratio of letters, click the Fix Proportions button in the
Text Properties panel. The program will change the width of letters to restore their original look.
The height of letters will remain unchanged.

Editing Text as Paths

You can convert a text object to paths using the Modify > Expand command from the main
menu. Then you can edit each character as paths and anchor points using the respective tools.
Note that after expanding a text object it will not be possible to edit it as text nor change its
formatting.

Modifying the Boundary

To resize or rotate the boundary, drag the corresponding corner or side handle as explained in
the Move, Resize and Rotate Objects section.

The boundary of a text box cannot be modified as a path.
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Text Along a Path

Adding Text

We assume that a path is already present in your document.

To place text along a path:

1. Press the Shift-T key.
or
Click on the Text tool  in the Tools panel. Make sure that the Text on Path mode 

 is activated in the Control panel.
2. Point the cursor exactly at the path (not fill or shadow) and click. The program will display

a text editor containing the default text.
3. Type in or paste new text.

To exit the text editing mode, press the Escape key or activate another tool.

If the path is not long enough to display the entire text, the object's frame has a red square. It is
visible when the object is selected.

Editing and Formatting Text

To edit text in your document, double-click on it with the Move or Selection tool. Alternatively,
you can start editing text by clicking on it with the Text tool. The built-in text editor provides
basic capabilities for editing and formatting text.

Apart from the text itself, you can change its font, color and other properties as described in the
Properties of Text section. The most important properties can be found in the Control panel
located above the canvas.

Aligning Text with the Path

Text starts at the beginning of the path by default. It is the point from which you begin drawing
a path with the Pen or Pencil tool. It is less obvious, but all curves and shapes created with
tools like Rectangle or Star also have the start and end points. There are several settings that
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let you change the position of the text in relation to the path. By combining those settings, you
can produce different results.

Let's take a look at a few typical cases. We use a standard oval whose path begins at the upper
point and goes in the clockwise direction.

Example 1

The default oval was used as the path for the default text.

Example 2

The text was aligned with the end of the path using the text alignment buttons in the Control
panel.
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Example 3

Create a gap between the start point of the path and text by increasing the indent width.

Example 4

The start and end points of the path were swapped using the Modify > Path > Reverse
command.
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Example 5

The start and end points of the path were swapped using the Modify > Path > Reverse
command. Additionally, the text was aligned with the middle of the path.

Editing Text as Paths

You can convert a text object to paths using the Modify > Expand command from the main
menu. Then you can edit each character as paths and anchor points using the respective tools.
Note that after expanding a text object it will not be possible to edit it as text nor change its
formatting.

Modifying the Path

To resize or rotate the path that defines the text's shape and direction, drag the corresponding
corner or side handle of the object's boundary as explained in the Move, Resize and Rotate
Objects section.

The path can also be modified with the Selection, Pen and other tools.



175

Text Inside a Shape

Adding Text

We assume that a shape (either closed or open path) is already present in your document.

To add text inside a shape:

1. Press Opt-T.
or
Click on the Text tool  in the Tools panel. Make sure that the Text in Shape mode 

 is activated in the Control panel.
2. Point with the cursor exactly at the path (not fill or shadow), and click. The program will

display a text editor containing the default text.
3. Type in or paste new text.

To exit the text editing mode, press the Escape key.

Note that properties of the original path, such as stroke, fill or effects, will not be preserved
after adding text inside the shape.

Editing and Formatting Text

To edit text in your document, double-click on it with the Move or Selection tool. Alternatively,
you can start editing text by clicking on it with the Text tool. The built-in text editor provides
basic capabilities for editing and formatting text.

Apart from the text itself, you can change its font, color and other properties as described in the
Properties of Text section. The most important properties can be found in the Control panel
located above the canvas.

Editing Text as Paths

You can convert a text object to paths using the Modify > Expand command from the main
menu. Then you can edit each character as paths and anchor points using the respective tools.
Note that after expanding a text object it will not be possible to edit it as text nor change its
formatting.
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Modifying the Boundary

To resize or rotate the boundary, drag the corresponding corner or side handle as explained in
the Move, Resize and Rotate Objects section.

You can modify the boundary of your text as a path with the Selection, Pen and other tools.

Rotate a Shape in Relation to Text

To rotate a shape in relation to the text inside it, use the Free Transform tool .
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Properties of Text
The Control panel gives you quick access to the most frequently used properties. For extra
options, you can use the Appearance Panel.

Text Properties in the Control Panel

Text properties are displayed in the Control panel when you activate the Text tool or select text.
The panel is usually located above the canvas.

1 - Select the type of a new text object: regular text, text along a path or text inside a shape.
You should select one of the types before creating a new text object.

2 - Select a font family (also known as typeface). You can also select fonts in the standard
Fonts pane (Cmd-T).

3 - Select a font style. This drop-down list shows styles actually available for the selected font.

4 - Set up the font size.

5 - Choose color. This button opens the Color panel.

6 - Select text alignment.

7 - Make text bold, italic or underlined. Notice that these buttons repeat options that can be
present in the list of font styles (3). Some of the buttons may make no change if the
corresponding style is not provided by the selected font.

Text Properties in the Appearance Panel

In order to access text properties, open the Appearance panel by choosing Window >
Appearance from the main menu. Notice that the Appearance panel lets you change the font
size and color directly.

Then click on the gear icon of a text object.
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1 - Select a font family.

2 - Select a font style.

3 - Set up the font size.

4 - Change the kerning.

5 - Select the text alignment.

6 - Set up the line spacing.

7 - Set up the amount of space after a paragraph. If the whole text box is selected, this control
affects all paragraphs. In the editing mode, you can select one or several paragraphs. In this
case, spacing after selected paragraphs will be changed.

8 - Create a list. You can choose numbers or letters for ordered lists, or bullet-like symbols.

9 - Set the distance from the bullet symbol to the text box border.

10 - The Fix Proportions button restores the original look of the text. This function is supported
only by distortable text. The button appears in the Control panel when this type of text is
selected.

11 - Make text bold, italic or underlined.

12 - Move the baseline up or down. That moves selected characters up or down in relation to
the rest of the text in the same line.

13 - Set up the paragraph indent width which offsets the beginning of the first line.

14 - Set up the amount of space before a paragraph. If the whole text box is selected, this
control affects all paragraphs. In the editing mode, you can select one or several paragraphs. In
this case, spacing before selected paragraphs will be changed.
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15 - Decrease or increase the indent level to create a nested list.

16 - Set the distance between the bullet symbol and the beginning of the text.
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Creating Columns with Flowing Text
You can split your text into several parts to make it easier to read or to combine it with images.
Columns of text are an example of such a layout. Text boxes that contain such text are linked
into a chain. When the first text box becomes full, the text automatically flows into the second
one, third one and so on. The same happens when you change the size of the text box or font.

Most commonly, the rectangular boundary is used for flowing text. Text inside a shape also
supports this feature.

The text object boundary indicates whether a particular text box is single or linked with others.
A linked text box has a tag at the top that displays the number of this text box in the chain.
Once you select any text box in the chain, the rest will display their boundaries and numbers. A
single text box has no tag.

The boundary of a selected text box has a square control on each side. The functions of these
controls are explained in the table. The Available Actions column describes operations that are
supported in each case. Consider the left control as the input point and the right control as the
output point.
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Control Functions Available Actions

Blank

A blank control on the left side of the frame
means that there is no other text box linked to
this side. The text box is either single or the first
one in the chain.

Create a linked
text box or link an
existing text box
to the current
one.

Arrow inside

An arrow directed inside indicates that text
begins in another text box and continues in the
current one. The text box is a part of a chain but
not the first one.

Unlink the
preceding text
box or add a
linked text box
before the current
one.

Blank

A blank control on the right side of the frame
means that there is no other text box linked to
this side. The text box is either single or the last
one in the chain.

Create a linked
text box or link an
existing text box
to the current
one.

Arrow outside

An arrow directed outside indicates that text
continues in another text box. The current text
box is a part of a chain but not the last one.

Unlink the
following text box
or add a linked
text box after the
current one.

Red plus

A red plus on the right side of the frame means
that the text doesn't fit the given space. The text
box can be either a single one or a part of a
chain. In the second case, it is the last text box
in the chain.

Create a linked
text box or link an
existing text box
to the current
one.
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Adding Linked Text Boxes

To create a chain of linked text boxes, add the first text box. Click on its right-hand control. The
 cursor indicates that you can create a linked text box. Draw the second text box.

Alternatively, you can click on the control and then click on the canvas. In this case, the second
text box will have exactly the same size as the first one. You can continue doing this in order to
create a chain of multiple text boxes.

Linking Text Boxes

To link two text boxes, use the controls on their sides. You can link the control on the right-hand
side of one text box to the control on the left side of another text box. Or vice versa. It is only
possible to link either two blank controls or a red plus and a blank control.

In order to link two text boxes, click on a square control of one of the text boxes. To make this
text box the first in the chain, choose its right control. To make it the second, choose its left
control. Once you place the cursor over another text box, the cursor's icon will change to 
indicating that the text boxes can be linked. Click to complete the operation.
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Linking Two Chains of Text Boxes

In order to link two chains of text boxes, you should link the right control of the last text box of
one chain to the left control of the first text box of a second chain. This requires the same
actions as you take to link individual text boxes.

 

Unlinking Text Boxes

To unlink a text box from the preceding one, click on its left control. To unlink from the following
text box, click on the right-hand control of the current text box. Then click on the text box to
finish. Alternatively, the second click can be made on a text box that you want to unlink from
the current one. The cursor's icon  indicates that unlinking is possible.
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Inserting a Text Box in the Middle of a Chain

To add a text box in the middle of a chain, after a particular text box, click on its right-hand
control with an arrow directed outside. Then draw a new text box. The new text box will be
automatically linked to the preceding and following text boxes.

To insert a text box before a particular one, use its left control.

Removing a Text Box from a Chain

To delete a text box from your design, just delete it as you would do with any object. If a text
box is located in the middle of the chain, the program will automatically relink the text boxes
before and after it.

If you want to remove a text box from a chain but preserve it in the design, unlink this text box
and relink other text boxes if necessary.
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The Shadow Effect
You can add a Shadow effect to an object to create a drop shadow. You can also add an Inner
Shadow effect.

Shadow

 

Inner Shadow

The Appearance panel is used to add and adjust the effects.

1 - Visibility of an effect.

2 - Add a new effect.

3 - Open settings of an effect.

4 - Delete a selected effect.

5 - Click to adjust the color of an effect. This button opens the Color panel.

In order to add a shadow, click on the plus button in the Appearance panel. Select Shadow or
Inner Shadow. Then click on the gear icon of the effect and set up its properties. You can also
change the color of the shadow.

The Shadow effects create raster graphics. If you plan to export a high-resolution image, or, if
the exported image might be enlarged in other software, make sure that your export settings
are sufficient for that.
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Settings of the Shadow Effect

1 - Opacity of the shadow.

2 - The offset of the shadow in relation to the object.

3 - Amount of blur.

4 - The direction in which the shadow is casted.

5 - Blend mode that defines how the effect's colors interact with underlying colors. Blending is
explained with examples in Blending Layers.

6 - The base color of the shadow.
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The Glow Effect
You can apply the Inner Glow and Outer Glow effects to objects.

Outer Glow

The Appearance panel is used to add and adjust the effects.

1 - Visibility of an effect.

2 - Add a new effect.

3 - Open settings of an effect.

4 - Delete a selected effect.

5 - Click to adjust the color of an effect. This button opens the Color panel.

In order to add a glow effect, click on the plus button in the Appearance panel. Select Inner
Glow or Outer Glow. Then click on the gear icon of the effect and set up its properties. You can
also change the color of the glow.

The Glow effects create raster graphics. If you plan to export a high-resolution image, or, if the
exported image might be enlarged in other software, make sure that your export settings are
sufficient for that.
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Settings of the Glow Effect

1 - Opacity of the glow effect.

2 - The thickness of the glow.

3 - Amount of blur.

4 - Blend mode that defines how the effect's colors interact with underlying colors. Blending is
explained with examples in Blending Layers.

5 - The base color of the glow.
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The Blur Effect
You can add a Blur effect in order to soften an object's edges.

Original object

 

Blur effect

The Appearance panel is used to add and adjust the effects.

1 - Visibility of an effect.

2 - Add a new effect.

3 - Open settings of an effect. Blur lets you adjust its width directly in the Appearance panel.

4 - Delete a selected effect.

5 - Click to adjust the color of an effect. This button opens the Color panel.

In order to add a blur effect, click on the plus button in the Appearance panel. Select Blur. Then
adjust the blur width.

The Blur effect creates raster graphics. If you plan to export a high-resolution image, or, if the
exported image might be enlarged in other software, make sure that your export settings are
sufficient for that.
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Introduction to the Object Shape Transformation
The following methods can be used to modify objects:

Resize or rotate using the bound box
Path editing tools: the most powerful, but, at the same time, the most labor-consuming
way
Smart shape-specific methods: easy-to-use, they apply pre-programmed object
transformations
Rounding of the object's corners
Transform panel: gathers the resize, rotation and other tools in one place
Free Transform tool: lets you distort an object
Combine objects
Apply clipping mask
Fusion tool: lets you create a new object from several others

In this chapter, we are going to learn about special tools that help you change the shape of
objects, such as the Transform panel and Free Transform tool. Others are described in the
dedicated chapters.

Combining objects as well as applying a clipping mask change the visual representation of
objects. At the same time, these methods provide you certain access to the original objects.
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The Transform Panel
The Transform panel is used to adjust the geometric properties of objects. To open the panel,
select Modify > Transform… in the main menu.

To transform a selected object, set new values in the dialog. Then click the OK button.

The dialog saves settings after the last transformation. To apply these settings again, select an
object and choose Modify > Transform Again.

In order to restore the default values in the dialog, click the Reset button.

When you change one of the values, an outline displays a new shape or position of the object.
In the image below, we moved the object to the right but didn't click OK so far.

The controls in the Transform panel resemble controls from the Geometry panel.

1 - Scale the width or height. You scale up or down from the current object size. The width and
height can be changed independently.

2 - Move the object horizontally or vertically by the specified distance.
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3 - Reference point selector. The 9-point selector lets you choose a corner, the middle of any
side or the center. The reference point preserves its location when you resize or rotate the
object.

4 - The rotation tool.

5 - Shear the object.

6 - Flip the object horizontally.

7 - Flip the object vertically.

8 - Transform each. When multiple objects are selected, you can select whether to apply a
transformation to each object individually (checked) or to all of them as if they were a single
object (unchecked). For example, two selected objects can rotate around the center of the
common bounding box (unchecked), or each can rotate around its own center (checked).

Rotation when
Transform Each is deactivated

 

Rotation when
Transform Each is activated

9 - Transform a copy of the object. Instead of applying a transformation to the original object,
the program creates its copy. Then it transforms the copy. As a result, you will have two
objects. This feature can be used to create a series of objects with one or several properties
changing.

In the following example, we move the square horizontally and vertically and rotate it at the
same time. The Copy objects check box should be selected. To repeat the image shown
below, you should apply the transformation using the Transform panel. Then repeat it by calling
Modify > Transform Again (Cmd-J) multiple times.
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Doing this manually would take much more effort.
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Transforming Objects

Resize Objects

Resize Using the Bounding Box

To resize an object, drag a corner or side handle on the object's bounding box using the Move
tool . To preserve the aspect ratio, do that by holding down the Shift key.

Resize Objects to a Particular Size

If you know the new size of the object, you can input it into the width and height fields of the
Geometry panel.

Resize Objects by a Particular Percentage

In order to scale an object by a certain percentage, set the W and H values in the Transform
panel.

Shear Objects

In order to shear an object, use either the Transform or Geometry panel.

Shear tools in the Transform panel

To shear an object, set the amount of transformation using one of the Shear controls. An icon
near each tool shows the corresponding transformation pattern.

In some cases, an object can be aligned to the grid or some other object. To preserve the
alignment, you can select a reference point using the 9-point control. The selected point will
retain its position after transformation. For example, you can align the top left corner of a
rectangle to the grid. Then click on the upper left dot of the 9-point control. After
transformation, that corner will still be aligned to the grid.



195

Rounding Corners
User interfaces and websites often use elements with rounded corners. The most convenient
way to create objects with rounded corners is to use the features described below.

Note that some anchor points create corners on a path and others don't. These two cases are
explained in the Corner Points and Smooth Points section. We are going to make rounded
corners at Corner Points.

Rounded Corners in Smart Shapes

Smart Shapes are objects that are created using specialized tools. If you select a Smart Shape
with the Selection tool, the Control panel will let you set the radius and select the shape of the
corner in the popup panel.

Refer to the following subsection for details.

Rounding Corners in Arbitrary Paths

When a path is selected and the Selection or Lasso tool is activated, the app displays handles
near corner points. In order to create a rounded corner, move the handle. To hide or show the
handles, use the View > Show / Hide Corner Handles menu command.

1 - Corner point.

2 - Corner rounding handle.
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3 - Points that create a rounded corner.

As soon as you drag the handle off its original position, the corner radius will start increasing.
The corner radius is displayed near the cursor while you are dragging the handle. You can also
see and edit the value of the radius in the Corner edit box.

To create a bevel, the app replaces the original point with two points and a segment. Strictly
speaking, when you are adjusting the corner radius or the bevel shape, you actually change the
location of these points and the shape of the new segment. Although the path got an extra
segment and point, the app remembers the position of the original point. At certain conditions
explained later, the new segment can become permanent and the rounding handle will
disappear.

If a path or Smart Shape was selected using the Selection tool, you can adjust radiuses of all
corners by moving just one corner handle. This is possible because all of the handles become
selected by default. In order to adjust only particular corners, you should select the
corresponding handles. To select or deselect several handles individually, Shift-click on them.
The selected and deselected handles have different colors in the center.

1 and 3 - Selected corner handles.

2 - Not selected handle.

When the handles aren't visible, you still can adjust the corner radius using the Control panel.



197

Changing the Bevel Shape

By default, a rounded bevel is created. This concerns arbitrary paths as well as Smart Shapes.
To select a different bevel type, click on the gear icon in the Control panel.

Concave bevel

 

Straight bevel

 

Round bevel

 

Elliptic bevel

 

The slider below the presets lets you set intermediate values.

Converting a Rounded Corner into a Path Segment

As it was mentioned earlier, the app adds an extra segment in order to make a corner rounded.
At the same time, it keeps information about the original corner point. Due to this, the handle
can change the radius or restore the original point.

If you transform the path or Smart Shape, the rounded corners will be replaced with the curved
segments permanently. The corresponding corner rounding handles will disappear. Then, if you
select the object with the Selection tool again, the app will detect currently present corners
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and display their handles. The mentioned transformations include: non-proportional resizing,
flipping, distorting with Free Transform and Shear tools, applying the Expand and other
operations.

The main menu has two options to expand corners. Modify > Expand (also available in the
Control panel) expands all of the rounded corners of a selected object. Modify > Expand
Selected Corners expands rounded corners that you selected. To select a rounded corner for
that purpose, activate the Selection tool. Then click on a corner rounding handle. Shift-click in
order to select multiple handles. Alternatively, click and drag to outline the handles with the
selection frame.
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The Free Transform Tool
The Free Transform tool  has three modes that can be selected in the Control panel: Free
Transform, Symmetrical Distort and Free Distort.

In order to use the tool in any of its modes, you should select an object or several objects
before activating the tool. Once the tool is activated, you cannot select or deselect objects.

The tool can work either with the whole object, or with some of the object's anchor points.

Free Transform

In the Free Transform mode, the tool can scale, shear and rotate objects.

Holding down the Option key, you can transform an object from the center.

Scale an Object

To scale an object, move the bounding box corner handle. By default, the width and height will
change independently. To maintain the aspect ratio, scale the object holding down the Shift
key.

Original image

 

Image scaled vertically

Shear an Object

To shear an object, move the handle in the middle of the bounding box side. This side will move
along its current axis.
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Original image

 

Shear-like distortion

Rotate an Object

To rotate an object around an arbitrary point, drag a pink circular handle to that point. Place the
mouse pointer outside the bounding box near a corner handle. The cursor should turn into a
bent double-sided arrow. Click and move the cursor to specify a new angle.

Original image

 

Rotation around an arbitrary point

Symmetrical Distort

In this mode, you can turn the rectangular bounding box of the object to trapezium. The object
will be distorted accordingly. This distortion lets you show an object in perspective.

To perform the symmetrical distortion, drag a corner handle of the bounding box along one of
the sides. The handle located on the same side will move in the opposite direction by the same
distance.
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Original image

 

Symmetrical distortion

Free Distort

This mode lets you move each corner handle independently from the others.

To distort an object, drag one of the corner handles to a new position.

Original image

 

Free Distort tool used

Holding down the Option key, you can transform an object symmetrically.

Modifier Keys and Shortcut Summary

Shortcut:

Q activate the Free Transform tool.

Free Transform tool modifier keys:

Space switches to the Pan mode.
Option allows you to transform an object symmetrically.
Shift lets you maintain the object's aspect ratio.
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Combining Objects

Introduction

You can combine objects using Boolean operations: Union, Intersect, Exclude and Subtract.
These operations can be applied to two or more objects. They also require that objects overlap
partially or completely.

The program finds areas with and without intersections. Then it decides to hide or show those
areas depending on the selected operation. Later on this page, we'll see how this works in a
simple case with only two objects.

The result of combining objects is a compound group.

To combine objects, select two or more objects. Then choose the Union, Intersect, Exclude,
Subtract or Divide command from the Modify > Combine menu. You can also find these
commands by clicking on  in the Control panel.

In some cases, the creation of a complex object by combining primitive ones is easier than
drawing the same object from scratch.

Union

The result of Union is an object that includes the area of all original objects.

Original shapes

 

Union

The created object takes on the style of the original object that is in front of all others.

Intersect

The result of the Intersect operation is an object that includes only the area where all of the
original objects overlap.

Original shapes

 

Intersect
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The created object takes on the style of the original object that is in front of all others.

Subtract

The result of the Subtract operation is a part of the background object that is not covered by
any other object.

Original shapes

 

Subtract

The created object takes on the style of the original object that is behind all others.

Exclude

The result of the Exclude operation depends on the number of objects that overlap at every
single point. A hole appears in the area where two objects overlap.

If more than two objects cover the same spot, then only an even number of objects creates a
hole.

Original shapes

 

Exclude

The created object takes on the style of the original object that is in front of all others.

Divide

The Divide operation has a few significant differences from the rest. It is often used not to
combine shapes but to cut them. You can utilize it as a sophisticated Knife tool.

When you apply the Divide operation to overlapping objects, all paths act as cut lines. The
result of the Divide operation is a regular group, not a compound group as with other
operations. So, to separate parts of the created group you just need to ungroup them.
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Original shapes

 

Divide

To illustrate a possible usage scenario for the Divide operation, let's create a pie chart showing
1/8 of something (or a pizza, if you like, with one slice separated). In order to cut a sector of a
circle, we can use a triangle that has an appropriate angle at one of its corners. In our case, it
must be 45 degrees.

We need to place the corner of the triangle in the center of the circle.

Then we select both of them and apply Divide. Once the result is ungrouped, we can delete the
part of the triangle that is outside of the circle. Finally, we pull the sector off the center of the
circle.
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Compound Groups

A compound group can be created by combining objects.

In the Layers panel, a compound group is presented as an object named Compound Group
whose sub-items are the original objects. It is similar to groups. You can access and edit those
sub-objects individually. The program will instantly update the compound group.

You can change the properties of a compound group as you do with basic objects: apply
stroke, fill or effects.

To split a compound group back into the objects that compose it, use the Modify > Combine >
Release command.

To edit a compound group, use the Selection tool as you do to edit separate paths. Apart from
editing anchor points, this tool lets you move individual objects inside the compound group.

It can be helpful to double-click on the compound group in order to enter the Isolate mode. In
this mode, you can move, resize, rotate and transform the original objects.
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Compound Path
You can combine objects using compound paths. After creating a compound path, the original
objects become one object. A compound path can be created from two or more objects. Areas
where objects overlap create holes if the objects are filled with a color, gradient or image. A
new compound path takes on the style of the original object that was in front of all others.

To create a compound path, select two or more paths. Then choose Modify > Make
Compound Path command from the main menu.

Paths that make up a compound path can be split apart. To do this, use the Modify > Release
Compound Path command.

The Layers panel displays a compound path as a basic object like a single path. Unlike a
compound group, you cannot access the original paths in the Layers panel. The Selection tool
still lets you edit anchor points of the original paths.

By using a compound path, you can cut holes in objects (prevent a particular area from being
filled) or create a complex object out of several simple ones.

To cut a hole, you should place one object over another. Select them. Then select Modify >
Make Compound Path. It doesn't matter if the smaller object is in front or behind the bigger
one. The same result can be achieved by applying the Exclude Boolean operation, followed by
Expand.

A path may outline some area in the middle of the object. The program uses certain rules to
determine if such an area is inside a shape, and therefore should be filled, or it is outside and
shouldn't be filled. These rules are Non-zero Winding Fill Rule and Even-Odd Fill Rule. To
choose a rule, select Modify > Fill Mode in the main menu. The Even-Odd rule is used by
default because it creates more predictable results.

The following images demonstrate the difference between the two methods.
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Non-zero Winding Fill Rule

 

Even-Odd Fill Rule

Let's see in detail how the rules work.

Non-Zero Rule

The non-zero rule determines whether a point is inside or outside the shape body by going from
this point to the infinity in any direction. While going from the selected point toward infinity, we
should count how many times we crossed paths. Each time we cross a path drawn clockwise,
we should subtract 1. If we cross a path drawn counterclockwise, we add 1. The counted
number is called a winding number.

The rule: if the winding number is zero, the point is outside the shape, so we don't fill it (cut a
hole).

Notice that the direction of paths is a key thing in the non-zero rule.

Let's count the winding number (WN) for two cases. In the first, paths have the same direction.
In the second example, directions will be opposite.

Same direction

a: WN = 0. The a point is outside.

b: WN = +1. The b point is inside.

c: WN = +2. The c point is inside.
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Opposite directions

d: WN = 0. The d point is outside.

A more complex example where the internal path changed its direction.

Different directions

Even-Odd Rule

The even-odd rule is more straightforward. To determine if a point is inside or outside, we
should go from this point toward infinity in any direction. We count how many paths we
crossed.

The rule: if the number of crossings is even, the point is outside. If odd, the point is inside.

Even-Odd Rule
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e: 0 crossings - even. The e point is outside.

f: 1 crossing - odd. The f point is inside.

g: 2 crossings - even. The g point is outside.
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Using a Clipping Mask

About Clipping Masks

A clipping mask is an object whose outline masks another object. You can treat such a mask as
an infinite surface with a hole defined by the clipping path through which you can see a masked
object.

You might be familiar with the crop tool that is present in any photo editing software. A
rectangular clipping mask can do the same, but it is much more flexible. It can have any other
shape and can also be applied to multiple separate objects. In addition to that, you can still edit
the mask and masked objects after the mask has been applied.
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Use Clipping Mask to Hide Parts of Objects

To apply a clipping mask to an object:

1. Create a vector object that will be used as a clipping mask. Only the shape of its path
matters.

2. Place the clipping path over the object you want to mask.
3. Select both the mask and object.
4. Choose Modify > Make Clipping Mask command from the main menu.

The result is a Clipping Group object that includes the clipping path and masked object.

Only a vector object can be used as a clipping path. If you try to create a clipping mask out of a
raster image, the rectangular boundary of this image will be used to create a clipping path.

You can mask any artwork.

A clipping mask created as explained above has no fill or stroke. It doesn't retain any style that
the original object could have. If you want the mask to retain its original style, use the method
explained below.

With help of the Layers panel, you can create a Clipping Group preserving the styles of the
object(s) and mask. To do this, open the Layers panel and make sure that the object and its
future mask are visible. Drag the object in the panel and drop it onto the object that should
become the mask. The app will create a Clipping Group with both objects inside it. If the group
should contain more objects, drag them into the group as well.

Edit a Clipping Mask

You can modify the clipping path using vector editing tools.

In order to outline the visible part of the masked object, apply a stroke to the clipping path.

Edit a Masked Object

In order to edit a masked object, select it in the Layers panel. The object can be found inside
the corresponding Clipping Group. Then you can modify the masked object using regular
methods and tools.



212

Release Objects from a Clipping Mask

To release objects from a clipping mask, select the respective Clipping Group in the Layers
panel or on the canvas. Then choose Modify > Release Clipping Mask from the main menu.

Notice that the clipping mask will turn into an invisible object if it has no stroke nor fill.

You can also release the clipping mask directly in the Layers panel. Expand the Clipping Group
item in the panel to see its contents. Then drag the object and drop it outside the group. If the
clipping group contains multiple objects, drag them one after another. Or select all of them and
drag them together. Once there are no objects in the group, it will disappear.
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Cut an Object with the Knife Tool
The Knife tool can cut paths and objects into parts. This tool also works with groups and
compound groups.

To activate the Knife tool, click on the Knife icon  in the Tools panel.

To cut an object or path, select it. Then draw a cut line over that object or path.

Drawing with the Knife tool

 

The object was split into two parts

To have a straight cut, press the Option key before drawing a cut line. In order to snap the cut
line to 45, 90 degrees and so on, hold down the Option and Shift keys.

If you cut a closed path, paths of created objects will also be closed. The program will
automatically add new path segments where they are needed.

Modifier Keys and Shortcut Summary

Shortcut:

K activate the Knife tool.

Knife tool modifier keys:

Space switches to the Pan mode.
Command switches to either Move or Selection tool depending on which of them was
active most recently.
Option lets you make a straight cut.
Option-Shift allows you to make a straight cut directed at 45 and 90 degrees.
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Cut a Path with the Scissors Tool
The Scissors tool can cut paths.

To activate the Scissors tool, click on the Scissors icon  in the Tools panel.

To split a path, place the tool over the path and click. You can cut the path at any point.

Unlike other tools (e.g., Knife), the Scissors tool can edit any visible object if it is not locked.
When you hover with the tool over a path, it becomes highlighted. A circle indicates the location
of the cut point.

The tool makes a closed path open. Ends of two segments will overlap at the cut point and will
look like a single anchor point.

What the Scissors tool does can be achieved with the Pen and Selection tools. In that case,
you need to add an anchor point using the Pen tool in the corresponding mode. Then select
the anchor point with the Selection tool and use its cut mode.

Modifier Keys and Shortcut Summary

Shortcut:

C activates the Scissors tool.

Scissors tool modifier keys:

Space switches to the Pan mode.
Command switches to either Move or Selection tool depending on which of them was
active most recently.
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Erase a Part of an Object
The Eraser tool can remove a part of an object. This tool also works with groups and
compound groups.

To activate the Eraser tool, click on the Eraser icon  in the Tools panel.

In order to erase a portion of an object, select this object. Then paint with the tool over the
object's part that you want to remove.

If the original object has a closed path, the tool will keep it closed. So, the result will be one or
several closed paths.

The Eraser tool was dragged over the path.

The Eraser tool was dragged across the rectangle.

In order to move the Eraser tool along a straight line, use the Option key. Press it before
dragging the tool. In order to snap the line to 45, 90 degrees and so on, hold down the Option
and Shift keys.

The Eraser tool has a round shape with a customizable width (diameter). When the diameter is
zero, the Eraser tool does exactly the same as the Knife tool. To change the diameter, use
these keys: [ to decrease, and ] to increase.

Modifier Keys and Shortcut Summary

Shortcut:

E activates the Eraser tool.

Eraser tool modifier keys:

Space switches to the Pan mode.
Command switches to either Move or Selection tool depending on which of them was
active most recently.
Option lets you erase along a straight line.
Option-Shift allows you to erase along a straight line directed at 45 and 90 degrees.
[ decrements the diameter of the Eraser tool.
] increments the diameter of the Eraser tool.
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The Fusion Tool
The Fusion tool is designed to create objects with complex shapes from simpler ones. With
this tool, you can merge particular parts of original objects and remove unnecessary parts. You
can do similar work with help of the Boolean operations. However, the Fusion tool is more
interactive. It provides you with convenient visual feedback on what is going to happen with the
objects that you edit.

To activate the Fusion tool, click on the Fusion icon  in the Tools panel.

The tool operates on selected objects only. While the Fusion tool is activated, you can press
Cmd-Shift to temporarily switch to the Move tool in order to select more objects or deselect
some of them. In fact, Cmd switches to either Move or Selection tool depending on which of
them was active most recently. We additionally press Shift to select or deselect objects.

Controls of the Fusion Tool

The Control panel displays the following options when the Fusion tool is activated.

1 - Merge mode.

2 - Erase mode.

3 - Use the current object's appearance, or set up a new Stroke and Fill.

4 and 5 - The colors of new Stroke and Fill. Click to set up the color or other properties.

How the Tool Works

The tool works with objects' paths. Let's select two overlapping objects, place the cursor inside
one of them and press the mouse button.

The tool will find all nearest segments, no matter which of the objects they belong to, and try to
define the area those segments outline. Then it will highlight this area. When you release the
mouse button (the cursor stays at the same place all the time), the Fusion tool will assemble a
new path from the segments. So, the highlighted area gives you the idea of the object's shape
that will be created.
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In our example, we have created a new shape that is filled with a gray color. The rest of the
segments formed a second shape.

Now, let's go to another example. We start with the same two ovals. But in this case, we'll draw
with the tool from the middle of one oval to the middle of the second oval.

Note that a temporary line indicates areas visited by the cursor which might be affected by the
tool. When we cross a path segment with the line, we tell the program to remove this segment
and merge the areas the segment separates.

The Appearance of a New Object

The appearance of the created object depends on the Customize checkbox. If it is selected,
the app applies the stroke and fill which are displayed near the checkbox. You can click on
them to change their properties (e.g., set up the stroke width or color, or fill the object with a
different color or gradient). When the Customize checkbox is not selected, the new object will
have the same appearance as the first object that was visited by the cursor.

The Fusion Tool Modes

The Fusion tool has two modes that can be selected in the Control panel. We have just learned
about the default Merge mode . In this mode, the tool creates a bigger area from several
smaller areas that touch each other. The cursor's icon in this mode has a plus sign.

The  button in the Control panel activates the erase mode. You can also activate it by
holding down the Option key. In this mode, the cursor icon has a minus sign. Object parts that
will be removed are highlighted with red color.

If you click on a segment in the Erase mode, the segment will be deleted.



218

Similarly to the Merge mode, you can draw across multiple segments in order to remove them.

Notice that after using the Fusion tool, you may have a number of separate segments instead
of a closed path.

To turn them into a single object, use the Fusion tool in the Merge mode. Just click or drag
inside the area. You can also use the Selection tool to link anchor points manually.

Usage Example

Let's create a flower using seven circles and the Fusion tool.

Remove the external parts of circles. By the way, you don't have to do a lot of work in one
single step. Delete one segment at a time if this way is easier for you.
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As a result, we have the following.

We are going to remove unnecessary segments inside the circle in the center. A different way to
do that is to merge the central part of the flower.

Merge two parts of each petal.

This is what we finally have.
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Modifier Keys and Shortcut Summary

Shortcut:

F activates the Fusion tool.

Fusion tool modifier keys:

Space switches to the Pan mode.
Command switches to either Move or Selection tool depending on which of them was
active most recently.
Command-Shift switches to either Move or Selection tool and lets you select or deselect
objects.
Option switches from the Merge to Erase mode.
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Introduction to Importing
It is a common practice to create more complicated projects using simple designs or images as
building blocks. For example, you can create a vector pattern and place it as a decoration in a
greeting card design. Or, you can import a raster image in order to create the background from
it. Adding graphics from an external source can be done by importing.

Imported graphics preserve many of its properties, such as raster or vector format, or color
model. You should remember this because it may be impossible to change those features once
an image is imported. This means that you may need to prepare graphics before importing.

Importing graphics can also influence your work or the final design in a way that you may not
originally expect. For example, you may have a design in which all colors used belong to the
CMYK color model. If you then import an RGB image, you will no longer have a pure CMYK
document. As another example, you may import a photo to serve as a texture or background in
a completely vector design. This can limit the ability to scale up your design without quality loss
because that photo will become pixelated at certain large scales.
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Importing Graphics
To import graphics from a file, select File > Import… from the main menu and choose a file.
Alternatively, you can drag and drop an image from Finder to your document. These methods
can be used with SVG files as well as with other formats such as TIFF, PNG, JPEG, PDF, EPS,
HEIC and AI. Note that EPS is not supported on macOS 14 Sonoma and later.

Raster graphic files that you import appear in your document as a rectangle filled with the
imported image. When you import an image in a vector format such as SVG or PDF, the app
works with it differently.

An imported SVG image becomes a Clipping Group. To access or edit the elements that are
parts of the image, use the Layers Panel. You can also split the Clipping Group into separate
objects. To do that, use the Modify > Release Clipping Mask command from the main menu.

When you import a PDF or EPS, you can see it in your document as one object. To edit it, you
have to split it into parts with help of the Modify > Expand command from the main menu. The
object will turn into a Clipping Group. Then use the Modify > Release Clipping Mask
command.

If you want to fill a shape with an image, open the Color panel and choose the Image tab. Then
select a graphic file. Note that the Color panel does not support the SVG format.
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Importing Multipage PDF Files
The app can import multipage PDF files. You can choose to import one, several or all pages.

Importing the First Page

To import the first page of a multipage PDF, drag the PDF from Finder and drop it into the
canvas in your document. One-page PDFs can be imported in the same way.

You can also import the first page using the Import PDF dialog described below.

Importing Some or All Pages

In order to select pages that you want to import, use one of these ways:

Choose File > Import from the main menu
Drag and drop a file onto the app's icon
Right-click on a PDF file in Finder and select Open With and then Amadine

The app will open the Import PDF dialog where you can select pages. Once done, click the
Import button. Each page will appear on a separate sheet. The sizes of sheets will be the same
as the sizes of pages in the PDF.

If you use the File > Import menu command while a document is open in the app, the PDF
pages will be added to this document. Otherwise, a new document will be created.

The Import PDF Dialog

The dialog helps you select pages that should be imported. The middle of the dialog displays
page previews together with page numbers.
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In order to import the entire PDF, select the All pages option.

To select particular pages, choose Range and then type in page numbers in the text field.
Examples:

1,2,4 - page numbers are separated by commas let you import the listed pages.
1-4 - a range of pages is defined by the numbers of the first and last pages in the range
with hyphen between them.
1,4-6 - a range and separate page number(s) can be used together.
3,2,1 - import the first three pages in the reversed order.

To be able to edit the contents of imported pages, you have to expand them. This can be done
automatically with help of the Expand for editing checkbox. You can expand the pages
manually after importing them. To do that, use the Modify > Expand command in the main
menu. Don't expand pages if you are not going to edit those.
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Exporting Documents

Supported File Formats

You can export your document to the SVG, EPS, PDF, TIFF, PNG and JPEG formats. SVG and
PDF let you export vector graphics that can be scaled without quality loss. SVG, PNG and
JPEG are frequently used for the Web. PDF, EPS and TIFF can be used to send your design to a
print shop. Note that EPS is not supported on macOS 14 Sonoma and later.

Export Your Design

To export the whole document or its part:

1. Select the File > Export… command from the main menu to open the Export dialog.

2. Select a file format at the top.
3. Choose what you want to export using the Export Scope drop-down menu. You can

choose to export the Entire Document, Selection or particular Sheets.
4. Set up the rest of the export settings. They are explained in the Export Dialog section.
5. Click the Export button and type in a file name in order to complete exporting.

There is a shorter way to export a part of your design. Select what you wish to export, right-
click on it, and choose Export Selection… Then follow the procedure above starting at step 4.
Just don't forget to choose an appropriate format.

Another quick way to export your design or its parts is to copy it and paste to another app.
However, note that you have no control over the export options in this case.
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Export Scope

The Export Scope drop-down menu helps you select what part of your design should be
exported. With Entire Document, you will export the entire document (all the sheets if you have
many of them). The Selection option will export a selected object or multiple selected objects. If
you choose Sheets, you can export particular sheets by inputting their numbers. For example,
to export sheets from 2 to 4, you can type either 2-4 or 2, 3, 4 into the Sheets Range field.

The Export Scope also defines the default size of the image that will be exported. If you export
a sheet, the size of the sheet will be used although the contents don't take up all of its space. If
you export a selected object, the object's boundary will define the size of the image. If you
choose to export the entire document, the image size will be set according to the area on the
canvas that includes all sheets together with gaps between them. In such cases, you may get a
huge image if you have several Letter-sized sheets in your document.

Copying Graphics to Another App

You can copy your design to another app or web-based editor instead of exporting it. The
clipboard will contain several copies of the same graphics in the PDF, PNG and SVG formats. If
you paste, the receiving app will choose which of those formats to use.
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The Export Dialog
The Export dialog displays settings for different export formats: JPEG, PDF, EPS, PNG, SVG
and TIFF. Some of the settings are shared between the formats. Note that EPS is not supported
on macOS 14 Sonoma and later.

JPEG

Export Scope: Choose whether to export the entire document or a part of it. The Export
Scope option is described in the Export Scope subsection.

Resolution: Resolution of the output image. You can select one of the predefined options or
type your own value.

Width and Height: Set the absolute size of the output image.

Scale: Set the output image size in relation to the original dimensions. When you change the
Scale, the program shows the corresponding Width and Height.

Quality: Set the output image quality. By decreasing the value, you can have a smaller file, but
the image will preserve less details, and it may have artifacts.
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PDF and EPS

Export Scope: Choose whether to export the entire document or a part of it. The Export
Scope option is described in the Export Scope subsection.

Resolution: Resolution of raster elements of the design. This option doesn't affect vector
elements. You can select one of the predefined options or type your own value.

PNG

Export Scope: Choose whether to export the entire document or a part of it. The Export
Scope option is described in the Export Scope subsection.
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Resolution: Resolution of the output image. You can select one of the predefined options or
type your own value.

Width and Height: Set the absolute size of the output image.

Scale: Set the output image size in relation to the original dimensions. When you change the
Scale, the program shows the corresponding Width and Height.

Transparent Background: Keep transparency in areas that contain no visible objects in your
design. When this option is turned off, a white background is used to fill such areas.

SVG

Export Scope: Choose whether to export the entire document or a part of it. The Export
Scope option is described in the Export Scope subsection.

Resolution: Resolution raster elements of the design. This option doesn't affect vector
elements. You can select one of the predefined options or type your own value.

Unique ID as Object's Name: Use unique IDs for paths, groups, etc. Otherwise, the app
exports the names which were used for naming objects, groups and layers in the Layers panel.
Turning this option on can be useful if you are going to use the exported image for Web
applications.

Text as Curves: Convert text objects to paths. This option lets you avoid issues with missing
fonts. Note that using curves to display text can significantly increase the size of exported files.

Responsive: Create an SVG file in format that better fits responsive web pages.



230

TIFF

Export Scope: Choose whether to export the entire document or a part of it. The Export
Scope option is described in the Export Scope subsection.

Resolution: Resolution of the output image. You can select one of the predefined options or
type your own value.

Width and Height: Set the absolute size of the output image.

Scale: Set the output image size in relation to the original dimensions. When you change the
Scale, the program shows the corresponding Width and Height.

Transparent Background: Keep transparency in areas that contain no visible objects in your
design. When this option is turned off, a white background is used to fill such areas.

LZW Compression: Activate this option to decrease the output file size. Note that not all
software supports compressed images.
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Printing
You can print your design directly from the program. As an alternative, you can export your
document to a graphic file and then print it using any other software.

To print a document:

1. Select the File > Print… command from the main menu to open the Print dialog.
2. If the Print dialog opens in the compact mode, click the Show Details button at the

bottom to make the dialog look like in the following image.

3. Set the Paper Size and Orientation.
4. Make sure that Amadine is selected below the Orientation buttons in order to display the

group of settings that we are going to use. Otherwise, choose Amadine from the drop-
down menu.

5. Set up the Scope. It works similarly to the Export Scope used for exporting.
6. Set up the Scale. Your document can be printed at the Actual Size. If the image is bigger

than the paper sheet, you can fit it to the page by selecting Scale to Fit. The Custom
Scale option lets you choose an arbitrary scale.

7. Click the Print button to start printing.
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Introduction to the Library

Built-in Collection of Objects

The app provides you with a collection of different arrows, signs and so on that you can use in
your designs. All of these images are in vector format. You can edit them with the same tools
that you use for creation of your own graphics.

The objects can be found in the Libraries panel. To open it, select Window > Libraries & Stock
Images > Amadine Libraries in the main menu. Another way is to click on  in the Control
panel and select Amadine Libraries at the top.

Images related to a certain subject area are located in the same category (e.g., Science). Such
categories are also called libraries in the program. Thus you have a library of arrows, a library of
symbols and so on.

Users cannot change the contents of the standard libraries. If you wish to store your own
objects, create a new library.

User's Libraries

The Libraries panel can serve you as a storage for reusable objects created in the app. User's
libraries can store almost any object type from a single path to objects with multiple effects
applied, or groups.

You can create as many libraries as you need. It is possible to add and delete objects from your
libraries. Objects in a user's library can also be reordered. Finally, you can delete a library if it is
not needed any more. All of this you can do with help of the Libraries panel.

Unlike the standard libraries, user's libraries can be exported and imported. This is useful for
sharing a library between multiple users or multiple devices.
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The Libraries Panel
The Libraries panel has two main purposes. It gives you access to a collection of vector images
that you can add to your documents. The panel also lets you store your own objects so that
they can be reused later.

To bring up the panel, select Window > Libraries & Stock Images > Amadine Libraries in the
main menu. Another way is to click on  in the Control panel and select Amadine Libraries at
the top.

1 - Open a built-in library or image stock.

2 - Open the panel's menu.

3 - Choose a library.

4 - Object's preview.

To add a library object to your design, drag the object onto the canvas. Another way is to click
on the object's preview in the library.

Working with Libraries

The menu  lets you manage user's libraries. It is not possible to make any changes in the
standard libraries.

In order to create a new library, select New in the menu and type in a name. If you wish to
change the name, use the Rename command.

To delete a library that is currently displayed in the panel, choose the Delete command from
the menu. Note that the library will be removed together with all objects inside it.

Working with Objects

To add an object to a user's library, select that object on the canvas. Then create or open a
library that should store the object and click on the Add Object command in the panel's menu.
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In order to remove an object from the user's library, bring up the context menu of the object by
right-clicking on it and choose Delete Object.

To reorder objects, drag one of them and drop at a new position in the library.

It is possible to export a user's library to a file that can be imported later on the same or
different device.
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Exporting and Importing Libraries
You can export and import the contents of the user's libraries. This feature lets you create a set
of objects (e.g., components for a design) on one device and then use these objects on another
device to finalize the design. Exporting is also a convenient way to share your object with other
people.

Another use of exporting and importing is the possibility to create a backup copy of your
libraries outside the app.

Exporting

When you export one or all libraries, the app creates an *.amdl file. To import, you need to
provide a file in the same format. This format is supported on all platforms where you can run
the Amadine app.

To export one particular library, choose it in the Libraries panel. Then choose Export in the
menu .

In order to export all of the user's libraries, use the Export All command in the menu of the
panel.

Importing

To import libraries from a file, use the Import command in the panel's menu .

Libraries that you import should appear as separate items in the drop-down list of libraries in
the panel. If you import a library with the same name as one already present in the panel, both
of them will be listed. The program doesn't merge or delete libraries automatically.
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Using Image Stocks
The app can import images from online image stocks directly into your document. The Internet
connection is required for that. The following stocks are supported: Pexels, Pixabay and
Unsplash.

The Libraries panel is used to access the image stocks. To open it, you can use the main menu.
Select Window > Libraries & Stock Images and choose a stock. Another way is to click on 

 in the Control panel in order to bring up the Libraries panel. Then choose a particular
image stock in the upper drop-down menu. By default, the panel displays the built-in image
collection under the Amadine Libraries title.

Type in keywords into the Search box and press Return to find images. The menu button 
lets you filter images by the orientation (e.g., portrait or landscape).

The panel displays previews of images. To add one to your design, drag and drop it. That can
also be done by clicking on a preview.

https://www.pexels.com/
https://pixabay.com/
https://unsplash.com/
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Each image has its author's name at the bottom. You can click on it to open that particular
author's page in your browser.
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