Amadine for macOS Release Notes

To update, use Check for Updates option under Amadine menu.

Users of the Mac App Store version: update in the Store.

What's new in Amadine v1.2.2

  • Bug fixes and performance improvements.

What's new in Amadine v1.2.1

New features:

  • It is now possible to use numbered and bulleted lists in text. In the text settings you can choose the bullet style (number, bullet or letter) and set the distance between the bullet and its text.
  • The Align commands can now work with respect to the edges and center of the sheet (when there's only one object selected).

The Recolor operation:

  • Improved Saturation algorithm—monochrome colors are now brighter.
  • Improved performance for duplicated groups of objects.

Fixes:

  • Draw tool: it is now possible to draw with fills. A corresponding setting was added to the app's Preferences.
  • Lasso tool: anchor and direction points can now be manipulated—it is possible to move them or change their type.
  • Text and images can now be dragged into the program from a web browser and Photos.
  • Automatic scrolling has been disabled when the Draw tool is active.
  • Various interface and usability improvements.

What's new in Amadine v1.2

New features:

  • The Recolor function lets you easily make large color changes to your artwork.
    Available from the Modify menu. Use it to change color of selected shapes by modifying their Hue, Saturation and Brightness. You can change colors manually or merge them. An option to automatically merge similar colors is also available.
  • Importing of files in the AI (Adobe Illustrator) format is now possible.
  • Boolean operation Divide for dividing shapes wherever the lines intersect has been added.

Pen tool:

  • A button for removing selected anchor points added to the toolbar.
  • Double-clicking an anchor point toggles its type between Corner and Smooth.
  • Clicking a Direction point with the Shift or Opt key removes the corresponding Direction line.

Selection tool:

  • In the Edit Segments by Dragging mode, it is now possible to constrain movement by holding the Shift key.
  • Entering the Isolation Mode by double-clicking is possible again.
  • Clicking a Direction point with the Shift or Opt key removes the corresponding Direction line.

Fixes:

  • When moving or duplicating sheets, locked objects are now moved as well (if the Move Artwork with Sheet option is enabled).
  • Fixed the problem when changing the guides color in Settings would take no effect.
  • Changes in the Pencil Pressure profile: Variation and Accuracy settings are now remembered. The default values are set to 60% and 30% respectively.
  • Better raster effects performance.
  • The default font changed to Helvetica.
  • Other bug fixes and usability improvement.

What's new in Amadine v1.1.1

  • Amadine now runs natively on Apple Silicon M1 chip.
  • The Duplicate command now inserts the copy directly over the original shape, without an offset.
  • Minor interface tweaks for macOS 11 Big Sur.

What's new in Amadine v1.1

  • New feature: The Simplify tool for removing unnecessary anchor points without significantly affecting the original path.
  • Fixed an issue where the Edit > Transformations menu commands would not apply when the entire text was selected in a text box.
  • Fixed a problem where Shift and Option keys pressed together would not work properly when resizing shapes.
  • Minor internal improvements.

What's new in Amadine v1.0.9

  • New feature: The Select > Same menu commands can be used to select objects with similar properties—stroke, fill color and other.
  • Texts no longer disappear after expanding imported PDFs.
  • Improves the way the Expand operation is applied to texts that have stoke, fill or other effects.
  • It is now possible to lock/unlock, show/hide selected elements in the Layers panel using the context menu.
  • Some usability improvements in the Layers panel.
  • Arrow keys now always apply to objects selected on the canvas, they can no longer be used to navigate the Inspector.
  • Fixes an issue where text filled with an image would display incorrectly after changing alignment.
  • Fixes a number of bugs where shapes filled with PDF images display incorrectly.
  • Fixes crashes when drawing short lines using a graphic tablet.
  • Fixes some issues where text could display incorrectly when opening a documents.

What's new in Amadine v1.0.8

  • A new text editing engine is now used instead of Apple’s standard editor.
  • Raster images and gradient fills are now preserved after expanding imported PDFs.
  • Improved rendering for Shadow and Glow effects.
  • Text pasted from the Clipboard becomes a regular text instead of scalable text.
  • Objects on hidden layers are no longer displayed in the Outline View.
  • Fixed a crash happening after selecting certain fonts.
  • The Path Width tool now works correctly with the endpoints of a path.
  • Other minor fixes and enhancements.

What's new in Amadine v1.0.7

  • Fixed a number of rendering problems arising after the Expand operation.
  • When exporting to PDF, the Inner Shadow effect is now clipped by the shape’s outline correctly.
  • The Esc key can now be used to exit the Isolation Mode.
  • Fixed a problem with rotating shapes using the Transform operation.
  • Fixed a bug where shapes would change their order after the Knife tool.
  • By holding down the Option key, it’s now possible to cut along a straight line with the Knife tool.
  • Fixed a bug with path segments missing after expanding imported EPS graphics.
  • Tool mode buttons on the Control bar now work correctly in the Full Screen mode.
  • Raster effects DPI settings now apply correctly when exporting documents to vector formats.
  • Text alignment now works properly for distortable text with two or more lines.

What's new in Amadine v1.0.6

  • Fixed the problem with changing colors in the Gradient tool.
  • The Transparent Background option in PNG and TIFF export now works correctly.
  • The Eyedropper tools now works properly with objects inside groups.
  • Improved import from SVG and export to EPS.

What's new in Amadine v1.0.5

  • Improvements in SVG import and export.
  • Fixes a bug with the Make Compound Path command not working.
  • Fixes export of sheets in the Mac App Store version.

What's new in Amadine v1.0.4

  • Resolves a problem with the Color Picker not working properly.
  • Addresses an issue where the text could draw incorrectly in the text editing mode.

What's new in Amadine v1.0.3

  • When opening a document, the program now restores its latest zoom and canvas position.
  • EPS files can be imported as editable vector images.
  • The Effects Quality setting in the Document Settings can be used to adjust on-screen drawing quality for better performance.
  • The Sheets panel now displays sheet numbers along with their names.
  • Exporting of multi-sheet documents has been improved.
  • The arrowhead sizes can be adjusted in a wider range.
  • Invisible shapes and layers are no longer included into PDF export.

What's new in Amadine v1.0.2

  • The Eraser, Scissors and Knife tool can be used with the Shift key for erasing/cutting in a straight line.
  • It is now possible to change an anchor from Corner to Smooth by double-clicking on it.
  • Changes in the Sheets panel: Double-click a sheet's name to change it, or next to the name to switch to that sheet.
  • Changes in the Layers panel: Double-click a name to change it, or next to the name to show the shape on the canvas.
  • The behavior of sliders has been improved.
  • Snapping can be temporarily disabled by holding down the Cmd key when moving a shape.
  • When exporting a document, the document’s name is now used instead of “Untitled”.
  • Holding down the Shift key now increases or decreases a stepper’s value by 10.
  • It is now possible to exit the application using Cmd+Q with the Welcome Window open.
  • The SVG Fill option has been removed from Image Fill options as redundant.
  • Changing stroke width with [ and ] keys now works in all drawing tools (Pen, Rectangle, Rounded Rectangle, Ellipse, Polygon, Star, Line, Arc).
  • Newly added sheets are now centered in the window.
  • In the Sheets tool, the selected sheet can be moved with the arrow keys.
  • When exporting to TIFF and PNG, it is possible to choose between the transparent or white background.
  • When importing from SVG, the image would shift with respect to the canvas – this has been fixed.
  • Fixed an issue where the currently selected tool would reset to Move after switching to another application with the Cmd+Tab shortcut.
  • Fixed an issue with incorrect closing of a path with the Modify > Path > Close command.
  • Fixed a number of bugs related to exporting and Expand operations.

What's new in Amadine v1.0.1

  • Touch Bar controls for the Arc tool have been added.
  • Redesigned Touch Bar controls for the Star and Polygon tools.
  • Constrained movement with Shift now uses 45 degree increments instead of 15 degree.
  • Fixes some memory leaks.
  • Fixes a problem where changing a slider on the Touch Bar would not update the cursor respectively.
  • Other bug fixes and usability improvement.