Drawing

The Appearance Panel

The Appearance panel lets you manage the object's Fill, Stroke and other effects. To open the panel, choose Window > Appearance from the main menu.

Appearance panel

1 - Each line contains one effect, such as Stroke or Shadow.

2 - Hide or show an effect. Uncheck an effect to remove it from the design but still have the ability to easily re-apply it again.

3 - Add an effect. You can choose from a list of all supported effects: Fill, Stroke, Gradient, Brush, Inner Glow, Outer Glow, Inner Shadow, Shadow and Blur.

4 - Add a stroke.

5 - Add a fill.

6 - Change the color.

7 - Show a panel with effect's settings. Some of the settings, such as the color or stroke width, can be accessed from the Appearance panel directly.

8 - Restore the default object's appearance. As a rule, an object will look as it was originally created using a drawing tool.

9 - Delete the selected item.

Changing the Order of Effects

Effects in the Appearance panel are ordered in the same way as they were applied to an object.

Appearance panel with a list of different effects

The arrangement of effects atop one other defines how the object looks on the canvas. Two rectangles below have identical paths, stroke and color fill. The only difference is that the left one has the stroke below the fill. The rectangle on the right has the opposite order of effects. As you can see, when the stroke is behind the color fill, half of the stroke width is invisible, making it look two times thinner.

Appearance panel with a list of different effects Appearance panel with a list of different effects

To change the order of effects, drag one to a new position.

The ability to place certain effects above or below others in the list depends on their type. These types are presented in the Appearance panel as sections separated with lines. Let's see how those types would be arranged if all possible effects were present in the panel at the same time.

The Text entry occupies the top of the list. Then Stroke and Fill would go. You can place Stroke and Fill entries in any order you like, but you cannot place any of them above Text. The rest of the entries such as Shadow and Glow, appear in the bottom section. Again, you can rearrange them within their own section, but placing them into another section is not possible.

The Style of an Object

Any object in your design has particular effects set up in a certain way. We call such a combination of effects "style".

In order to apply exactly the same style to a second object, you can copy this style. To do this, select the first object and choose Edit > Copy Style from the main menu. Then select the second object and use the Edit > Paste Style command. These commands are also available in the context menu which can be opened by right-clicking on an object.