Selecting and Arranging Objects

Select Objects

In order to edit an object or its part, you should select it. Then you can use tools or panels to modify object's properties such as the shape, color, size and others. The program lets you select an object, object's part, or multiple objects using different methods.

If an object is locked, it cannot be selected by any of the methods described below.

Select a Single Object

To select an object, activate the Move tool Move tool, and then click on the object.

As a rule, you should click on a visible part of an object to select it. For example, when a rectangle has a stroke but there is no fill, you should click on the stroke. Clicking inside the rectangle won't select it. On the other hand, if the Fill option is on, you can click anywhere on the rectangle.

Select Multiple Objects

To select several objects, activate the Move tool Move tool, and then click on each of the objects holding down the Shift key.

Another way to select multiple objects it to outline those objects with the selection frame. Click with the Move tool at an empty point and drag the tool. The selection frame will appear between the starting point and the current position of the tool. Make the selection frame big enough to completely or partially outline the objects you want to select.

Select an object with the selection frame

To deselect one of several selected objects keeping the rest of them selected, Shift-click on that object.

To deselect all selected objects, and select all unselected objects, choose Select > Invert Selection (Cmd-AltShift-A).

Select All Objects

To select all objects that are not locked, use either Select > Select All (Cmd-A) or Select > Select All on Active Sheet (Cmd-Alt-A) command from the main menu.

Select Objects with the Lasso Tool

The Lasso tool Lasso tool is used to select multiple objects when other methods are not effective. For example, when objects of interest are surrounded by other objects so closely that the selection frame touches object(s) you don't want to select.

Use the Lasso tool to select objects

Lasso is also used to select multiple anchor points. Those anchor points can be a part of the same or different objects.

Use the Lasso tool to select points

You should drag the tool around objects or anchor points that you want to select.

Select an Object in the Layers Panel

You can select an object by clicking on its name in the Layers panel.

Object selected on the Layers panel

To select multiple objects, click on their names in the Layers panel holding down the Cmd key.

To select multiple objects whose names follow one after another, click on the first name, then press and hold the Shift key, and click on the last name.

Deselect an Object

To deselect one or multiple objects, click with the Move tool Move tool at any empty space on a sheet or on the canvas.

An alternative way is to choose Select > Deselect All (Cmd-Shift-A) from the main menu.

Isolation Mode

The Isolation mode is used to work with a particular object or its part. In this mode, only the isolated object can be edited. The rest of the objects are locked and displayed in dimmed colors. As soon as you deactivate the Isolation mode, those objects will become unlocked.

You can isolate a stand-alone object, an object that is a part of a compound object or group.

To isolate an object, double-click on it. If an object is in a group that itself is a part of another group, click on the object several times until you reach it.

To exit the Isolation mode, hit the Esc key, or click the "X" button in a bar below the horizontal ruler. This bar displays the name of the isolated object. If the isolated object is inside a group, the name of the group will be indicated there.

Indication of the Isolation mode below the ruler

In the Isolation mode, the Layers panel hides the list of layers and objects, and shows the "Isolation Mode" item as the top level object. The isolated object will be one of its subitems directly, or it can be inside of one of nested subitems.

Indication of the Isolation mode in the Layers panel

Select Objects Inside a Group

It is possible to access an object inside a group without ungrouping it. There are two ways to do this. One of them is to use the Isolation Mode discussed earlier.

Another way is to make use of the Layers panel. You should click on a triangle near the name of the group to expand it and show the grouped objects. Then click on the name of the object you want to select.

Select object inside a group using the Layers panel

Locking and Unlocking Objects

Locking an object helps you prevent it from being moved or edited accidentally.

To lock an object, use one of these methods:

Select object inside a group using the Layers panel

To unlock an object, click on its Lock icon in the Layers panel.

To unlock all objects, select Layer > Unlock All (Cmd-Alt-L).